aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wvdial
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/wvdial
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wvdial')
-rw-r--r--recipes/wvdial/wvdial-1.56/fixmakefile.patch11
-rw-r--r--recipes/wvdial/wvdial_1.56.bb19
-rw-r--r--recipes/wvdial/wvdial_1.60.bb17
3 files changed, 47 insertions, 0 deletions
diff --git a/recipes/wvdial/wvdial-1.56/fixmakefile.patch b/recipes/wvdial/wvdial-1.56/fixmakefile.patch
new file mode 100644
index 0000000000..38160e61fd
--- /dev/null
+++ b/recipes/wvdial/wvdial-1.56/fixmakefile.patch
@@ -0,0 +1,11 @@
+--- wvdial-1.56/Makefile~ 2009-01-13 21:03:10.000000000 +0100
++++ wvdial-1.56/Makefile 2009-01-13 21:03:10.000000000 +0100
+@@ -38,7 +38,7 @@
+ ifeq ($(WVSTREAMS_LIB),)
+ LIBUNICONF:=-luniconf
+ endif
+-wvdial wvdialconf papchaptest pppmon: wvdial.a $(LIBUNICONF)
++wvdial wvdialconf papchaptest pppmon: wvdial.a
+
+ install-bin: all
+ [ -d ${BINDIR} ] || install -d ${BINDIR}
diff --git a/recipes/wvdial/wvdial_1.56.bb b/recipes/wvdial/wvdial_1.56.bb
new file mode 100644
index 0000000000..878c6b27a1
--- /dev/null
+++ b/recipes/wvdial/wvdial_1.56.bb
@@ -0,0 +1,19 @@
+HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
+DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
+
+PR = "r1"
+
+LICENSE = "LGPL"
+SRC_URI = "http://www.alumnit.ca/download/wvdial-1.56.tar.gz \
+ file://fixmakefile.patch;patch=1"
+
+DEPENDS = "wvstreams"
+RDEPENDS = "ppp"
+
+EXTRA_OEMAKE = ""
+export WVLINK="${LD}"
+LDFLAGS_append = " -luniconf"
+
+do_install() {
+ oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
+}
diff --git a/recipes/wvdial/wvdial_1.60.bb b/recipes/wvdial/wvdial_1.60.bb
new file mode 100644
index 0000000000..29532b241c
--- /dev/null
+++ b/recipes/wvdial/wvdial_1.60.bb
@@ -0,0 +1,17 @@
+HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
+DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
+
+PR = "r1"
+
+LICENSE = "LGPL"
+SRC_URI = "http://www.alumnit.ca/download/wvdial-1.60.tar.gz"
+
+DEPENDS = "wvstreams"
+RDEPENDS = "ppp"
+
+EXTRA_OEMAKE = ""
+export WVLINK="${LD}"
+
+do_install() {
+ oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
+}