aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wview
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/wview
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wview')
-rw-r--r--recipes/wview/files/Makefile.am.patch24
-rw-r--r--recipes/wview/wview-common.inc39
-rw-r--r--recipes/wview/wview-mysql.inc7
-rw-r--r--recipes/wview/wview-sim-mysql_3.1.3.bb3
-rw-r--r--recipes/wview/wview-sim_3.1.3.bb4
-rw-r--r--recipes/wview/wview-vpro-mysql_3.1.3.bb3
-rw-r--r--recipes/wview/wview-vpro_3.1.3.bb4
-rw-r--r--recipes/wview/wview-wxt510-mysql_3.1.3.bb3
-rw-r--r--recipes/wview/wview-wxt510_3.1.3.bb4
-rw-r--r--recipes/wview/wview.inc2
10 files changed, 93 insertions, 0 deletions
diff --git a/recipes/wview/files/Makefile.am.patch b/recipes/wview/files/Makefile.am.patch
new file mode 100644
index 0000000000..1c35ee8c29
--- /dev/null
+++ b/recipes/wview/files/Makefile.am.patch
@@ -0,0 +1,24 @@
+--- wview-3.1.3/wunderground/Makefile.am.orig 2006-07-01 18:28:45.000000000 +0200
++++ wview-3.1.3/wunderground/Makefile.am 2006-07-01 18:29:23.000000000 +0200
+@@ -9,8 +9,6 @@
+ INCLUDES = \
+ -I$(top_srcdir)/common \
+ -I$(prefix)/include \
+- -I/usr/include \
+- -I/usr/local/include \
+ -D_GNU_SOURCE \
+ -DBUILD_WVWUNDERGROUND
+
+@@ -36,10 +34,10 @@
+ endif
+
+ # define library directories
+-wvwunderd_LDFLAGS = -L/usr/lib -L/usr/local/lib -L$(prefix)/lib
++wvwunderd_LDFLAGS = -L$(prefix)/lib
+
+ if DB_MYSQL
+-wvwunderd_LDFLAGS += -L$(prefix)/lib/mysql -L/usr/lib/mysql
++wvwunderd_LDFLAGS += -L$(prefix)/lib/mysql
+ else
+ if DB_PGRESQL
+ wvwunderd_LDFLAGS += -L$(prefix)/lib -L$(prefix)/pgsql/lib
diff --git a/recipes/wview/wview-common.inc b/recipes/wview/wview-common.inc
new file mode 100644
index 0000000000..c9bdc805b9
--- /dev/null
+++ b/recipes/wview/wview-common.inc
@@ -0,0 +1,39 @@
+SECTION = "apps"
+LICENSE = "GPL"
+DESCRIPTION = "wview is a weather site generator and more for a variety of weather stations"
+HOMEPAGE = "http://www.wviewweather.com/"
+DEPENDS += " bash util-linux gd openssl curl update-rc.d"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wview/wview-${PV}.tar.gz \
+ file://Makefile.am.patch;patch=1"
+
+S = "${WORKDIR}/wview-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF += "--prefix=${D} --enable-wunderground"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}/${sysconfdir}/wview
+ install -d ${D}/${sysconfdir}/wview/html
+ install -d ${D}/${sysconfdir}/wview/alarms
+ install -m 755 ${S}/examples/NSLU2/wview ${D}/${sysconfdir}/init.d
+ install -m 644 ${S}/examples/conf/*.* ${D}/${sysconfdir}/wview
+ install -m 755 ${S}/examples/alarms/*.sh ${D}/${sysconfdir}/wview/alarms
+ install -m 644 ${S}/examples/html/*.* ${D}/${sysconfdir}/wview/html
+
+ install -d ${D}/var/wview
+ install -d ${D}/var/wview/archive
+ install -d ${D}/var/wview/alarms
+ install -d ${D}/var/wview/img
+ install -d ${D}/var/wview/noaa
+ install -m 644 ${S}/bin/img/*.* ${D}/var/wview/img
+
+ if test "x${D}" != "x"; then
+ D="-r ${D}"
+ else
+ D=""
+ fi
+ update-rc.d $D wview defaults 95 15
+}
diff --git a/recipes/wview/wview-mysql.inc b/recipes/wview/wview-mysql.inc
new file mode 100644
index 0000000000..3b9314eafd
--- /dev/null
+++ b/recipes/wview/wview-mysql.inc
@@ -0,0 +1,7 @@
+DEPENDS += " radlib-mysql"
+
+export CFLAGS_append=" -I${STAGING_INCDIR}/mysql "
+export LDFLAGS_append=" -L${STAGING_LIBDIR}/mysql "
+
+EXTRA_OECONF += " --enable-mysql"
+
diff --git a/recipes/wview/wview-sim-mysql_3.1.3.bb b/recipes/wview/wview-sim-mysql_3.1.3.bb
new file mode 100644
index 0000000000..99f2f7ad70
--- /dev/null
+++ b/recipes/wview/wview-sim-mysql_3.1.3.bb
@@ -0,0 +1,3 @@
+require wview-common.inc
+require wview-mysql.inc
+EXTRA_OECONF += " --enable-station-sim"
diff --git a/recipes/wview/wview-sim_3.1.3.bb b/recipes/wview/wview-sim_3.1.3.bb
new file mode 100644
index 0000000000..86ccf00458
--- /dev/null
+++ b/recipes/wview/wview-sim_3.1.3.bb
@@ -0,0 +1,4 @@
+require wview-common.inc
+require wview.inc
+EXTRA_OECONF += " --enable-station-sim"
+PR = "r1"
diff --git a/recipes/wview/wview-vpro-mysql_3.1.3.bb b/recipes/wview/wview-vpro-mysql_3.1.3.bb
new file mode 100644
index 0000000000..f6f63eab3e
--- /dev/null
+++ b/recipes/wview/wview-vpro-mysql_3.1.3.bb
@@ -0,0 +1,3 @@
+require wview-common.inc
+require wview-mysql.inc
+EXTRA_OECONF += " --enable-station-vpro"
diff --git a/recipes/wview/wview-vpro_3.1.3.bb b/recipes/wview/wview-vpro_3.1.3.bb
new file mode 100644
index 0000000000..ae72f6a286
--- /dev/null
+++ b/recipes/wview/wview-vpro_3.1.3.bb
@@ -0,0 +1,4 @@
+require wview-common.inc
+require wview.inc
+EXTRA_OECONF += " --enable-station-vpro"
+PR = "r1"
diff --git a/recipes/wview/wview-wxt510-mysql_3.1.3.bb b/recipes/wview/wview-wxt510-mysql_3.1.3.bb
new file mode 100644
index 0000000000..4e7c712500
--- /dev/null
+++ b/recipes/wview/wview-wxt510-mysql_3.1.3.bb
@@ -0,0 +1,3 @@
+require wview-common.inc
+require wview-mysql.inc
+EXTRA_OECONF += " --enable-station-wxt510"
diff --git a/recipes/wview/wview-wxt510_3.1.3.bb b/recipes/wview/wview-wxt510_3.1.3.bb
new file mode 100644
index 0000000000..0c8bb5b5da
--- /dev/null
+++ b/recipes/wview/wview-wxt510_3.1.3.bb
@@ -0,0 +1,4 @@
+require wview-common.inc
+require wview.inc
+EXTRA_OECONF += " --enable-station-wxt510"
+PR = "r1"
diff --git a/recipes/wview/wview.inc b/recipes/wview/wview.inc
new file mode 100644
index 0000000000..9b2229d699
--- /dev/null
+++ b/recipes/wview/wview.inc
@@ -0,0 +1,2 @@
+DEPENDS += " radlib"
+