aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wvstreams
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/wvstreams
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wvstreams')
-rw-r--r--recipes/wvstreams/files/build-fixes-and-sanity.patch84
-rw-r--r--recipes/wvstreams/files/wvstreams-debian.patch49
-rw-r--r--recipes/wvstreams/wvstreams_4.2.2.bb40
-rw-r--r--recipes/wvstreams/wvstreams_4.4.1.bb38
4 files changed, 211 insertions, 0 deletions
diff --git a/recipes/wvstreams/files/build-fixes-and-sanity.patch b/recipes/wvstreams/files/build-fixes-and-sanity.patch
new file mode 100644
index 0000000000..1571d7b3fe
--- /dev/null
+++ b/recipes/wvstreams/files/build-fixes-and-sanity.patch
@@ -0,0 +1,84 @@
+Index: wvstreams-4.4.1/configure.ac
+===================================================================
+--- wvstreams-4.4.1.orig/configure.ac 2007-08-30 04:47:54.000000000 +0200
++++ wvstreams-4.4.1/configure.ac 2008-04-12 00:15:13.000000000 +0200
+@@ -445,7 +445,6 @@
+ # tcl
+ if test "$with_tcl" != "no"; then
+ CPPFLAGS_save="$CPPFLAGS"
+- WV_APPEND(CPPFLAGS, -I/usr/include/tcl8.3)
+ AC_CHECK_HEADERS(tcl.h,, [with_tcl=no])
+ AC_CHECK_LIB(tcl8.3, TclInterpInit,, [with_tcl=no])
+ if test "$with_tcl" != "no"; then
+Index: wvstreams-4.4.1/Makefile
+===================================================================
+--- wvstreams-4.4.1.orig/Makefile 2007-08-30 04:48:09.000000000 +0200
++++ wvstreams-4.4.1/Makefile 2008-04-12 00:51:51.000000000 +0200
+@@ -76,7 +76,7 @@
+ $(call configure)
+
+ include/wvautoconf.h: include/wvautoconf.h.in
+- $(call configure)
++
+
+ gnulib/Makefile: gnulib/Makefile.in
+ $(call configure)
+@@ -97,9 +97,7 @@
+ @touch $@
+
+ configure: configure.ac include/wvautoconf.h.in aclocal.m4
+- autoconf
+- @rm -f config.mk include/wvautoconf.h gnulib/Makefile
+- @touch $@
++ @echo hey@
+
+ include/wvautoconf.h.in: configure.ac aclocal.m4
+ autoheader
+Index: wvstreams-4.4.1/config.mk.in
+===================================================================
+--- wvstreams-4.4.1.orig/config.mk.in 2007-08-17 07:15:31.000000000 +0200
++++ wvstreams-4.4.1/config.mk.in 2008-04-12 00:25:54.000000000 +0200
+@@ -31,6 +31,7 @@
+
+ prefix=@prefix@
+ datadir=@datadir@
++datarootdir=@datarootdir@
+ includedir=@includedir@
+ infodir=@infodir@
+ localstatedir=@localstatedir@
+Index: wvstreams-4.4.1/vars.mk
+===================================================================
+--- wvstreams-4.4.1.orig/vars.mk 2007-08-17 07:15:31.000000000 +0200
++++ wvstreams-4.4.1/vars.mk 2008-04-12 01:44:03.000000000 +0200
+@@ -174,7 +174,7 @@
+
+ libwvutils.a libwvutils.so: $(filter-out $(BASEOBJS) $(TESTOBJS),$(call objects,utils)) gnulib/libgnu.a
+ libwvutils.so: libwvbase.so
+-libwvutils.so: -lz -lcrypt
++libwvutils.so: LIBS+=-lz -lcrypt
+
+ libwvstreams.a libwvstreams.so: $(filter-out $(BASEOBJS), \
+ $(call objects,configfile crypto ipstreams \
+Index: wvstreams-4.4.1/wvrules.mk
+===================================================================
+--- wvstreams-4.4.1.orig/wvrules.mk 2007-08-17 07:15:31.000000000 +0200
++++ wvstreams-4.4.1/wvrules.mk 2008-04-12 01:00:05.000000000 +0200
+@@ -51,7 +51,7 @@
+ LIBWVTEST=$(WVSTREAMS_LIB)/libwvtest.a $(LIBWVUTILS)
+
+ # Default compiler we use for linking
+-WVLINK_CC = gcc
++WVLINK_CC = $(CC)
+
+ # FIXME: what does this do??
+ XX_LIBS := $(XX_LIBS) $(shell $(CC) -lsupc++ -lgcc_eh 2>&1 | grep -q "undefined reference" && echo " -lsupc++ -lgcc_eh")
+Index: wvstreams-4.4.1/xplc/config/config.mk.in
+===================================================================
+--- wvstreams-4.4.1.orig/xplc/config/config.mk.in 2005-10-31 23:33:26.000000000 +0100
++++ wvstreams-4.4.1/xplc/config/config.mk.in 2008-04-12 00:27:33.000000000 +0200
+@@ -49,4 +49,4 @@
+ LN_S:=@LN_S@
+ LIBS:=@LIBS@
+ CVS2CL:=@CVS2CL@
+-
++datarootdir:=@datarootdir@
diff --git a/recipes/wvstreams/files/wvstreams-debian.patch b/recipes/wvstreams/files/wvstreams-debian.patch
new file mode 100644
index 0000000000..5cb4837955
--- /dev/null
+++ b/recipes/wvstreams/files/wvstreams-debian.patch
@@ -0,0 +1,49 @@
+--- wvstreams.old/include/wvvector.h 2005-11-24 19:46:46.000000000 +0000
++++ wvstreams-4.2.2/include/wvvector.h 2007-07-24 06:35:55.000000000 +0000
+@@ -358,7 +358,7 @@
+ /** Returns a pointer to the current element */
+ T *ptr() const
+ {
+- return static_cast<T *>(cur()->data);
++ return static_cast<T *>(this->cur()->data);
+ }
+
+ WvIterStuff(T);
+@@ -368,7 +368,7 @@
+ */
+ bool get_autofree() const
+ {
+- return link->get_autofree();
++ return this->link->get_autofree();
+ }
+
+ /**
+@@ -376,7 +376,7 @@
+ */
+ void set_autofree(bool autofree)
+ {
+- link->set_autofree(autofree);
++ this->link->set_autofree(autofree);
+ }
+
+ /**
+@@ -386,7 +386,7 @@
+ */
+ void remove(bool destroy = true)
+ {
+- WvVector::vec.remove(i, destroy);
++ WvVector::vec.remove(this->i, destroy);
+ }
+
+ /**
+@@ -404,8 +404,8 @@
+ */
+ void xremove(bool destroy = true)
+ {
+- WvVector::vec.remove(i, destroy);
+- prev();
++ WvVector::vec.remove(this->i, destroy);
++ this->prev();
+ }
+ };
+ };
diff --git a/recipes/wvstreams/wvstreams_4.2.2.bb b/recipes/wvstreams/wvstreams_4.2.2.bb
new file mode 100644
index 0000000000..5d5b0242be
--- /dev/null
+++ b/recipes/wvstreams/wvstreams_4.2.2.bb
@@ -0,0 +1,40 @@
+HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
+LICENSE = "LGPL"
+DESCRIPTION = "WvStreams is a network programming library in C++"
+DEPENDS = "zlib openssl (>= 0.9.8)"
+
+PR = "r1"
+
+SRC_URI = "http://ftp.de.debian.org/debian/pool/main/w/wvstreams/${PN}_${PV}.orig.tar.gz \
+ http://ftp.de.debian.org/debian/pool/main/w/wvstreams/wvstreams_4.2.2-2.2.diff.gz;patch=1 \
+ file://wvstreams-debian.patch;patch=1 \
+ file://build-fixes-and-sanity.patch;patch=1 "
+
+inherit autotools pkgconfig
+
+LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
+
+EXTRA_AUTORECONF += " -I${S}/gnulib/m4"
+EXTRA_OECONF = " --without-tcl --without-qt --without-pam"
+
+PACKAGES_prepend = "libuniconf libuniconf-dbg "
+PACKAGES_prepend = "uniconfd uniconfd-dbg "
+PACKAGES_prepend = "libwvstreams-base libwvstreams-base-dbg "
+PACKAGES_prepend = "libwvstreams-extras libwvstreams-extras-dbg "
+
+FILES_libuniconf = "${libdir}/libuniconf.so.*"
+FILES_libuniconf-dbg = "${libdir}/.debug/libuniconf.so.*"
+
+FILES_uniconfd = "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
+FILES_uniconfd-dbg = "${sbindir}/.debug/uniconfd"
+
+FILES_libwvstreams-base = "${libdir}/libwvutils.so.*"
+FILES_libwvstreams-base-dbg = "${libdir}/.debug/libwvutils.so.*"
+
+FILES_libwvstreams-extras = "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
+FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debug/libwvstreams.so.*"
+
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/wvstreams/wvstreams_4.4.1.bb b/recipes/wvstreams/wvstreams_4.4.1.bb
new file mode 100644
index 0000000000..8cf1d1b5eb
--- /dev/null
+++ b/recipes/wvstreams/wvstreams_4.4.1.bb
@@ -0,0 +1,38 @@
+HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
+LICENSE = "LGPL"
+DESCRIPTION = "WvStreams is a network programming library in C++"
+DEPENDS = "zlib openssl (>= 0.9.8)"
+
+PR = "r2"
+
+SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
+ file://build-fixes-and-sanity.patch;patch=1 "
+
+inherit autotools pkgconfig
+
+LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
+
+EXTRA_AUTORECONF += " -I${S}/gnulib/m4"
+EXTRA_OECONF = " --without-tcl --without-qt --without-pam"
+
+PACKAGES_prepend = "libuniconf libuniconf-dbg "
+PACKAGES_prepend = "uniconfd uniconfd-dbg "
+PACKAGES_prepend = "libwvstreams-base libwvstreams-base-dbg "
+PACKAGES_prepend = "libwvstreams-extras libwvstreams-extras-dbg "
+
+FILES_libuniconf = "${libdir}/libuniconf.so.*"
+FILES_libuniconf-dbg = "${libdir}/.debug/libuniconf.so.*"
+
+FILES_uniconfd = "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
+FILES_uniconfd-dbg = "${sbindir}/.debug/uniconfd"
+
+FILES_libwvstreams-base = "${libdir}/libwvutils.so.*"
+FILES_libwvstreams-base-dbg = "${libdir}/.debug/libwvutils.so.*"
+
+FILES_libwvstreams-extras = "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
+FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debug/libwvstreams.so.*"
+
+
+do_stage() {
+ autotools_stage_all
+}