aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wwwoffle
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/wwwoffle
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/wwwoffle')
-rw-r--r--recipes/wwwoffle/files/wwwoffle.if-down4
-rw-r--r--recipes/wwwoffle/files/wwwoffle.if-up36
-rw-r--r--recipes/wwwoffle/files/wwwoffle.init22
-rw-r--r--recipes/wwwoffle/wwwoffle_2.9c.bb31
4 files changed, 93 insertions, 0 deletions
diff --git a/recipes/wwwoffle/files/wwwoffle.if-down b/recipes/wwwoffle/files/wwwoffle.if-down
new file mode 100644
index 0000000000..71721c38d5
--- /dev/null
+++ b/recipes/wwwoffle/files/wwwoffle.if-down
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+/usr/bin/wwwoffle -offline &
+exit
diff --git a/recipes/wwwoffle/files/wwwoffle.if-up b/recipes/wwwoffle/files/wwwoffle.if-up
new file mode 100644
index 0000000000..43167a9e9c
--- /dev/null
+++ b/recipes/wwwoffle/files/wwwoffle.if-up
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+# We want to run wwwoffle only for selected interfaces:
+# Maybe better would be checking of the default route.
+case "$IFACE" in
+ wlan*)
+ ;;
+ eth*)
+ ;;
+ usb*)
+ ;;
+ ppp*)
+ ;;
+ *)
+ exit 0
+ ;;
+esac
+
+# wwwoffle caches old network configuration and it may cause resolve failures
+/usr/bin/wwwoffle -kill
+/usr/sbin/wwwoffled >/dev/null 2>&1
+
+/usr/bin/wwwoffle -online
+
+# Don't fetch over ppp*, which is typically expensive dial-up.
+# Comment out, if you want to fetch pre-ordered pages over GPRS, dial-up or so.
+case "$IFACE" in
+ ppp*)
+ exit 0
+ ;;
+esac
+
+# Fetch may take longer time. Run it in background
+( /usr/bin/wwwoffle -fetch ) &
+
+exit
diff --git a/recipes/wwwoffle/files/wwwoffle.init b/recipes/wwwoffle/files/wwwoffle.init
new file mode 100644
index 0000000000..7eac239a3e
--- /dev/null
+++ b/recipes/wwwoffle/files/wwwoffle.init
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ /usr/sbin/wwwoffled
+ ;;
+restart)
+ /usr/bin/wwwoffle -kill
+ /usr/sbin/wwwoffled >/dev/null 2>&1
+ ;;
+reload|force-reload)
+ /usr/bin/wwwoffle -config
+ ;;
+stop)
+ /usr/bin/wwwoffle -kill
+ ;;
+*)
+ echo "Usage: /etc/init.d/wwwoffle {start|stop|restart|reload|force-reload}"
+ exit 1
+esac
+
+exit 0
diff --git a/recipes/wwwoffle/wwwoffle_2.9c.bb b/recipes/wwwoffle/wwwoffle_2.9c.bb
new file mode 100644
index 0000000000..c280e7c8a9
--- /dev/null
+++ b/recipes/wwwoffle/wwwoffle_2.9c.bb
@@ -0,0 +1,31 @@
+LICENSE = "GPL"
+SECTION = "console/network"
+PRIORITY = "standard"
+DESCRIPTION = "World Wide Web Offline Explorer"
+DEPENDS = ""
+
+SRC_URI = "http://www.gedanken.demon.co.uk/download-wwwoffle/${PN}-${PV}.tgz \
+ file://wwwoffle.init \
+ file://wwwoffle.if-up \
+ file://wwwoffle.if-down"
+
+INITSCRIPT_NAME = "${PN}"
+
+inherit autotools gettext update-rc.d
+
+EXTRA_OEMAKE = "docdir=${datadir}/doc"
+
+do_configure() {
+ pwd
+ mv aclocal.m4 acinclude.m4
+ autotools_do_configure
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/network/if-up.d
+ install -m 755 ${WORKDIR}/wwwoffle.if-up ${D}/${sysconfdir}/network/if-up.d/wwwoffle
+ install -d ${D}/${sysconfdir}/network/if-down.d
+ install -m 755 ${WORKDIR}/wwwoffle.if-down ${D}/${sysconfdir}/network/if-down.d/wwwoffle
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/wwwoffle.init ${D}/${sysconfdir}/init.d/wwwoffle
+}