aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xawtv
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xawtv
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xawtv')
-rw-r--r--recipes/xawtv/xawtv-3.93/make.patch147
-rw-r--r--recipes/xawtv/xawtv_3.93.bb31
2 files changed, 178 insertions, 0 deletions
diff --git a/recipes/xawtv/xawtv-3.93/make.patch b/recipes/xawtv/xawtv-3.93/make.patch
new file mode 100644
index 0000000000..481e945bea
--- /dev/null
+++ b/recipes/xawtv/xawtv-3.93/make.patch
@@ -0,0 +1,147 @@
+--- tmp/base/xawtv-3.93-r0/xawtv-3.93/common/Subdir.mk 2003-02-14 09:14:04.000000000 -0500
++++ xawtv-3.93/common/Subdir.mk 2004-06-08 16:50:35.382555000 -0400
+@@ -17,7 +17,7 @@
+
+ # RegEdit.c is good old K&R ...
+ common/RegEdit.o: CFLAGS += -Wno-missing-prototypes -Wno-strict-prototypes
+-common/channel-no-x11.o: CFLAGS += -DNO_X11=1
++common/channel-no-x11.o: DEFS += -DNO_X11=1
+
+ common/channel-no-x11.o: common/channel.c
+ @$(echo_compile_c)
+--- tmp/base/xawtv-3.93-r0/xawtv-3.93/configure.ac 2004-03-10 11:34:37.000000000 -0500
++++ xawtv-3.93/configure.ac 2004-06-08 17:01:42.023414000 -0400
+@@ -150,6 +150,12 @@
+ ATHENA=""
+ FSLIB=""
+ fi
++if test "x$x_includes" = "x"; then
++ x_includes=/usr/X11R6/include
++fi
++if test "x$x_libraries" = "x"; then
++ x_libraries=/usr/X11R6/lib
++fi
+ AC_SUBST(X_CFLAGS)
+ AC_SUBST(X_PRE_LIBS)
+ AC_SUBST(X_EXTRA_LIBS)
+--- tmp/base/xawtv-3.93-r0/xawtv-3.93/console/Subdir.mk 2003-02-14 09:14:04.000000000 -0500
++++ xawtv-3.93/console/Subdir.mk 2004-06-08 16:54:22.296488000 -0400
+@@ -84,11 +84,11 @@
+ console/v4l-conf : LDLIBS += $(ATHENA_LIBS)
+
+ # linker flags
+-console/fbtv : LDFLAGS := $(DLFLAGS)
+-console/ttv : LDFLAGS := $(DLFLAGS)
+-console/scantv : LDFLAGS := $(DLFLAGS)
+-console/streamer : LDFLAGS := $(DLFLAGS)
+-console/webcam : LDFLAGS := $(DLFLAGS)
++console/fbtv : LDLIBS += $(DLFLAGS)
++console/ttv : LDLIBS += $(DLFLAGS)
++console/scantv : LDLIBS += $(DLFLAGS)
++console/streamer : LDLIBS += $(DLFLAGS)
++console/webcam : LDLIBS += $(DLFLAGS)
+
+ # global targets
+ all:: $(TARGETS-console) $(TARGETS-v4l-conf)
+--- tmp/base/xawtv-3.93-r0/xawtv-3.93/libng/contrib-plugins/Subdir.mk 2003-02-14 09:14:05.000000000 -0500
++++ xawtv-3.93/libng/contrib-plugins/Subdir.mk 2004-06-08 16:53:10.545928000 -0400
+@@ -18,7 +18,7 @@
+
+ # linear-blend has mmx support ...
+ ifeq ($(USE_MMX),yes)
+-libng/contrib-plugins/linear-blend.so : CFLAGS += -DMMX=1
++libng/contrib-plugins/linear-blend.so : DEFS += -DMMX=1
+ endif
+
+ # global targets
+--- tmp/base/xawtv-3.93-r0/xawtv-3.93/Makefile.in 2004-04-22 10:52:29.000000000 -0400
++++ xawtv-3.93/Makefile.in 2004-06-08 17:06:40.828711000 -0400
+@@ -28,12 +28,13 @@
+
+ # for CFLAGS
+ WARN_FLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes -Wpointer-arith
+-LFS_FLAGS := -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+-X11_FLAGS := @X_CFLAGS@ @XFT_FLAGS@ -I/usr/X11R6/include/X11/fonts
+-LIB_FLAGS := -I. -I./vbistuff -I./x11 \
++LFS_DEFS := -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++X11_DEFS := @X_CFLAGS@ @XFT_FLAGS@ -I@x_includes@/X11/fonts -I@x_includes@/X11/FS
++LIB_DEFS := -I. -I./vbistuff -I./x11 \
+ -I$(srcdir)/jwz -I$(srcdir)/common -I$(srcdir)/console \
+ -I$(srcdir)/x11 -I$(srcdir)/structs \
+- -I$(srcdir)/libng -Llibng
++ -I$(srcdir)/libng
++LIB_LIBS := -Llibng
+
+ # various libraries
+ ATHENA_LIBS := @X_LIBS@ @XFT_LIBS@ @LIBS@ @ATHENA@
+@@ -67,24 +68,25 @@
+ # build final cflags
+ CFLAGS := @CFLAGS@
+ CFLAGS += $(WARN_FLAGS)
+-CFLAGS += $(LFS_FLAGS)
+-CFLAGS += $(X11_FLAGS)
+-CFLAGS += $(LIB_FLAGS)
+-CFLAGS += -DCONFIGFILE='"$(config)"'
+-CFLAGS += -DLIBDIR='"$(libdir)"'
+-CFLAGS += -DDATADIR='"$(datadir)"'
+-CFLAGS += -DVERSION='"$(VERSION)"'
++DEFS += $(LFS_DEFS)
++DEFS += $(X11_DEFS)
++DEFS += $(LIB_DEFS)
++DEFS += -DCONFIGFILE='"$(config)"'
++DEFS += -DLIBDIR='"$(libdir)"'
++DEFS += -DDATADIR='"$(datadir)"'
++DEFS += -DVERSION='"$(VERSION)"'
+ CXXFLAGS := $(CFLAGS)
+
+ # for gcc3
+ #CFLAGS += -std-gnu99
+
+ # shared objects need -fPIC
+-%.so : CFLAGS += -fPIC
+-%.so : CXXFLAGS += -fPIC
++%.so : DEFS += -fPIC
+
+ # libraries
++LDFLAGS := @LDFLAGS@
+ LDLIBS := @LDLIBS@
++LDLIBS += $(LIB_LIBS)
+
+
+ #########################################################
+--- tmp/base/xawtv-3.93-r0/xawtv-3.93/mk/Compile.mk 2003-02-14 09:14:08.000000000 -0500
++++ xawtv-3.93/mk/Compile.mk 2004-06-08 16:53:52.030861000 -0400
+@@ -20,8 +20,8 @@
+ depfile = mk/$(subst /,_,$*).dep
+ depfiles = mk/*.dep
+
+-compile_c = $(CC) $(CFLAGS) -Wp,-MD,$(tmpdep) -c -o $@ $<
+-compile_cc = $(CXX) $(CXXFLAGS) -Wp,-MD,$(tmpdep) -c -o $@ $<
++compile_c = $(CC) $(CFLAGS) $(DEFS) -Wp,-MD,$(tmpdep) -c -o $@ $<
++compile_cc = $(CXX) $(CXXFLAGS) $(DEFS) -Wp,-MD,$(tmpdep) -c -o $@ $<
+ fixup_deps = sed -e "s|.*\.o:|$@:|" < $(tmpdep) > $(depfile) && rm -f $(tmpdep)
+
+ link_app = $(CC) $(LDFLAGS) -o $@ $^ $(LDLIBS)
+--- tmp/base/xawtv-3.93-r0/xawtv-3.93/x11/Subdir.mk 2004-01-12 12:56:17.000000000 -0500
++++ xawtv-3.93/x11/Subdir.mk 2004-06-08 16:53:36.097733000 -0400
+@@ -110,14 +110,14 @@
+ x11/propwatch : LDLIBS += $(ATHENA_LIBS)
+
+ # linker flags
+-x11/xawtv : LDFLAGS := $(DLFLAGS)
+-x11/motv : LDFLAGS := $(DLFLAGS)
+-x11/v4lctl : LDFLAGS := $(DLFLAGS)
+-x11/pia : LDFLAGS := $(DLFLAGS)
++x11/xawtv : LDLIBS += $(DLFLAGS)
++x11/motv : LDLIBS += $(DLFLAGS)
++x11/v4lctl : LDLIBS += $(DLFLAGS)
++x11/pia : LDLIBS += $(DLFLAGS)
+
+ # compile flags
+-x11/complete-xaw.o : CFLAGS += -DATHENA=1
+-x11/complete-motif.o : CFLAGS += -DMOTIF=1
++x11/complete-xaw.o : DEFS += -DATHENA=1
++x11/complete-motif.o : DEFS += -DMOTIF=1
+
+
+ # i18n
diff --git a/recipes/xawtv/xawtv_3.93.bb b/recipes/xawtv/xawtv_3.93.bb
new file mode 100644
index 0000000000..75bfa71e6d
--- /dev/null
+++ b/recipes/xawtv/xawtv_3.93.bb
@@ -0,0 +1,31 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+DESCRIPTION = "XawTV is a simple Xaw-based TV program which uses the bttw \
+driver or video4linux. It also contains various command-line utilities for \
+grabbing images and AVI movies, tuning in TV stations, etc."
+DEPENDS = "libxaw libxmu libxt libxpm libxext virtual/libx11 ncurses libxft fs jpeg"
+
+SRC_URI = "http://dl.bytesex.org/releases/xawtv/xawtv-${PV}.tar.gz \
+ file://make.patch;patch=1"
+S = "${WORKDIR}/xawtv-${PV}"
+
+inherit autotools
+
+# FIXME: libXaw needs a full x11, not diet
+BROKEN = "1"
+
+EXTRA_OECONF = "--disable-xfree-ext \
+ --disable-xvideo \
+ --disable-lirc \
+ --disable-quicktime \
+ --disable-motif \
+ --disable-aa \
+ --disable-alsa \
+ --disable-zvbi \
+ --disable-gl \
+ --disable-dv \
+ --disable-mmx \
+ --enable-xft \
+ --x-includes=${STAGING_INCDIR} \
+ --x-libraries=${STAGING_LIBDIR}"
+EXTRA_OEMAKE += " 'verbose=yes'"