aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xcalibrate
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xcalibrate
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xcalibrate')
-rw-r--r--recipes/xcalibrate/xcalibrate/xextproto.patch11
-rw-r--r--recipes/xcalibrate/xcalibrate_20060312.bb17
-rw-r--r--recipes/xcalibrate/xcalibrate_cvs.bb16
-rw-r--r--recipes/xcalibrate/xcalibrate_git.bb16
4 files changed, 60 insertions, 0 deletions
diff --git a/recipes/xcalibrate/xcalibrate/xextproto.patch b/recipes/xcalibrate/xcalibrate/xextproto.patch
new file mode 100644
index 0000000000..cb190c073b
--- /dev/null
+++ b/recipes/xcalibrate/xcalibrate/xextproto.patch
@@ -0,0 +1,11 @@
+--- XCalibrate/configure.ac.orig 2006-03-08 14:57:07.000000000 +0100
++++ XCalibrate/configure.ac 2006-03-08 14:57:14.000000000 +0100
+@@ -7,7 +7,7 @@
+ AC_PROG_LIBTOOL
+
+ # Check for X
+-PKG_CHECK_MODULES(XCALIBRATE, x11 xextensions xcalibrateext)
++PKG_CHECK_MODULES(XCALIBRATE, x11 xextproto xcalibrateext)
+
+ AC_OUTPUT([Makefile
+ xcalibrate.pc])
diff --git a/recipes/xcalibrate/xcalibrate_20060312.bb b/recipes/xcalibrate/xcalibrate_20060312.bb
new file mode 100644
index 0000000000..a5855dff08
--- /dev/null
+++ b/recipes/xcalibrate/xcalibrate_20060312.bb
@@ -0,0 +1,17 @@
+PV = "0.0+cvs${FIXEDSRCDATE}"
+FIXEDSRCDATE = "${@bb.data.getVar('FILE', d, 1).split('_')[-1].split('.')[0]}"
+LICENSE = "BSD-X"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11 xcalibrateext libxext"
+DESCRIPTION = "XCalibrate client-side library"
+
+SRC_URI = "${FREEDESKTOP_CVS}/xlibs;module=XCalibrate \
+ file://xextproto.patch;patch=1"
+S = "${WORKDIR}/XCalibrate"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/xcalibrate/xcalibrate_cvs.bb b/recipes/xcalibrate/xcalibrate_cvs.bb
new file mode 100644
index 0000000000..c3eeffc478
--- /dev/null
+++ b/recipes/xcalibrate/xcalibrate_cvs.bb
@@ -0,0 +1,16 @@
+PV = "0.0+cvs${SRCDATE}"
+LICENSE = "BSD-X"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11 xcalibrateext libxext"
+DESCRIPTION = "XCalibrate client-side library"
+
+SRC_URI = "${FREEDESKTOP_CVS}/xlibs;module=XCalibrate \
+ file://xextproto.patch;patch=1"
+S = "${WORKDIR}/XCalibrate"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/xcalibrate/xcalibrate_git.bb b/recipes/xcalibrate/xcalibrate_git.bb
new file mode 100644
index 0000000000..aba693ad6c
--- /dev/null
+++ b/recipes/xcalibrate/xcalibrate_git.bb
@@ -0,0 +1,16 @@
+LICENSE = "BSD-X"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11 xcalibrateext libxext"
+DESCRIPTION = "XCalibrate client-side library"
+
+PV = "0.0+git4be232e30cd33a44a1ce6d3ec429ee6101540c62"
+
+SRC_URI = "git://anongit.freedesktop.org/git/xorg/lib/libXCalibrate;protocol=git;tag=4be232e30cd33a44a1ce6d3ec429ee6101540c62"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}