aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xcb
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2009-06-12 19:32:21 +0100
committerPhil Blundell <philb@gnu.org>2009-06-12 19:32:21 +0100
commit6c47b3e373477fe5037b4d54b25a5d22e3d4a654 (patch)
tree694e6feef5d5ba7e5eaeebfb9c42ad6af5317c75 /recipes/xcb
parent1e02d5cf1d61d399f765a1bc971a77443afa7f67 (diff)
downloadopenembedded-6c47b3e373477fe5037b4d54b25a5d22e3d4a654.tar.gz
libxcb: look for xproto.xml in staging, not in the host environment
Diffstat (limited to 'recipes/xcb')
-rw-r--r--recipes/xcb/libxcb.inc5
-rw-r--r--recipes/xcb/libxcb/configure.patch11
2 files changed, 15 insertions, 1 deletions
diff --git a/recipes/xcb/libxcb.inc b/recipes/xcb/libxcb.inc
index 6e7bd5edec..4029decb05 100644
--- a/recipes/xcb/libxcb.inc
+++ b/recipes/xcb/libxcb.inc
@@ -7,7 +7,8 @@ PARALLEL_MAKE = ""
DEPENDS = "xcb-proto xproto libxau libxslt-native"
# DEPENDS += "xsltproc-native gperf-native"
-SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2"
+SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
+ file://configure.patch;patch=1;pnum=0"
PACKAGES =+ "libxcb-composite libxcb-damage libxcb-dpms libxcb-glx \
libxcb-randr libxcb-record libxcb-render libxcb-res \
@@ -41,6 +42,8 @@ FILES_libxcb-xvmc = "${libdir}/libxcb-xvmc.so.*"
inherit autotools pkgconfig
+EXTRA_OECONF = "STAGING_DIR=${STAGING_DIR_HOST}"
+
do_stage() {
autotools_stage_all
}
diff --git a/recipes/xcb/libxcb/configure.patch b/recipes/xcb/libxcb/configure.patch
new file mode 100644
index 0000000000..2e397718d4
--- /dev/null
+++ b/recipes/xcb/libxcb/configure.patch
@@ -0,0 +1,11 @@
+--- configure.ac~ 2006-11-23 15:33:01.000000000 +0000
++++ configure.ac 2009-06-12 19:10:47.000000000 +0100
+@@ -50,7 +50,7 @@
+
+ # Find the xcb-proto protocol descriptions
+ AC_MSG_CHECKING(XCBPROTO_XCBINCLUDEDIR)
+-XCBPROTO_XCBINCLUDEDIR=`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
++XCBPROTO_XCBINCLUDEDIR=${STAGING_DIR}`$PKG_CONFIG --variable=xcbincludedir xcb-proto`
+ AC_MSG_RESULT($XCBPROTO_XCBINCLUDEDIR)
+ AC_SUBST(XCBPROTO_XCBINCLUDEDIR)
+