summaryrefslogtreecommitdiffstats
path: root/recipes/xdelta
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2010-10-22 17:31:07 -0400
committerMichael Smith <msmith@cbnco.com>2010-10-22 17:36:19 -0400
commit117024cefa6d38753e3094b964b077aa7c0ce17f (patch)
tree70ab6759b157954b8196a67723e5aea377825306 /recipes/xdelta
parent0770548c90b819a90bdf74f98664966c75bd5326 (diff)
downloadopenembedded-117024cefa6d38753e3094b964b077aa7c0ce17f.tar.gz
xdelta 3.0z: add
Signed-off-by: Michael Smith <msmith@cbnco.com> Cc: Sergei Frankoff <sfrankoff@cbnco.com>
Diffstat (limited to 'recipes/xdelta')
-rw-r--r--recipes/xdelta/xdelta_3.0z.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/xdelta/xdelta_3.0z.bb b/recipes/xdelta/xdelta_3.0z.bb
new file mode 100644
index 0000000000..2ee3f3d615
--- /dev/null
+++ b/recipes/xdelta/xdelta_3.0z.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "utilities for creating binary deltas"
+LICENSE = "GPLv2+"
+PR = "r0"
+SRC_URI = "http://xdelta.googlecode.com/files/xdelta${PV}.tar.gz"
+
+S = "${WORKDIR}/${PN}${PV}"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/xdelta3 ${D}${bindir}/xdelta3
+}
+
+SRC_URI[md5sum] = "2b5b3c33438cff581ce5c12d66c28b6c"
+SRC_URI[sha256sum] = "5504b25eb21c743a651367976b40655ea874603976d83fd50ea8a3ef8725f3e6"