aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xdiskusage
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xdiskusage
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xdiskusage')
-rw-r--r--recipes/xdiskusage/files/running_from_menu.patch14
-rw-r--r--recipes/xdiskusage/files/xdiskusage.desktop10
-rw-r--r--recipes/xdiskusage/files/xdiskusage.pngbin0 -> 312 bytes
-rw-r--r--recipes/xdiskusage/xdiskusage_1.48.bb26
4 files changed, 50 insertions, 0 deletions
diff --git a/recipes/xdiskusage/files/running_from_menu.patch b/recipes/xdiskusage/files/running_from_menu.patch
new file mode 100644
index 0000000000..7d0c08ee37
--- /dev/null
+++ b/recipes/xdiskusage/files/running_from_menu.patch
@@ -0,0 +1,14 @@
+--- a/xdiskusage.C 29 Sep 2004 07:32:12 -0000 1.20
++++ b/xdiskusage.C 13 Oct 2004 03:20:26 -0000 1.21
+@@ -261,7 +261,8 @@
+ OutputWindow* d = OutputWindow::make(argv[n++]);
+ if (d) d->show(argc,argv);
+ }
+- } else if (!isatty(0)) {
++ } else if (!isatty(0) && (n=getc(stdin))>=0) {
++ ungetc(n,stdin);
+ // test for pipe, if so read stdin:
+ OutputWindow* d = OutputWindow::make(0);
+ if (d) d->show(argc,argv);
+
+
diff --git a/recipes/xdiskusage/files/xdiskusage.desktop b/recipes/xdiskusage/files/xdiskusage.desktop
new file mode 100644
index 0000000000..ab4d2fd901
--- /dev/null
+++ b/recipes/xdiskusage/files/xdiskusage.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=XDiskUsage
+GenericName=Disk Usage
+Comment=Utility showing disk usage
+Type=Application
+Exec=xdiskusage
+Icon=xdiskusage
+Categories=System;Filesystem;
+Terminal=false
+
diff --git a/recipes/xdiskusage/files/xdiskusage.png b/recipes/xdiskusage/files/xdiskusage.png
new file mode 100644
index 0000000000..43b1924ed6
--- /dev/null
+++ b/recipes/xdiskusage/files/xdiskusage.png
Binary files differ
diff --git a/recipes/xdiskusage/xdiskusage_1.48.bb b/recipes/xdiskusage/xdiskusage_1.48.bb
new file mode 100644
index 0000000000..baac5f88a3
--- /dev/null
+++ b/recipes/xdiskusage/xdiskusage_1.48.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Xdiskusage shows graphically what is using up your disk space"
+AUTHOR = "Bill Spitzak"
+HOMEPAGE = "http://xdiskusage.sourceforge.net/"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "fltk"
+
+SRC_URI = "http://xdiskusage.sourceforge.net/xdiskusage-${PV}.tgz \
+ file://running_from_menu.patch;patch=1 \
+ file://xdiskusage.desktop \
+ file://xdiskusage.png"
+
+EXTRA_OEMAKE = "CXXFLAGS="${CXXFLAGS} `fltk-config --cxxflags`" \
+ LDLIBS="`fltk-config --ldflags`""
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -d ${D}/${mandir}/man1
+ install -d ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0755 ${S}/xdiskusage ${D}/${bindir}/
+ install -m 0644 ${S}/xdiskusage.1 ${D}/${mandir}/man1/
+ install -m 0644 ${WORKDIR}/xdiskusage.desktop ${D}/${datadir}/applications/
+ install -m 0644 ${WORKDIR}/xdiskusage.png ${D}/${datadir}/pixmaps/
+}