aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xerces-c
diff options
context:
space:
mode:
authorBernhard Guillon <Bernhard.Guillon@opensimpad.org>2011-05-19 22:55:12 +0200
committerBernhard Guillon <Bernhard.Guillon@opensimpad.org>2011-05-19 22:55:12 +0200
commitfefa244bbbd672126e73aabb2fe674bf0b5ac6f7 (patch)
treea6a094d1e3bfe0116a14d3f0c7858410840890ff /recipes/xerces-c
parent73ff7347f48c8d8d1c5d2e7fc55cc86054716d99 (diff)
downloadopenembedded-fefa244bbbd672126e73aabb2fe674bf0b5ac6f7.tar.gz
xerces-c: add version 3.1.1, change license to Apache-2.0
Signed-off-by: Bernhard Guillon <Bernhard.Guillon@opensimpad.org>
Diffstat (limited to 'recipes/xerces-c')
-rw-r--r--recipes/xerces-c/xerces-c_3.1.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/xerces-c/xerces-c_3.1.1.bb b/recipes/xerces-c/xerces-c_3.1.1.bb
new file mode 100644
index 0000000000..46ec6d28ab
--- /dev/null
+++ b/recipes/xerces-c/xerces-c_3.1.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Xerces-c is a validating xml parser written in C++"
+HOMEPAGE = "http://xerces.apache.org/xerces-c/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "Apache-2.0"
+
+SRC_URI = "http://apache.lauf-forum.at/xerces/c/3/sources/${BP}.tar.gz"
+
+inherit autotools pkgconfig
+
+PACKAGES = "libxerces-c \
+ libxerces-c-dbg \
+ libxerces-c-dev \
+ xerces-c-samples \
+ xerces-c-samples-dbg \
+"
+
+FILES_libxerces-c = "${libdir}/libxerces-c-3.1.so"
+FILES_libxerces-c-dbg = "${libdir}/.debug/"
+FILES_libxerces-c-dev = "${libdir}/lib*.la \
+ ${libdir}/lib*.a \
+ ${libdir}/libxerces-c.so \
+ ${libdir}/pkgconfig/xerces-c.pc \
+ ${includedir}/xercesc \
+"
+FILES_xerces-c-samples = "${bindir}/*"
+FILES_xerces-c-samples-dbg = "${bindir}/.debug/"
+
+SRC_URI[md5sum] = "6a8ec45d83c8cfb1584c5a5345cb51ae"
+SRC_URI[sha256sum] = "a42785f71e0b91d5fd273831c87410ce60a73ccfdd207de1b805d26d44968736"
+
+BBCLASSEXTEND += "native"