aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfsprogs
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xfsprogs
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xfsprogs')
-rw-r--r--recipes/xfsprogs/libattr_2.4.43.bb27
-rw-r--r--recipes/xfsprogs/xfsprogs_2.8.16.bb24
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes/xfsprogs/libattr_2.4.43.bb b/recipes/xfsprogs/libattr_2.4.43.bb
new file mode 100644
index 0000000000..99890313f5
--- /dev/null
+++ b/recipes/xfsprogs/libattr_2.4.43.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "library functions to get attribute bits"
+HOMEPAGE = "http://oss.sgi.com/projects/xfs"
+LICENSE = "GPL"
+SECTION = "base"
+PR = "r0"
+DEPENDS = "gettext"
+
+SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/attr_${PV}-1.tar.gz"
+S = "${WORKDIR}/attr-${PV}"
+
+PARALLEL_MAKE = ""
+inherit autotools
+EXTRA_OECONF = "--enable-gettext=no --enable-shared=yes"
+
+do_configure () {
+ export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
+ export DEBUG="-DNDEBUG"
+ oe_runconf
+}
+
+do_install () {
+ export DIST_ROOT=${D}
+ oe_runmake install
+ oe_libinstall -a libattr ${D}${libdir}
+ oe_libinstall -a libattr ${STAGING_LIBDIR}
+}
+
diff --git a/recipes/xfsprogs/xfsprogs_2.8.16.bb b/recipes/xfsprogs/xfsprogs_2.8.16.bb
new file mode 100644
index 0000000000..13c96eade3
--- /dev/null
+++ b/recipes/xfsprogs/xfsprogs_2.8.16.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "XFS Filesystem Utilities"
+HOMEPAGE = "http://oss.sgi.com/projects/xfs"
+LICENSE = "GPL"
+SECTION = "base"
+PR = "r2"
+DEPENDS = "e2fsprogs-libs"
+
+SRC_URI = "http://slackware.osuosl.org/slackware-12.0/source/a/xfsprogs/xfsprogs_2.8.16-1.tar.gz"
+
+PARALLEL_MAKE = ""
+inherit autotools
+EXTRA_OECONF = "--enable-gettext=no"
+
+do_configure () {
+ export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
+ export DEBUG="-DNDEBUG"
+ oe_runconf
+}
+
+do_install () {
+ export DIST_ROOT=${D}
+ oe_runmake install
+}
+