aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xinput-calibrator
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2010-01-19 22:04:33 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-01-20 10:19:05 +0100
commitf6c05a045df03c86b1a58af3cc164a2ad6005101 (patch)
treefe752f1af132bc6be8aa41ec2d9cd3f824b8e90c /recipes/xinput-calibrator
parenta353f4ee7229c686bfc61417cab979ffa1735d55 (diff)
downloadopenembedded-f6c05a045df03c86b1a58af3cc164a2ad6005101.tar.gz
xinput_calibrator: switch to autotools
Signed-off-by: Petr Štetiar <ynezz@true.cz> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/xinput-calibrator')
-rw-r--r--recipes/xinput-calibrator/xinput-calibrator-0.5.0/0001-switch-to-autotools-based-build-system.patch162
-rw-r--r--recipes/xinput-calibrator/xinput-calibrator-0.5.0/use-proper-compiler.patch20
-rw-r--r--recipes/xinput-calibrator/xinput-calibrator_0.5.0.bb7
3 files changed, 166 insertions, 23 deletions
diff --git a/recipes/xinput-calibrator/xinput-calibrator-0.5.0/0001-switch-to-autotools-based-build-system.patch b/recipes/xinput-calibrator/xinput-calibrator-0.5.0/0001-switch-to-autotools-based-build-system.patch
new file mode 100644
index 0000000000..adec403147
--- /dev/null
+++ b/recipes/xinput-calibrator/xinput-calibrator-0.5.0/0001-switch-to-autotools-based-build-system.patch
@@ -0,0 +1,162 @@
+From 1a85be450fba4585c64b3178316603a5ad7dd4e6 Mon Sep 17 00:00:00 2001
+From: =?utf-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
+Date: Tue, 19 Jan 2010 18:59:52 +0100
+Subject: [PATCH] switch to autotools based build system
+MIME-Version: 1.0
+Content-Type: text/plain; charset=utf-8
+Content-Transfer-Encoding: 8bit
+
+This patch autotoolize xinput_calibrator for easier (cross)compiling.
+
+Signed-off-by: Petr Štetiar <ynezz@true.cz>
+---
+ Makefile | 11 -----------
+ Makefile.am | 41 +++++++++++++++++++++++++++++++++++++++++
+ autogen.sh | 12 ++++++++++++
+ configure.ac | 49 +++++++++++++++++++++++++++++++++++++++++++++++++
+ 4 files changed, 102 insertions(+), 11 deletions(-)
+ delete mode 100644 Makefile
+ create mode 100644 Makefile.am
+ create mode 100755 autogen.sh
+ create mode 100644 configure.ac
+
+diff --git a/Makefile b/Makefile
+deleted file mode 100644
+index c6eabed..0000000
+--- a/Makefile
++++ /dev/null
+@@ -1,11 +0,0 @@
+-all: x11 gtkmm
+-
+-x11: main_x11.cpp gui_x11.cpp
+- g++ -Wall main_x11.cpp -lX11 -lXi -o xinput_calibrator.x11
+- cp xinput_calibrator.x11 xinput_calibrator
+-
+-gtkmm: main_gtkmm.cpp gui_gtkmm.cpp
+- g++ -Wall main_gtkmm.cpp `pkg-config --cflags --libs gtkmm-2.4` -o xinput_calibrator.gtkmm
+-
+-clean:
+- rm -f xinput_calibrator xinput_calibrator.x11 xinput_calibrator.gtkmm
+diff --git a/Makefile.am b/Makefile.am
+new file mode 100644
+index 0000000..ef8f531
+--- /dev/null
++++ b/Makefile.am
+@@ -0,0 +1,41 @@
++#
++# Copyright (c) 2010 Petr Stetiar <ynezz@true.cz>
++#
++# Permission is hereby granted, free of charge, to any person
++# obtaining a copy of this software and associated documentation
++# files (the "Software"), to deal in the Software without
++# restriction, including without limitation the rights to use,
++# copy, modify, merge, publish, distribute, sublicense, and/or sell
++# copies of the Software, and to permit persons to whom the
++# Software is furnished to do so, subject to the following
++# conditions:
++#
++# The above copyright notice and this permission notice shall be
++# included in all copies or substantial portions of the Software.
++#
++# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++# OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++# OTHER DEALINGS IN THE SOFTWARE.
++#
++
++#AM_CFLAGS = -Wall -ansi -pedantic -W -Wmissing-prototypes -Wmissing-declarations -Werror -std=gnu99
++
++if BUILD_GTKMM
++bin_PROGRAMS = xinput_calibrator_x11 xinput_calibrator_gtkmm
++xinput_calibrator_gtkmm_SOURCES = main_gtkmm.cpp
++xinput_calibrator_gtkmm_CXXFLAGS = $(GTKMM_CFLAGS)
++xinput_calibrator_gtkmm_LDADD = $(GTKMM_LIBS)
++else
++bin_PROGRAMS = xinput_calibrator_x11
++endif
++
++xinput_calibrator_x11_LDADD = $(XORG_LIBS)
++xinput_calibrator_x11_CFLAGS = $(XORG_CFLAGS)
++xinput_calibrator_x11_SOURCES = main_x11.cpp
++
++EXTRA_DIST = autogen.sh
+diff --git a/autogen.sh b/autogen.sh
+new file mode 100755
+index 0000000..904cd67
+--- /dev/null
++++ b/autogen.sh
+@@ -0,0 +1,12 @@
++#! /bin/sh
++
++srcdir=`dirname $0`
++test -z "$srcdir" && srcdir=.
++
++ORIGDIR=`pwd`
++cd $srcdir
++
++autoreconf -v --install || exit 1
++cd $ORIGDIR || exit $?
++
++$srcdir/configure --enable-maintainer-mode "$@"
+diff --git a/configure.ac b/configure.ac
+new file mode 100644
+index 0000000..13257b4
+--- /dev/null
++++ b/configure.ac
+@@ -0,0 +1,49 @@
++#
++# Copyright (c) 2010 Petr Stetiar <ynezz@true.cz>
++#
++# Permission is hereby granted, free of charge, to any person
++# obtaining a copy of this software and associated documentation
++# files (the "Software"), to deal in the Software without
++# restriction, including without limitation the rights to use,
++# copy, modify, merge, publish, distribute, sublicense, and/or sell
++# copies of the Software, and to permit persons to whom the
++# Software is furnished to do so, subject to the following
++# conditions:
++#
++# The above copyright notice and this permission notice shall be
++# included in all copies or substantial portions of the Software.
++#
++# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++# OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++# HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++# OTHER DEALINGS IN THE SOFTWARE.
++#
++
++AC_PREREQ([2.57])
++AC_INIT(xinput_calibrator,[0.5.0], [http://github.com/tias/xinput_calibrator])
++AM_INIT_AUTOMAKE([foreign dist-bzip2])
++AM_MAINTAINER_MODE
++
++AC_PROG_CC
++AC_PROG_CXX
++AC_PROG_INSTALL
++
++AC_ARG_ENABLE([gtkmm], AS_HELP_STRING([--enable-gtkmm], [Enable GTKMM GUI]))
++AS_IF([test "x$enable_gtkmm" = "xyes"], [
++ PKG_CHECK_MODULES(GTKMM, [gtkmm-2.4])
++ AC_SUBST(GTKMM_CFLAGS)
++ AC_SUBST(GTKMM_LIBS)
++])
++
++AM_CONDITIONAL([BUILD_GTKMM], [test "x$enable_gtkmm" = "xyes"])
++
++PKG_CHECK_MODULES(XORG, [x11 xi])
++AC_SUBST(XORG_CFLAGS)
++AC_SUBST(XORG_LIBS)
++
++AC_CONFIG_FILES(Makefile)
++AC_OUTPUT
+--
+1.6.0.4
+
diff --git a/recipes/xinput-calibrator/xinput-calibrator-0.5.0/use-proper-compiler.patch b/recipes/xinput-calibrator/xinput-calibrator-0.5.0/use-proper-compiler.patch
deleted file mode 100644
index a7912fb4c7..0000000000
--- a/recipes/xinput-calibrator/xinput-calibrator-0.5.0/use-proper-compiler.patch
+++ /dev/null
@@ -1,20 +0,0 @@
----
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- git.orig/Makefile
-+++ git/Makefile
-@@ -1,11 +1,11 @@
- all: x11 gtkmm
-
- x11: main_x11.cpp gui_x11.cpp
-- g++ -Wall main_x11.cpp -lX11 -lXi -o xinput_calibrator.x11
-+ $(CXX) $(CFLAGS) $(LDFLAGS) -Wall main_x11.cpp -lX11 -lXi -o xinput_calibrator.x11
- cp xinput_calibrator.x11 xinput_calibrator
-
- gtkmm: main_gtkmm.cpp gui_gtkmm.cpp
-- g++ -Wall main_gtkmm.cpp `pkg-config --cflags --libs gtkmm-2.4` -o xinput_calibrator.gtkmm
-+ $(CXX) $(CFLAGS) $(LDFLAGS) -Wall main_gtkmm.cpp `pkg-config --cflags --libs gtkmm-2.4` -o xinput_calibrator.gtkmm
-
- clean:
- rm -f xinput_calibrator xinput_calibrator.x11 xinput_calibrator.gtkmm
diff --git a/recipes/xinput-calibrator/xinput-calibrator_0.5.0.bb b/recipes/xinput-calibrator/xinput-calibrator_0.5.0.bb
index 59a28569c9..2d6924711d 100644
--- a/recipes/xinput-calibrator/xinput-calibrator_0.5.0.bb
+++ b/recipes/xinput-calibrator/xinput-calibrator_0.5.0.bb
@@ -2,12 +2,13 @@ DEPENDS = "virtual/libx11 libxi"
SRCREV = "6af268f1b435f7bdd83335092ddc684054df2110"
SRC_URI = "git://github.com/tias/xinput_calibrator.git;protocol=git \
- file://use-proper-compiler.patch;patch=1"
+ file://0001-switch-to-autotools-based-build-system.patch;patch=1"
+PR = "r1"
+inherit autotools
S = "${WORKDIR}/git/"
-EXTRA_OEMAKE = "x11"
do_install() {
install -d ${D}${bindir}
- install -m 0755 xinput_calibrator ${D}${bindir}
+ install -m 0755 xinput_calibrator_x11 ${D}${bindir}/xinput_calibrator
}