summaryrefslogtreecommitdiffstats
path: root/recipes/xinput-calibrator
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2010-03-12 14:27:08 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2010-03-17 18:26:03 -0300
commit98764601e536047238130cb8ad02c74250656346 (patch)
tree541b27ad76835745b3601b24ff688b73372c56cd /recipes/xinput-calibrator
parent5cca66257cb46960378e302069fbf8353390fef3 (diff)
downloadopenembedded-98764601e536047238130cb8ad02c74250656346.tar.gz
xinput-calibrator: patch to fix miny and maxx printing order for UDEV and HAL
Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/xinput-calibrator')
-rw-r--r--recipes/xinput-calibrator/xinput-calibrator-0.6.0/0001-calibratorXorgPrint.cpp-fix-miny-and-maxx-printing-o.patch36
-rw-r--r--recipes/xinput-calibrator/xinput-calibrator_0.6.0.bb5
2 files changed, 39 insertions, 2 deletions
diff --git a/recipes/xinput-calibrator/xinput-calibrator-0.6.0/0001-calibratorXorgPrint.cpp-fix-miny-and-maxx-printing-o.patch b/recipes/xinput-calibrator/xinput-calibrator-0.6.0/0001-calibratorXorgPrint.cpp-fix-miny-and-maxx-printing-o.patch
new file mode 100644
index 0000000000..fa0314726b
--- /dev/null
+++ b/recipes/xinput-calibrator/xinput-calibrator-0.6.0/0001-calibratorXorgPrint.cpp-fix-miny-and-maxx-printing-o.patch
@@ -0,0 +1,36 @@
+From 383a3a8523814d1b108d2dc1ed812f80d6c9f050 Mon Sep 17 00:00:00 2001
+From: Mario Domenech Goulart <mario@ossystems.com.br>
+Date: Thu, 11 Mar 2010 11:05:18 -0300
+Subject: [PATCH] calibratorXorgPrint.cpp: fix miny and maxx printing order for UDEV and HAL
+
+
+Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br>
+---
+ src/calibrator/calibratorXorgPrint.cpp | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/calibrator/calibratorXorgPrint.cpp b/src/calibrator/calibratorXorgPrint.cpp
+index 92d297a..1f74de0 100644
+--- a/src/calibrator/calibratorXorgPrint.cpp
++++ b/src/calibrator/calibratorXorgPrint.cpp
+@@ -69,7 +69,7 @@ bool CalibratorXorgPrint::finish_data(const XYinfo new_axys, int swap_xy)
+ \tENV{x11_options.miny}=\"%d\"\n\
+ \tENV{x11_options.maxx}=\"%d\"\n\
+ \tENV{x11_options.maxy}=\"%d\"\n"
+- , new_axys.x_min, new_axys.x_max, new_axys.y_min, new_axys.y_max);
++ , new_axys.x_min, new_axys.y_min, new_axys.x_max, new_axys.y_max);
+ if (swap_xy != 0)
+ printf("\tENV{x11_options.swapxy}=\"%d\"\n", swap_xy);
+ printf("\tLABEL=\"xorg_touchscreen_end\"\n");
+@@ -81,7 +81,7 @@ bool CalibratorXorgPrint::finish_data(const XYinfo new_axys, int swap_xy)
+ \t <merge key=\"input.x11_options.miny\" type=\"string\">%d</merge>\n\
+ \t <merge key=\"input.x11_options.maxx\" type=\"string\">%d</merge>\n\
+ \t <merge key=\"input.x11_options.maxy\" type=\"string\">%d</merge>\n"
+- , new_axys.x_min, new_axys.x_max, new_axys.y_min, new_axys.y_max);
++ , new_axys.x_min, new_axys.y_min, new_axys.x_max, new_axys.y_max);
+ if (swap_xy != 0)
+ printf("\t <merge key=\"input.x11_options.swapxy\" type=\"string\">%d</merge>\n", swap_xy);
+ printf("\t</match>\n");
+--
+1.6.3.3.444.g4ecbc
+
diff --git a/recipes/xinput-calibrator/xinput-calibrator_0.6.0.bb b/recipes/xinput-calibrator/xinput-calibrator_0.6.0.bb
index 21194ae0be..fb43231e24 100644
--- a/recipes/xinput-calibrator/xinput-calibrator_0.6.0.bb
+++ b/recipes/xinput-calibrator/xinput-calibrator_0.6.0.bb
@@ -1,11 +1,12 @@
require xinput-calibrator.inc
-SRC_URI = "git://github.com/tias/xinput_calibrator.git;protocol=git"
+SRC_URI = "git://github.com/tias/xinput_calibrator.git;protocol=git \
+ file://0001-calibratorXorgPrint.cpp-fix-miny-and-maxx-printing-o.patch;patch=1"
SRCREV = "d6e01d780001948f55006698e8e9e48c12894810"
S = "${WORKDIR}/git/"
-PR = "r1"
+PR = "r2"
do_install_append() {
install -d ${D}${bindir}