aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xkeyboard-config
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xkeyboard-config
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xkeyboard-config')
-rw-r--r--recipes/xkeyboard-config/files/abnt2-fixes.patch10
-rw-r--r--recipes/xkeyboard-config/xkeyboard-config_1.4.bb21
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes/xkeyboard-config/files/abnt2-fixes.patch b/recipes/xkeyboard-config/files/abnt2-fixes.patch
new file mode 100644
index 0000000000..eb4c3e37f1
--- /dev/null
+++ b/recipes/xkeyboard-config/files/abnt2-fixes.patch
@@ -0,0 +1,10 @@
+--- a/keycodes/evdev
++++ b/keycodes/evdev
+@@ -311,6 +311,7 @@ xkb_keycodes "jp106" {
+ // For brazilian ABNT2 keyboard.
+ xkb_keycodes "abnt2" {
+ include "evdev(evdev)"
++ <KPPT> = 129;
+ };
+
+ // PC98
diff --git a/recipes/xkeyboard-config/xkeyboard-config_1.4.bb b/recipes/xkeyboard-config/xkeyboard-config_1.4.bb
new file mode 100644
index 0000000000..58bb811177
--- /dev/null
+++ b/recipes/xkeyboard-config/xkeyboard-config_1.4.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Common X11 Keyboard layouts"
+LICENSE = "MIT"
+DEPENDS = "intltool xkbcomp-native"
+RDEPENDS = "xkbcomp"
+PR = "r3"
+
+SRC_URI = "http://xlibs.freedesktop.org/xkbdesc/xkeyboard-config-${PV}.tar.bz2 \
+ file://abnt2-fixes.patch;patch=1"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install_append () {
+ install -d ${D}/usr/share/X11/xkb/compiled
+ cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
+}
+
+FILES_${PN} += "${datadir}/X11/xkb"