aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xmltv
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-12 22:16:45 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-12 22:16:45 +0100
commit63142c1df889922217f42842420c0593f3f29d63 (patch)
tree8ab31d47444a881e54435c4bbaad77787f844d04 /recipes/xmltv
parentb8e6b2627c2da5b855e8c9951e9023d16e8b7877 (diff)
downloadopenembedded-63142c1df889922217f42842420c0593f3f29d63.tar.gz
xmltv: added some grabbers
Diffstat (limited to 'recipes/xmltv')
-rw-r--r--recipes/xmltv/files/Makefile.PL.patch14
-rw-r--r--recipes/xmltv/xmltv_0.5.56.bb31
2 files changed, 40 insertions, 5 deletions
diff --git a/recipes/xmltv/files/Makefile.PL.patch b/recipes/xmltv/files/Makefile.PL.patch
new file mode 100644
index 0000000000..7acc2cbf8c
--- /dev/null
+++ b/recipes/xmltv/files/Makefile.PL.patch
@@ -0,0 +1,14 @@
+Index: xmltv-0.5.56/Makefile.PL
+===================================================================
+--- xmltv-0.5.56.orig/Makefile.PL
++++ xmltv-0.5.56/Makefile.PL
+@@ -777,8 +777,7 @@ END
+ die;
+ }
+
+- $info->{install} =
+- ask(0, $msg, not $missing);
++ $info->{install} = not $missing;
+ }
+ }
+ }
diff --git a/recipes/xmltv/xmltv_0.5.56.bb b/recipes/xmltv/xmltv_0.5.56.bb
index 70005d70f4..842ef5fbd1 100644
--- a/recipes/xmltv/xmltv_0.5.56.bb
+++ b/recipes/xmltv/xmltv_0.5.56.bb
@@ -1,14 +1,35 @@
DESCRIPTION="prerequisites for xmltv"
PARALLEL_MAKE = ""
-SRC_URI="http://downloads.sourceforge.net/xmltv/xmltv-${PV}.tar.bz2"
+SRC_URI="http://downloads.sourceforge.net/xmltv/xmltv-${PV}.tar.bz2 \
+ file://Makefile.PL.patch;patch=1"
+RDEPENDS = "perl libxml-parser-perl libwww-perl libdate-manip-perl \
+ libxml-twig-perl libxml-writer-perl libfile-slurp-perl \
+ libtermreadkey-perl libarchive-zip-perl libio-zlib-perl \
+ libdate-manip-perl \
+ libhtml-treebuilder-perl libwww-mechanize-perl"
DEPENDS = "perl libxml-parser-perl-native libwww-perl-native libdate-manip-perl-native \
libxml-twig-perl-native libxml-writer-perl-native libfile-slurp-perl-native \
- libtermreadkey-perl-native"
+ libtermreadkey-perl-native libarchive-zip-perl-native libio-zlib-perl-native \
+ libdate-manip-perl-native \
+ libhtml-treebuilder-perl-native libwww-mechanize-perl-native"
-PR = "r0"
+PR = "r1"
-EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+# cpan does not work, it installs things in the perl work dir iso the xmltv work dir
+# root cause are bad definitions in perl/config.sh, but I don't know what they should be
+# so for now commented out the cpan stuff and do the work myself.
+#EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
-inherit cpan
+#inherit cpan
+
+FILES_${PN} += "${libdir}"
+
+do_configure() {
+ perl Makefile.PL PREFIX=/usr
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}