aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-driver/xf86-video-msm_git.bb
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-04-06 21:37:04 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-04-06 22:19:46 +0200
commitc233ed019d22cb0571d14ed402acd0d699ce74d1 (patch)
tree1b8b2daa7ad2ab0a57164a918a1f15c70791d357 /recipes/xorg-driver/xf86-video-msm_git.bb
parentaa7fa11e618731ddc3db28fa56abe31a33265192 (diff)
downloadopenembedded-c233ed019d22cb0571d14ed402acd0d699ce74d1.tar.gz
xf86-video-msm : bump git version(fixes gtk issue),rebased patch,also made it compile automatically
*We had an issue with gtk+ programs resulting in screen corruption,this is now fixed with this version *rebased the patches to make it work with the new version *switched to machine arch(thanks XorA and hrw),that permit us to copy a kernel header in the sources, unfortunately it also depends on another non-staged kernel header(kgsl_drm.h) that was manually copied in the files dir *The copy of the kenrel headers in the source directory permit us to compile it (thanks mickeyl for how to do it corectly) *removed neon for htcdream machine,if someone wants to support more machines or architectures, he will have to find a better way and modify the recipe,maybe using a python @ function that checks TARGET_CC_ARCH,and as CosmicPenguin said in #oe "Thats what open source is all about"
Diffstat (limited to 'recipes/xorg-driver/xf86-video-msm_git.bb')
-rw-r--r--recipes/xorg-driver/xf86-video-msm_git.bb23
1 files changed, 16 insertions, 7 deletions
diff --git a/recipes/xorg-driver/xf86-video-msm_git.bb b/recipes/xorg-driver/xf86-video-msm_git.bb
index 4723b867f0..a7d7d6f106 100644
--- a/recipes/xorg-driver/xf86-video-msm_git.bb
+++ b/recipes/xorg-driver/xf86-video-msm_git.bb
@@ -2,17 +2,17 @@ require xorg-driver-video.inc
DESCRIPTION = "X.Org X server -- MSM display driver"
-PR_append = "d"
+PR_append = "e"
-SRCREV = "5f7df59155ae301a3ebc40aec22ed16d203cb5fc"
+SRCREV = "cfbbd17f0d4ab0f30915594d74e1b2b12c4ff8a1"
PV = "1.1.0+${PR}+gitr${SRCREV}"
PE = "1"
-SRC_URI = "git://codeaurora.org/quic/xwin/xf86-video-msm.git;protocol=git"
-SRC_URI_htcdream = "git://codeaurora.org/quic/xwin/xf86-video-msm.git;protocol=git \
- file://no_neon.patch;patch=1 \
- file://no_neon_flags.patch;patch=1 \
- file://renaming_variables.patch;patch=1"
+SRC_URI = "git://codeaurora.org/quic/xwin/xf86-video-msm.git;protocol=git;branch=chromium \
+ file://compile_cfbbd17f0d4ab0f30915594d74e1b2b12c4ff8a1.patch;patch=1 \
+ file://kgsl_drm.h "
+
+SRC_URI_append_htcdream = "file://no_neon_cfbbd17f0d4ab0f30915594d74e1b2b12c4ff8a1.patch;patch=1"
S = "${WORKDIR}/git"
@@ -20,3 +20,12 @@ CFLAGS += " -I${STAGING_INCDIR}/xorg "
CFLAGS += " -Wno-error "
ARM_INSTRUCTION_SET="arm"
+
+PACKAGE_ARCH="${MACHINE_ARCH}"
+
+do_compile_prepend() {
+ install -d ${S}/src/linux
+ install -d ${S}/src/drm
+ install -m 0644 ${STAGING_KERNEL_DIR}/include/linux/msm_mdp.h ${S}/src/linux/
+ install -m 0644 ${WORKDIR}/kgsl_drm.h ${S}/src/drm/
+}