aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-font
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-12-03 09:28:06 +0000
committerKoen Kooi <koen@openembedded.org>2009-12-04 10:43:11 +0100
commitc33a047eeda429ef01f6a0cf3948940474fa035f (patch)
treebe24fae2ad1a9937f689fd687425fa55eab5c877 /recipes/xorg-font
parentb5261869ab320951007265b66f9aa2ea5d6b8b8f (diff)
downloadopenembedded-c33a047eeda429ef01f6a0cf3948940474fa035f.tar.gz
xorg-font-common: Update include to deal with newer fonts installed to /usr/share and add INC_PR.
Diffstat (limited to 'recipes/xorg-font')
-rw-r--r--recipes/xorg-font/xorg-font-common.inc23
1 files changed, 16 insertions, 7 deletions
diff --git a/recipes/xorg-font/xorg-font-common.inc b/recipes/xorg-font/xorg-font-common.inc
index c2ea41e8e0..5cf40e8436 100644
--- a/recipes/xorg-font/xorg-font-common.inc
+++ b/recipes/xorg-font/xorg-font-common.inc
@@ -6,12 +6,14 @@ DEPENDS = " encodings font-alias font-util-native mkfontdir-native mkfontscale-n
RDEPENDS = "encodings font-util font-alias"
XORG_PN = "${PN}"
+INC_PR = "r1"
+
SRC_URI = "${XORG_MIRROR}/individual/font/${XORG_PN}-${PV}.tar.bz2"
S = "${WORKDIR}/${XORG_PN}-${PV}"
inherit autotools pkgconfig
-FILES_${PN} += " ${libdir}/X11/fonts"
+EXTRA_OEMAKE += "FCCACHE=/bin/true"
do_configure_prepend() {
if [ -f "${S}"/configure.ac ] ; then
@@ -19,10 +21,11 @@ do_configure_prepend() {
fi
}
-EXTRA_OEMAKE += "FCCACHE=/bin/true"
do_install_append() {
find ${D}${libdir}/X11/fonts -type f -name fonts.dir | xargs rm -f
find ${D}${libdir}/X11/fonts -type f -name fonts.scale | xargs rm -f
+ find ${D}${datadir}/fonts/X11 -type f -name fonts.dir | xargs rm -f
+ find ${D}${datadir}/fonts/X11 -type f -name fonts.scale | xargs rm -f
}
do_stage() {
@@ -31,10 +34,16 @@ do_stage() {
PACKAGE_ARCH = "all"
+FILES_${PN} += " ${libdir}/X11/fonts ${datadir}"
+
pkg_postinst_${PN} () {
- set -x
- for fontdir in `find $D/usr/lib/X11/fonts -type d`; do
- mkfontdir $fontdir
- mkfontscale $fontdir
- done
+ set -x
+ for fontdir in `find $D/usr/lib/X11/fonts -type d`; do
+ mkfontdir $fontdir
+ mkfontscale $fontdir
+ done
+ for fontdir in `find $D/usr/share/fonts/X11 -type d`; do
+ mkfontdir $fontdir
+ mkfontscale $fontdir
+ done
}