aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-lib/libx11-trim_1.1.5.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xorg-lib/libx11-trim_1.1.5.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xorg-lib/libx11-trim_1.1.5.bb')
-rw-r--r--recipes/xorg-lib/libx11-trim_1.1.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/xorg-lib/libx11-trim_1.1.5.bb b/recipes/xorg-lib/libx11-trim_1.1.5.bb
new file mode 100644
index 0000000000..e99b2a07b0
--- /dev/null
+++ b/recipes/xorg-lib/libx11-trim_1.1.5.bb
@@ -0,0 +1,33 @@
+require xorg-lib-common.inc
+
+DESCRIPTION = "X11 protocol and utility library"
+DEPENDS += "libxcb xproto xextproto xtrans libxau kbproto inputproto xf86bigfontproto"
+
+#FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libx11"
+#SRC_URI += "file://X18NCMSstubs.diff;patch=1 "
+
+PROVIDES = "virtual/libx11"
+
+PE = "1"
+PR = "r1"
+
+XORG_PN = "libX11"
+LEAD_SONAME = "libX11.so"
+
+SRC_URI += "file://include_fix.patch;patch=1"
+
+EXTRA_OECONF += "--with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h"
+#EXTRA_OECONF += "--disable-xlocale --disable-xcms --with-xcb"
+EXTRA_OECONF += "--disable-xcms --with-xcb"
+
+do_compile() {
+ (
+ unset CC LD CXX CCLD CFLAGS CPPFLAGS LDFLAGS CXXFLAGS
+ cd src/util; touch makekeys-makekeys.o ; ${BUILD_CC} ${BUILD_CFLAGS} makekeys.c -o makekeys
+ cd ../../
+ ) || exit 1
+ oe_runmake
+}
+
+FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB "
+