aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-lib
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-04 16:54:02 +0200
committerKoen Kooi <koen@Powerbook-3.local>2009-06-05 17:48:11 +0200
commitf1d8885f37c0ba682cf458477b8b94dc75fc2e58 (patch)
treeba244ec9d082cba4188ac5e5488108cebbf9ca60 /recipes/xorg-lib
parentd12429c3122671ee8312aabbaa3794c3a9877ea8 (diff)
downloadopenembedded-f1d8885f37c0ba682cf458477b8b94dc75fc2e58.tar.gz
pixman git: add patches to fix NEON bugs
Diffstat (limited to 'recipes/xorg-lib')
-rw-r--r--recipes/xorg-lib/pixman/0041-Fix-filler-bug.patch25
-rw-r--r--recipes/xorg-lib/pixman/0042-Really-fix-filler-bug.patch35
-rw-r--r--recipes/xorg-lib/pixman_git.bb8
3 files changed, 66 insertions, 2 deletions
diff --git a/recipes/xorg-lib/pixman/0041-Fix-filler-bug.patch b/recipes/xorg-lib/pixman/0041-Fix-filler-bug.patch
new file mode 100644
index 0000000000..02bd13a0db
--- /dev/null
+++ b/recipes/xorg-lib/pixman/0041-Fix-filler-bug.patch
@@ -0,0 +1,25 @@
+From 82ea3295e435b49478cf7943100b22286baf47dc Mon Sep 17 00:00:00 2001
+From: Jonathan Morton <jmorton@sd070.hel.movial.fi>
+Date: Thu, 4 Jun 2009 10:43:41 +0300
+Subject: [PATCH] Fix filler bug.
+
+---
+ pixman/pixman-arm-neon.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/pixman/pixman-arm-neon.c b/pixman/pixman-arm-neon.c
+index 18e9a16..67f0b63 100644
+--- a/pixman/pixman-arm-neon.c
++++ b/pixman/pixman-arm-neon.c
+@@ -1377,7 +1377,7 @@ pixman_fill_neon (uint32_t *bits,
+ "beq 2f\n"
+ "strh %[color], [r4]!\n"
+ "2:\n"
+- "tst r5, #1\n"
++ "tst %[width], #1\n"
+ "beq 2f\n"
+ "strb %[color], [r4]!\n"
+ "2:\n"
+--
+1.5.6.3
+
diff --git a/recipes/xorg-lib/pixman/0042-Really-fix-filler-bug.patch b/recipes/xorg-lib/pixman/0042-Really-fix-filler-bug.patch
new file mode 100644
index 0000000000..e23b9cd133
--- /dev/null
+++ b/recipes/xorg-lib/pixman/0042-Really-fix-filler-bug.patch
@@ -0,0 +1,35 @@
+From 5cdd43ac753780ef2cfd6adde822af5dcba6091f Mon Sep 17 00:00:00 2001
+From: Jonathan Morton <jmorton@sd070.hel.movial.fi>
+Date: Thu, 4 Jun 2009 15:11:40 +0300
+Subject: [PATCH] Really fix filler bug.
+
+---
+ pixman/pixman-arm-neon.c | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/pixman/pixman-arm-neon.c b/pixman/pixman-arm-neon.c
+index cfb69f4..0c05f64 100644
+--- a/pixman/pixman-arm-neon.c
++++ b/pixman/pixman-arm-neon.c
+@@ -1369,15 +1369,15 @@ pixman_fill_neon (uint32_t *bits,
+ "2:\n"
+ "tst %[width], #4\n"
+ "beq 2f\n"
+- "str %[color], [r4]!\n"
++ "str %[color], [r4], #4\n"
+ "2:\n"
+ "tst %[width], #2\n"
+ "beq 2f\n"
+- "strh %[color], [r4]!\n"
++ "strh %[color], [r4], #2\n"
+ "2:\n"
+ "tst %[width], #1\n"
+ "beq 2f\n"
+- "strb %[color], [r4]!\n"
++ "strb %[color], [r4], #1\n"
+ "2:\n"
+
+ "subs %[height], %[height], #1\n"
+--
+1.5.6.3
+
diff --git a/recipes/xorg-lib/pixman_git.bb b/recipes/xorg-lib/pixman_git.bb
index 128a3f3302..6c05c0ca53 100644
--- a/recipes/xorg-lib/pixman_git.bb
+++ b/recipes/xorg-lib/pixman_git.bb
@@ -4,13 +4,17 @@ DESCRIPTION = "Low-level pixel manipulation library."
LICENSE = "X11"
PV = "0.15.8"
+PR = "r1"
PR_append = "+gitr${SRCREV}"
-SRCREV = "a673a898e1e119836c9c68eff71feaec49f97bf1"
+SRCREV = "3c570a815afb282df01f41acad385ff0e3e33899"
DEFAULT_PREFERENCE = "-1"
-SRC_URI = "git://anongit.freedesktop.org/pixman;protocol=git"
+SRC_URI = "git://anongit.freedesktop.org/pixman;protocol=git \
+file://0041-Fix-filler-bug.patch;patch=1 \
+file://0042-Really-fix-filler-bug.patch;patch=1 \
+"
S = "${WORKDIR}/git"