aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-lib
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-09-28 16:46:49 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-09-29 23:16:44 +0200
commit7a54b54c10da1e57ef5fd965f5b27a8489aaa994 (patch)
treef0fc1f1d3be1b155219dc349439a691b04c607dd /recipes/xorg-lib
parent30098f191579d78bfe14b84b7649ce39ecad66ff (diff)
downloadopenembedded-7a54b54c10da1e57ef5fd965f5b27a8489aaa994.tar.gz
libx11: add 1.3.6 and 1.3.99.902, remove 1.3.5, change keysymdef_include_patch
* point to dir instead of keysymdef.h directly, because newer versions also check for vendor keysyms, see http://cgit.freedesktop.org/xorg/lib/libX11/commit/?h=libX11-1.3-branch&id=a32370c0854c8ad6f526dd997f14dbe3f466d4db Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-lib')
-rw-r--r--recipes/xorg-lib/libx11-1.1.5/keysymdef_include.patch6
-rw-r--r--recipes/xorg-lib/libx11-1.3.2/keysymdef_include.patch6
-rw-r--r--recipes/xorg-lib/libx11-1.3.5/keysymdef_include.patch21
-rw-r--r--recipes/xorg-lib/libx11-1.3.6/dolt-fix.patch (renamed from recipes/xorg-lib/libx11-1.3.5/dolt-fix.patch)0
-rw-r--r--recipes/xorg-lib/libx11-1.3.6/keysymdef_include.patch19
-rw-r--r--recipes/xorg-lib/libx11-1.3.6/x11_disable_makekeys.patch (renamed from recipes/xorg-lib/libx11-1.3.5/x11_disable_makekeys.patch)0
-rw-r--r--recipes/xorg-lib/libx11-1.3.99.902/keysymdef_include.patch19
-rw-r--r--recipes/xorg-lib/libx11-1.3.99.902/x11_disable_makekeys.patch29
-rw-r--r--recipes/xorg-lib/libx11.inc2
-rw-r--r--recipes/xorg-lib/libx11_1.1.5.bb2
-rw-r--r--recipes/xorg-lib/libx11_1.3.2.bb2
-rw-r--r--recipes/xorg-lib/libx11_1.3.5.bb6
-rw-r--r--recipes/xorg-lib/libx11_1.3.6.bb6
-rw-r--r--recipes/xorg-lib/libx11_1.3.99.902.bb8
14 files changed, 90 insertions, 36 deletions
diff --git a/recipes/xorg-lib/libx11-1.1.5/keysymdef_include.patch b/recipes/xorg-lib/libx11-1.1.5/keysymdef_include.patch
index 07487b6b2e..7e725b2132 100644
--- a/recipes/xorg-lib/libx11-1.1.5/keysymdef_include.patch
+++ b/recipes/xorg-lib/libx11-1.1.5/keysymdef_include.patch
@@ -8,9 +8,9 @@ Index: libX11-1.1.5/configure.ac
AC_MSG_CHECKING([keysymdef.h])
-dir=`pkg-config --variable=includedir xproto`
-KEYSYMDEF="$dir/X11/keysymdef.h"
-+AC_ARG_WITH(keysymdef,
-+ AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),
-+ KEYSYMDEF=$withval, KEYSYMDEF="")
++AC_ARG_WITH(keysymdefdir,
++ AC_HELP_STRING([--with-keysymdefdir=DIR], [The location of keysymdef.h]),
++ KEYSYMDEF=$withval/keysymdef.h, KEYSYMDEF="")
+
+if test x$KEYSYMDEF = x; then
+ dir=`pkg-config --variable=includedir xproto`
diff --git a/recipes/xorg-lib/libx11-1.3.2/keysymdef_include.patch b/recipes/xorg-lib/libx11-1.3.2/keysymdef_include.patch
index 07487b6b2e..7e725b2132 100644
--- a/recipes/xorg-lib/libx11-1.3.2/keysymdef_include.patch
+++ b/recipes/xorg-lib/libx11-1.3.2/keysymdef_include.patch
@@ -8,9 +8,9 @@ Index: libX11-1.1.5/configure.ac
AC_MSG_CHECKING([keysymdef.h])
-dir=`pkg-config --variable=includedir xproto`
-KEYSYMDEF="$dir/X11/keysymdef.h"
-+AC_ARG_WITH(keysymdef,
-+ AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),
-+ KEYSYMDEF=$withval, KEYSYMDEF="")
++AC_ARG_WITH(keysymdefdir,
++ AC_HELP_STRING([--with-keysymdefdir=DIR], [The location of keysymdef.h]),
++ KEYSYMDEF=$withval/keysymdef.h, KEYSYMDEF="")
+
+if test x$KEYSYMDEF = x; then
+ dir=`pkg-config --variable=includedir xproto`
diff --git a/recipes/xorg-lib/libx11-1.3.5/keysymdef_include.patch b/recipes/xorg-lib/libx11-1.3.5/keysymdef_include.patch
deleted file mode 100644
index 0cab165f74..0000000000
--- a/recipes/xorg-lib/libx11-1.3.5/keysymdef_include.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: libX11-1.3.4/configure.ac
-===================================================================
---- libX11-1.3.4.orig/configure.ac
-+++ libX11-1.3.4/configure.ac
-@@ -355,8 +355,14 @@ AC_CHECK_FUNC(poll, [AC_DEFINE(USE_POLL,
- # Find keysymdef.h
- #
- AC_MSG_CHECKING([keysymdef.h])
--dir=`$PKG_CONFIG --variable=includedir xproto`
--KEYSYMDEF="$dir/X11/keysymdef.h"
-+AC_ARG_WITH(keysymdef,
-+ AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),
-+ KEYSYMDEF=$withval, KEYSYMDEF="")
-+
-+if test x$KEYSYMDEF = x; then
-+ dir=`${PKG_CONFIG} --variable=includedir xproto`
-+ KEYSYMDEF="$dir/X11/keysymdef.h"
-+fi
- if test -f "$KEYSYMDEF"; then
- AC_MSG_RESULT([$KEYSYMDEF])
- else
diff --git a/recipes/xorg-lib/libx11-1.3.5/dolt-fix.patch b/recipes/xorg-lib/libx11-1.3.6/dolt-fix.patch
index 7e96075aa3..7e96075aa3 100644
--- a/recipes/xorg-lib/libx11-1.3.5/dolt-fix.patch
+++ b/recipes/xorg-lib/libx11-1.3.6/dolt-fix.patch
diff --git a/recipes/xorg-lib/libx11-1.3.6/keysymdef_include.patch b/recipes/xorg-lib/libx11-1.3.6/keysymdef_include.patch
new file mode 100644
index 0000000000..1a30e345f9
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.3.6/keysymdef_include.patch
@@ -0,0 +1,19 @@
+diff -uNr libX11-1.3.6.orig//configure.ac libX11-1.3.6/configure.ac
+--- libX11-1.3.6.orig//configure.ac 2010-09-20 08:04:16.000000000 +0200
++++ libX11-1.3.6/configure.ac 2010-09-28 16:29:26.000000000 +0200
+@@ -355,7 +355,14 @@
+ # Find keysymdef.h
+ #
+ AC_MSG_CHECKING([keysym definitions])
+-KEYSYMDEFDIR=`$PKG_CONFIG --variable=includedir xproto`/X11
++AC_ARG_WITH(keysymdefdir,
++ AC_HELP_STRING([--with-keysymdefdir=DIR], [The location of keysymdef.h]),
++ KEYSYMDEFDIR=$withval, KEYSYMDEFDIR="")
++
++if test x$KEYSYMDEFDIR = x; then
++ KEYSYMDEFDIR=`$PKG_CONFIG --variable=includedir xproto`/X11
++fi
++
+ FILES="keysymdef.h XF86keysym.h Sunkeysym.h DECkeysym.h HPkeysym.h"
+ for i in $FILES; do
+ if test -f "$KEYSYMDEFDIR/$i"; then
diff --git a/recipes/xorg-lib/libx11-1.3.5/x11_disable_makekeys.patch b/recipes/xorg-lib/libx11-1.3.6/x11_disable_makekeys.patch
index 9763313975..9763313975 100644
--- a/recipes/xorg-lib/libx11-1.3.5/x11_disable_makekeys.patch
+++ b/recipes/xorg-lib/libx11-1.3.6/x11_disable_makekeys.patch
diff --git a/recipes/xorg-lib/libx11-1.3.99.902/keysymdef_include.patch b/recipes/xorg-lib/libx11-1.3.99.902/keysymdef_include.patch
new file mode 100644
index 0000000000..1a30e345f9
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.3.99.902/keysymdef_include.patch
@@ -0,0 +1,19 @@
+diff -uNr libX11-1.3.6.orig//configure.ac libX11-1.3.6/configure.ac
+--- libX11-1.3.6.orig//configure.ac 2010-09-20 08:04:16.000000000 +0200
++++ libX11-1.3.6/configure.ac 2010-09-28 16:29:26.000000000 +0200
+@@ -355,7 +355,14 @@
+ # Find keysymdef.h
+ #
+ AC_MSG_CHECKING([keysym definitions])
+-KEYSYMDEFDIR=`$PKG_CONFIG --variable=includedir xproto`/X11
++AC_ARG_WITH(keysymdefdir,
++ AC_HELP_STRING([--with-keysymdefdir=DIR], [The location of keysymdef.h]),
++ KEYSYMDEFDIR=$withval, KEYSYMDEFDIR="")
++
++if test x$KEYSYMDEFDIR = x; then
++ KEYSYMDEFDIR=`$PKG_CONFIG --variable=includedir xproto`/X11
++fi
++
+ FILES="keysymdef.h XF86keysym.h Sunkeysym.h DECkeysym.h HPkeysym.h"
+ for i in $FILES; do
+ if test -f "$KEYSYMDEFDIR/$i"; then
diff --git a/recipes/xorg-lib/libx11-1.3.99.902/x11_disable_makekeys.patch b/recipes/xorg-lib/libx11-1.3.99.902/x11_disable_makekeys.patch
new file mode 100644
index 0000000000..9763313975
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.3.99.902/x11_disable_makekeys.patch
@@ -0,0 +1,29 @@
+Index: libX11-1.3.4/src/util/Makefile.am
+===================================================================
+--- libX11-1.3.4.orig/src/util/Makefile.am
++++ libX11-1.3.4/src/util/Makefile.am
+@@ -1,24 +1 @@
+-
+-noinst_PROGRAMS=makekeys
+-
+-makekeys_CFLAGS = \
+- $(X11_CFLAGS) \
+- $(CWARNFLAGS)
+-
+-CC = @CC_FOR_BUILD@
+-CPPFLAGS = @CPPFLAGS_FOR_BUILD@
+-CFLAGS = @CFLAGS_FOR_BUILD@
+-LDFLAGS = @LDFLAGS_FOR_BUILD@
+-
+ EXTRA_DIST = mkks.sh
+-
+-if LINT
+-# Check source code with tools like lint & sparse
+-
+-ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+- $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS)
+-
+-lint:
+- $(LINT) $(ALL_LINT_FLAGS) makekeys.c
+-
+-endif LINT
diff --git a/recipes/xorg-lib/libx11.inc b/recipes/xorg-lib/libx11.inc
index b9eb64ad55..4c8739ecef 100644
--- a/recipes/xorg-lib/libx11.inc
+++ b/recipes/xorg-lib/libx11.inc
@@ -22,7 +22,7 @@ FILES_${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"
XORG_PN = "libX11"
-EXTRA_OECONF += " --with-xcb --with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h --with-groff=no --with-ps2pdf=no"
+EXTRA_OECONF += " --with-xcb --with-keysymdefdir=${STAGING_INCDIR}/X11 --with-groff=no --with-ps2pdf=no"
EXTRA_OECONF_virtclass-native = " --without-xcb --with-groff=no --with-ps2pdf=no"
EXTRA_OECONF_virtclass-nativesdk = " --without-xcb --with-groff=no --with-ps2pdf=no"
diff --git a/recipes/xorg-lib/libx11_1.1.5.bb b/recipes/xorg-lib/libx11_1.1.5.bb
index cd902feda3..e7755854f0 100644
--- a/recipes/xorg-lib/libx11_1.1.5.bb
+++ b/recipes/xorg-lib/libx11_1.1.5.bb
@@ -1,6 +1,6 @@
require libx11.inc
DEPENDS = "${COMMON_DEPENDS}"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI[archive.md5sum] = "d1512d65dadd4f48c779d4749e7753a8"
SRC_URI[archive.sha256sum] = "da9272900e41615e9c5dc25d84730b8966da6f5c8f4c40418dca2ad040fc8b82"
diff --git a/recipes/xorg-lib/libx11_1.3.2.bb b/recipes/xorg-lib/libx11_1.3.2.bb
index 0446674c99..b3d48aba9f 100644
--- a/recipes/xorg-lib/libx11_1.3.2.bb
+++ b/recipes/xorg-lib/libx11_1.3.2.bb
@@ -1,5 +1,5 @@
require libx11.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
# gcc 4.5 ends up ICEing with thumb and -O1 with -fno-omit-framepointer
# therefore if we are in thumb mode then we use -Os instead of -O1 for
# DEBUG_OPTIMIZATION
diff --git a/recipes/xorg-lib/libx11_1.3.5.bb b/recipes/xorg-lib/libx11_1.3.5.bb
deleted file mode 100644
index 8c61aa756d..0000000000
--- a/recipes/xorg-lib/libx11_1.3.5.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require libx11.inc
-PR = "${INC_PR}.0"
-
-SRC_URI += " file://dolt-fix.patch"
-SRC_URI[archive.md5sum] = "a1175b6667fcb249c6f1d725965944e3"
-SRC_URI[archive.sha256sum] = "c95a3e3b5c7d45f933f922bdf6c757640f1c370369e85130bb75a9810dc6ede6"
diff --git a/recipes/xorg-lib/libx11_1.3.6.bb b/recipes/xorg-lib/libx11_1.3.6.bb
new file mode 100644
index 0000000000..625f9065b2
--- /dev/null
+++ b/recipes/xorg-lib/libx11_1.3.6.bb
@@ -0,0 +1,6 @@
+require libx11.inc
+PR = "${INC_PR}.0"
+
+SRC_URI += " file://dolt-fix.patch"
+SRC_URI[archive.md5sum] = "8e0a8a466aa78f66e09fe06cb395319f"
+SRC_URI[archive.sha256sum] = "599826765c59a98b1e58b4f6c4ad50dca69eeb0e7bd78aea736ca815f45bea40"
diff --git a/recipes/xorg-lib/libx11_1.3.99.902.bb b/recipes/xorg-lib/libx11_1.3.99.902.bb
new file mode 100644
index 0000000000..e7efc057bb
--- /dev/null
+++ b/recipes/xorg-lib/libx11_1.3.99.902.bb
@@ -0,0 +1,8 @@
+require libx11.inc
+#--without-xcb is not an option anymore
+#http://cgit.freedesktop.org/xorg/lib/libX11/commit/?id=15e5eaf62897b3179d1fbe457cb19f886f0449f8
+DEPENDS_virtclass-native = "libxcb-native ${COMMON_DEPENDS}"
+PR = "${INC_PR}.0"
+
+SRC_URI[archive.md5sum] = "dd824b76739a23fb466518f4acabb77b"
+SRC_URI[archive.sha256sum] = "9435dc0214afea0567f5f9f894cc62e44505511e4221dc936df361f14817bf2e"