aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-lib
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-22 12:32:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-22 19:51:03 +0200
commit5cb3bdc4a3151c4ee9f7822e75ac9bf6d70395a4 (patch)
tree2e795749e30328e8bfeda4ccc882a18e9bdb3e53 /recipes/xorg-lib
parent034c2cd49aa881b1b9dbc4f0abc203d5eaff11dd (diff)
downloadopenembedded-5cb3bdc4a3151c4ee9f7822e75ac9bf6d70395a4.tar.gz
xorg: bump packages 2010-06-22
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-lib')
-rw-r--r--recipes/xorg-lib/libx11-1.3.4/dolt-fix.patch22
-rw-r--r--recipes/xorg-lib/libx11-1.3.4/keysymdef_include.patch21
-rw-r--r--recipes/xorg-lib/libx11-1.3.4/x11_disable_makekeys.patch29
-rw-r--r--recipes/xorg-lib/libx11-native_1.3.4.bb8
-rw-r--r--recipes/xorg-lib/libx11_1.3.4.bb37
-rw-r--r--recipes/xorg-lib/libxcomposite_0.4.2.bb12
-rw-r--r--recipes/xorg-lib/libxdamage_1.1.3.bb13
-rw-r--r--recipes/xorg-lib/libxext-native_1.1.2.bb14
-rw-r--r--recipes/xorg-lib/libxext_1.1.2.bb12
-rw-r--r--recipes/xorg-lib/libxfixes-native_4.0.5.bb6
-rw-r--r--recipes/xorg-lib/libxfixes_4.0.5.bb11
-rw-r--r--recipes/xorg-lib/libxrender-native_0.9.6.bb6
-rw-r--r--recipes/xorg-lib/libxrender_0.9.6.bb11
13 files changed, 202 insertions, 0 deletions
diff --git a/recipes/xorg-lib/libx11-1.3.4/dolt-fix.patch b/recipes/xorg-lib/libx11-1.3.4/dolt-fix.patch
new file mode 100644
index 0000000000..7e96075aa3
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.3.4/dolt-fix.patch
@@ -0,0 +1,22 @@
+Index: libX11-1.3.4/m4/dolt.m4
+===================================================================
+--- libX11-1.3.4/m4/dolt.m4
++++ libX11-1.3.4/m4/dolt.m4
+@@ -155,7 +155,7 @@ dnl without '=', because automake does n
+ cat <<__DOLTLIBTOOL__EOF__ > doltlibtool
+ #!$DOLT_BASH
+ __DOLTLIBTOOL__EOF__
+- cat <<'__DOLTLIBTOOL__EOF__' >>doltlibtool
++ cat <<'__DOLTLIBTOOL__EOF__' | sed -e "s/@host_alias@/$host_alias/g" >>doltlibtool
+ top_builddir_slash="${0%%doltlibtool}"
+ : ${top_builddir_slash:=./}
+ args=()
+@@ -171,7 +171,7 @@ done
+ if $modeok && $tagok ; then
+ . ${top_builddir_slash}doltcompile "${args@<:@@@:>@}"
+ else
+- exec ${top_builddir_slash}libtool "$[]@"
++ exec ${top_builddir_slash}@host_alias@-libtool "$[]@"
+ fi
+ __DOLTLIBTOOL__EOF__
+
diff --git a/recipes/xorg-lib/libx11-1.3.4/keysymdef_include.patch b/recipes/xorg-lib/libx11-1.3.4/keysymdef_include.patch
new file mode 100644
index 0000000000..0cab165f74
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.3.4/keysymdef_include.patch
@@ -0,0 +1,21 @@
+Index: libX11-1.3.4/configure.ac
+===================================================================
+--- libX11-1.3.4.orig/configure.ac
++++ libX11-1.3.4/configure.ac
+@@ -355,8 +355,14 @@ AC_CHECK_FUNC(poll, [AC_DEFINE(USE_POLL,
+ # Find keysymdef.h
+ #
+ AC_MSG_CHECKING([keysymdef.h])
+-dir=`$PKG_CONFIG --variable=includedir xproto`
+-KEYSYMDEF="$dir/X11/keysymdef.h"
++AC_ARG_WITH(keysymdef,
++ AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),
++ KEYSYMDEF=$withval, KEYSYMDEF="")
++
++if test x$KEYSYMDEF = x; then
++ dir=`${PKG_CONFIG} --variable=includedir xproto`
++ KEYSYMDEF="$dir/X11/keysymdef.h"
++fi
+ if test -f "$KEYSYMDEF"; then
+ AC_MSG_RESULT([$KEYSYMDEF])
+ else
diff --git a/recipes/xorg-lib/libx11-1.3.4/x11_disable_makekeys.patch b/recipes/xorg-lib/libx11-1.3.4/x11_disable_makekeys.patch
new file mode 100644
index 0000000000..9763313975
--- /dev/null
+++ b/recipes/xorg-lib/libx11-1.3.4/x11_disable_makekeys.patch
@@ -0,0 +1,29 @@
+Index: libX11-1.3.4/src/util/Makefile.am
+===================================================================
+--- libX11-1.3.4.orig/src/util/Makefile.am
++++ libX11-1.3.4/src/util/Makefile.am
+@@ -1,24 +1 @@
+-
+-noinst_PROGRAMS=makekeys
+-
+-makekeys_CFLAGS = \
+- $(X11_CFLAGS) \
+- $(CWARNFLAGS)
+-
+-CC = @CC_FOR_BUILD@
+-CPPFLAGS = @CPPFLAGS_FOR_BUILD@
+-CFLAGS = @CFLAGS_FOR_BUILD@
+-LDFLAGS = @LDFLAGS_FOR_BUILD@
+-
+ EXTRA_DIST = mkks.sh
+-
+-if LINT
+-# Check source code with tools like lint & sparse
+-
+-ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+- $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS)
+-
+-lint:
+- $(LINT) $(ALL_LINT_FLAGS) makekeys.c
+-
+-endif LINT
diff --git a/recipes/xorg-lib/libx11-native_1.3.4.bb b/recipes/xorg-lib/libx11-native_1.3.4.bb
new file mode 100644
index 0000000000..71b45afdf4
--- /dev/null
+++ b/recipes/xorg-lib/libx11-native_1.3.4.bb
@@ -0,0 +1,8 @@
+require libx11_${PV}.bb
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libx11"
+
+DEPENDS = "xproto-native xextproto-native libxau-native xtrans-native libxdmcp-native xcmiscproto-native xf86bigfontproto-native kbproto-native inputproto-native bigreqsproto-native util-macros-native"
+PROVIDES = ""
+
+inherit native
diff --git a/recipes/xorg-lib/libx11_1.3.4.bb b/recipes/xorg-lib/libx11_1.3.4.bb
new file mode 100644
index 0000000000..1a7432caa6
--- /dev/null
+++ b/recipes/xorg-lib/libx11_1.3.4.bb
@@ -0,0 +1,37 @@
+require xorg-lib-common.inc
+
+DESCRIPTION = "Base X libs."
+DEPENDS += "bigreqsproto xproto xextproto xtrans libxau xcmiscproto \
+ libxdmcp xf86bigfontproto kbproto inputproto xproto-native"
+PROVIDES = "virtual/libx11"
+PE = "1"
+PR = "r7"
+
+XORG_PN = "libX11"
+
+SRC_URI += "file://x11_disable_makekeys.patch \
+ file://dolt-fix.patch \
+ ${@['file://keysymdef_include.patch', ''][(bb.data.inherits_class('native', d))]} \
+"
+
+# --with-keysymdef has intentionally no effect in native build without without keysymdef_include.patch
+EXTRA_OECONF += "--without-xcb --with-keysymdef=${STAGING_INCDIR}/X11/keysymdef.h"
+
+do_compile() {
+ (
+ unset CC LD CXX CCLD CFLAGS CPPFLAGS LDFLAGS CXXFLAGS
+ cd src/util;
+ mv makekeys.c.orig makekeys.c || true
+ touch makekeys-makekeys.o ; ${BUILD_CC} ${BUILD_CFLAGS} -I${STAGING_INCDIR_NATIVE} makekeys.c -o makekeys
+ # mv to stop it getting rebuilt
+ mv makekeys.c makekeys.c.orig
+ cd ../../
+ ) || exit 1
+ oe_runmake
+}
+
+FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${libdir}/X11/Xcms.txt"
+FILES_${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"
+
+SRC_URI[archive.md5sum] = "f65c9c7ecbfb64c19dbd7927160d63fd"
+SRC_URI[archive.sha256sum] = "88d7238ce5f7cd123450567de7a3b56a43556e4ccc45df38b8324147c889a844"
diff --git a/recipes/xorg-lib/libxcomposite_0.4.2.bb b/recipes/xorg-lib/libxcomposite_0.4.2.bb
new file mode 100644
index 0000000000..775e5aa812
--- /dev/null
+++ b/recipes/xorg-lib/libxcomposite_0.4.2.bb
@@ -0,0 +1,12 @@
+require xorg-lib-common.inc
+
+DESCRIPTION = "X Composite extension library."
+LICENSE= "BSD-X"
+DEPENDS += " compositeproto virtual/libx11 libxfixes libxext"
+PROVIDES = "xcomposite"
+PE = "1"
+
+XORG_PN = "libXcomposite"
+
+SRC_URI[archive.md5sum] = "e38dc98509149083f6c31b49b484e63c"
+SRC_URI[archive.sha256sum] = "442bde0bf7684330d6f5e4dd5a6faa46f1950512ff4e7bb6c01b36702166f800"
diff --git a/recipes/xorg-lib/libxdamage_1.1.3.bb b/recipes/xorg-lib/libxdamage_1.1.3.bb
new file mode 100644
index 0000000000..bcef444951
--- /dev/null
+++ b/recipes/xorg-lib/libxdamage_1.1.3.bb
@@ -0,0 +1,13 @@
+require xorg-lib-common.inc
+
+DESCRIPTION = "X11 damaged region extension library"
+LICENSE= "BSD-X"
+DEPENDS += "damageproto libxfixes"
+PROVIDES = "xdamage"
+PR = "r1"
+PE = "1"
+
+XORG_PN = "libXdamage"
+
+SRC_URI[archive.md5sum] = "44774e1a065158b52f1a0da5100cebec"
+SRC_URI[archive.sha256sum] = "bc6169c826d3cb17435ca84e1b479d65e4b51df1e48bbc3ec39a9cabf842c7a8"
diff --git a/recipes/xorg-lib/libxext-native_1.1.2.bb b/recipes/xorg-lib/libxext-native_1.1.2.bb
new file mode 100644
index 0000000000..40ddf6585f
--- /dev/null
+++ b/recipes/xorg-lib/libxext-native_1.1.2.bb
@@ -0,0 +1,14 @@
+require xorg-lib-common.inc
+
+DESCRIPTION = "X11 miscellaneous extension library"
+DEPENDS += "xproto-native libx11-native xextproto-native libxau-native util-macros-native"
+PROVIDES = ""
+PR = "r1"
+PE = "1"
+
+XORG_PN = "libXext"
+
+inherit native
+
+SRC_URI[archive.md5sum] = "9e51f9cb7e0a38c7099ac1c0de1a1add"
+SRC_URI[archive.sha256sum] = "ac6a0ff69c52c9b6e2096e5f74e22c8b5eef11ade4e30411cffeb7df32fe4f74"
diff --git a/recipes/xorg-lib/libxext_1.1.2.bb b/recipes/xorg-lib/libxext_1.1.2.bb
new file mode 100644
index 0000000000..7d37c5c3c8
--- /dev/null
+++ b/recipes/xorg-lib/libxext_1.1.2.bb
@@ -0,0 +1,12 @@
+require xorg-lib-common.inc
+
+DESCRIPTION = "X11 miscellaneous extension library"
+DEPENDS += "xproto virtual/libx11 xextproto libxau"
+PROVIDES = "xext"
+PR = "r1"
+PE = "1"
+
+XORG_PN = "libXext"
+
+SRC_URI[archive.md5sum] = "9e51f9cb7e0a38c7099ac1c0de1a1add"
+SRC_URI[archive.sha256sum] = "ac6a0ff69c52c9b6e2096e5f74e22c8b5eef11ade4e30411cffeb7df32fe4f74"
diff --git a/recipes/xorg-lib/libxfixes-native_4.0.5.bb b/recipes/xorg-lib/libxfixes-native_4.0.5.bb
new file mode 100644
index 0000000000..5ef6ded80a
--- /dev/null
+++ b/recipes/xorg-lib/libxfixes-native_4.0.5.bb
@@ -0,0 +1,6 @@
+require libxfixes_${PV}.bb
+
+DEPENDS = "libx11-native"
+PE = "1"
+
+inherit native
diff --git a/recipes/xorg-lib/libxfixes_4.0.5.bb b/recipes/xorg-lib/libxfixes_4.0.5.bb
new file mode 100644
index 0000000000..e6a78bb4ac
--- /dev/null
+++ b/recipes/xorg-lib/libxfixes_4.0.5.bb
@@ -0,0 +1,11 @@
+require xorg-lib-common.inc
+
+DESCRIPTION = "X Fixes extension library."
+LICENSE= "BSD-X"
+DEPENDS += "virtual/libx11 xproto fixesproto xextproto"
+PE = "1"
+
+XORG_PN = "libXfixes"
+
+SRC_URI[archive.md5sum] = "1b4b8386bd5d1751b2c7177223ad4629"
+SRC_URI[archive.sha256sum] = "2e6cd020460e4ef5d5a1d9b5d21143e9f5e580036a79c7de26ae539d7bcb8d74"
diff --git a/recipes/xorg-lib/libxrender-native_0.9.6.bb b/recipes/xorg-lib/libxrender-native_0.9.6.bb
new file mode 100644
index 0000000000..a4f4ba9e36
--- /dev/null
+++ b/recipes/xorg-lib/libxrender-native_0.9.6.bb
@@ -0,0 +1,6 @@
+require libxrender_${PV}.bb
+
+DEPENDS = "libx11-native renderproto-native"
+PE = "1"
+
+inherit native
diff --git a/recipes/xorg-lib/libxrender_0.9.6.bb b/recipes/xorg-lib/libxrender_0.9.6.bb
new file mode 100644
index 0000000000..7d7510d823
--- /dev/null
+++ b/recipes/xorg-lib/libxrender_0.9.6.bb
@@ -0,0 +1,11 @@
+require xorg-lib-common.inc
+
+DESCRIPTION = "X11 Rendering Extension client library"
+LICENSE = "BSD-X"
+DEPENDS += "virtual/libx11 renderproto xproto xdmcp"
+PE = "1"
+
+XORG_PN = "libXrender"
+
+SRC_URI[archive.md5sum] = "3b3b7d076c2384b6c600c0b5f4ba971f"
+SRC_URI[archive.sha256sum] = "7f58b1e263109e0a873eef8423aa14733a5499befbe645053aa622ed1f3ea668"