aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-lib
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-04-28 15:55:09 +0200
committerMarcin Juszkiewicz <hrw@openembedded.org>2009-04-28 15:57:48 +0200
commite264996efb684cfad7c196ea19be1b1dc060dccc (patch)
tree21c816fd551376cb0ec83a9359c2e93fb5909b27 /recipes/xorg-lib
parentc4cd2af6385c4937d1e6905bc6ebc49516267e15 (diff)
downloadopenembedded-e264996efb684cfad7c196ea19be1b1dc060dccc.tar.gz
Reverted all commits done by Robert Schuster.
Each change to stable/2009 branch needs to be reviewed and acked by stable branch maintainers. Signed-off-by: Marcin Juszkiewicz <hrw@openembedded.org>
Diffstat (limited to 'recipes/xorg-lib')
-rw-r--r--recipes/xorg-lib/libxt/pr10970-header-fix.patch512
-rw-r--r--recipes/xorg-lib/libxt_1.0.4.bb4
-rw-r--r--recipes/xorg-lib/libxt_1.0.5.bb4
3 files changed, 1 insertions, 519 deletions
diff --git a/recipes/xorg-lib/libxt/pr10970-header-fix.patch b/recipes/xorg-lib/libxt/pr10970-header-fix.patch
deleted file mode 100644
index 2acafb8b34..0000000000
--- a/recipes/xorg-lib/libxt/pr10970-header-fix.patch
+++ /dev/null
@@ -1,512 +0,0 @@
-diff --git a/include/X11/CallbackI.h b/include/X11/CallbackI.h
-index 4ae08ab..64e8152 100644
---- a/include/X11/CallbackI.h
-+++ b/include/X11/CallbackI.h
-@@ -58,6 +58,8 @@ typedef XrmResource **CallbackTable;
- #define _XtCBCalling 1
- #define _XtCBFreeAfterCalling 2
-
-+_XFUNCPROTOBEGIN
-+
- typedef struct internalCallbackRec {
- unsigned short count;
- char is_padded; /* contains NULL padding for external form */
-@@ -115,3 +117,5 @@ extern void _XtCallConditionalCallbackList(
- XtPointer /* call_data */,
- _XtConditionProc /* cond_proc */
- );
-+
-+_XFUNCPROTOEND
-diff --git a/include/X11/CompositeP.h b/include/X11/CompositeP.h
-index ed055b2..e93275a 100644
---- a/include/X11/CompositeP.h
-+++ b/include/X11/CompositeP.h
-@@ -52,6 +52,8 @@ SOFTWARE.
-
- #include <X11/Composite.h>
-
-+_XFUNCPROTOBEGIN
-+
- /************************************************************************
- *
- * Additional instance fields for widgets of (sub)class 'Composite'
-@@ -101,6 +103,8 @@ typedef struct _CompositeClassRec {
-
- externalref CompositeClassRec compositeClassRec;
-
-+_XFUNCPROTOEND
-+
- #define XtCompositeExtensionVersion 2L
- #define XtInheritGeometryManager ((XtGeometryHandler) _XtInherit)
- #define XtInheritChangeManaged ((XtWidgetProc) _XtInherit)
-diff --git a/include/X11/ConstrainP.h b/include/X11/ConstrainP.h
-index a90d19a..7030a34 100644
---- a/include/X11/ConstrainP.h
-+++ b/include/X11/ConstrainP.h
-@@ -52,6 +52,8 @@ SOFTWARE.
-
- #include <X11/Constraint.h>
-
-+_XFUNCPROTOBEGIN
-+
- typedef struct _ConstraintPart {
- XtPointer mumble; /* No new fields, keep C compiler happy */
- } ConstraintPart;
-@@ -88,6 +90,8 @@ typedef struct _ConstraintClassRec {
-
- externalref ConstraintClassRec constraintClassRec;
-
-+_XFUNCPROTOEND
-+
- #define XtConstraintExtensionVersion 1L
-
- #endif /* _XtConstraintP_h */
-diff --git a/include/X11/Constraint.h b/include/X11/Constraint.h
-index 9bb962e..b8bd902 100644
---- a/include/X11/Constraint.h
-+++ b/include/X11/Constraint.h
-@@ -50,11 +50,15 @@ SOFTWARE.
- #ifndef _XtConstraint_h
- #define _XtConstraint_h
-
-+_XFUNCPROTOBEGIN
-+
- typedef struct _ConstraintClassRec *ConstraintWidgetClass;
-
- #ifndef CONSTRAINT
- externalref WidgetClass constraintWidgetClass;
- #endif
-
-+_XFUNCPROTOEND
-+
- #endif /* _XtConstraint_h */
- /* DON'T ADD STUFF AFTER THIS #endif */
-diff --git a/include/X11/ConvertI.h b/include/X11/ConvertI.h
-index 02c0e5c..f3f7fb0 100644
---- a/include/X11/ConvertI.h
-+++ b/include/X11/ConvertI.h
-@@ -48,6 +48,8 @@ SOFTWARE.
- ******************************************************************/
- /* $XFree86: xc/lib/Xt/ConvertI.h,v 1.3 2001/12/14 19:56:09 dawes Exp $ */
-
-+_XFUNCPROTOBEGIN
-+
- /* Representation types */
-
- extern XrmQuark _XtQString;
-@@ -94,3 +96,4 @@ extern Boolean _XtConvert(
-
- void _XtConvertInitialize(void);
-
-+_XFUNCPROTOEND
-diff --git a/include/X11/Core.h b/include/X11/Core.h
-index ff6cb75..e1a7c28 100644
---- a/include/X11/Core.h
-+++ b/include/X11/Core.h
-@@ -53,6 +53,8 @@ SOFTWARE.
- #ifndef _XtCore_h
- #define _XtCore_h
-
-+_XFUNCPROTOBEGIN
-+
- typedef struct _WidgetClassRec *CoreWidgetClass;
- typedef struct _WidgetRec *CoreWidget;
- externalref WidgetClass coreWidgetClass;
-@@ -62,5 +64,7 @@ externalref WidgetClass widgetClass;
-
- #endif
-
-+_XFUNCPROTOEND
-+
- #endif /* _XtCore_h */
- /* DON'T ADD STUFF AFTER THIS #endif */
-diff --git a/include/X11/CoreP.h b/include/X11/CoreP.h
-index e07f085..57836e6 100644
---- a/include/X11/CoreP.h
-+++ b/include/X11/CoreP.h
-@@ -55,6 +55,8 @@ SOFTWARE.
-
- #include <X11/Core.h>
-
-+_XFUNCPROTOBEGIN
-+
- externalref int _XtInheritTranslations;
-
- #define XtInheritTranslations ((String) &_XtInheritTranslations)
-@@ -167,5 +169,7 @@ typedef struct _WidgetClassRec {
- externalref WidgetClassRec widgetClassRec;
- #define coreClassRec widgetClassRec
-
-+_XFUNCPROTOEND
-+
- #endif /* _XtCoreP_h */
- /* DON'T ADD STUFF AFTER THIS #endif */
-diff --git a/include/X11/CreateI.h b/include/X11/CreateI.h
-index 87abb1d..e0ca9a3 100644
---- a/include/X11/CreateI.h
-+++ b/include/X11/CreateI.h
-@@ -3,6 +3,8 @@
- #ifndef _XtcreateI_h
- #define _XtcreateI_h
-
-+_XFUNCPROTOBEGIN
-+
- extern Widget _XtCreateWidget(String name, WidgetClass widget_class,
- Widget parent, ArgList args, Cardinal num_args,
- XtTypedArgList typed_args,
-@@ -18,9 +20,12 @@ extern Widget _XtAppCreateShell(String name, String class,
- Cardinal num_typed_args);
- extern Widget _XtCreateHookObj(Screen *screen);
-
-+_XFUNCPROTOEND
-
- #include <stdarg.h>
-
-+_XFUNCPROTOBEGIN
-+
- /* VarCreate.c */
- extern Widget _XtVaOpenApplication(XtAppContext *app_context_return,
- _Xconst char* application_class,
-@@ -34,4 +39,6 @@ extern Widget _XtVaAppInitialize(XtAppContext *app_context_return,
- int *argc_in_out, String *argv_in_out,
- String *fallback_resources, va_list var_args);
-
-+_XFUNCPROTOEND
-+
- #endif /* _XtcreateI_h */
-diff --git a/include/X11/EventI.h b/include/X11/EventI.h
-index 00858e7..d2d1d0f 100644
---- a/include/X11/EventI.h
-+++ b/include/X11/EventI.h
-@@ -65,6 +65,8 @@ typedef struct _XtGrabRec *XtGrabList;
-
- #include "PassivGraI.h"
-
-+_XFUNCPROTOBEGIN
-+
- extern void _XtEventInitialize(
- void
- );
-@@ -131,4 +133,6 @@ extern void _XtFillAncestorList(Widget **listPtr, int *maxElemsPtr,
- /* NextEvent.c */
- extern Boolean XtAppPeekEvent_SkipTimer;
-
-+_XFUNCPROTOEND
-+
- #endif /* _Event_h_ */
-diff --git a/include/X11/HookObjI.h b/include/X11/HookObjI.h
-index c9a22a2..c0858c2 100644
---- a/include/X11/HookObjI.h
-+++ b/include/X11/HookObjI.h
-@@ -29,6 +29,8 @@ in this Software without prior written authorization from The Open Group.
- #ifndef _XtHookObjI_h
- #define _XtHookObjI_h
-
-+_XFUNCPROTOBEGIN
-+
- /* This object is implementation-dependent and private to the library. */
-
- typedef struct _HookObjRec *HookObject;
-@@ -66,6 +68,8 @@ typedef struct _HookObjClassRec {
-
- externalref HookObjClassRec hookObjClassRec;
-
-+_XFUNCPROTOEND
-+
- #endif /* ifndef _Xt_HookObjI_h */
-
-
-diff --git a/include/X11/InitialI.h b/include/X11/InitialI.h
-index c2fe47c..2ae9b74 100644
---- a/include/X11/InitialI.h
-+++ b/include/X11/InitialI.h
-@@ -84,6 +84,8 @@ SOFTWARE.
- #include <X11/Xos.h>
- #include <X11/Xpoll.h>
-
-+_XFUNCPROTOBEGIN
-+
- typedef struct _TimerEventRec {
- struct timeval te_timer_value;
- struct _TimerEventRec *te_next;
-@@ -426,4 +428,6 @@ extern XrmDatabase _XtPreparseCommandLine(XrmOptionDescRec *urlist,
- String *applName, String *displayName,
- String *language);
-
-+_XFUNCPROTOEND
-+
- #endif /* _XtinitialI_h */
-diff --git a/include/X11/IntrinsicI.h b/include/X11/IntrinsicI.h
-index d749867..d88166f 100644
---- a/include/X11/IntrinsicI.h
-+++ b/include/X11/IntrinsicI.h
-@@ -194,6 +194,8 @@ SOFTWARE.
- #define ERRORDB "/usr/lib/X11/XtErrorDB"
- #endif
-
-+_XFUNCPROTOBEGIN
-+
- extern String XtCXtToolkitError;
-
- extern void _XtAllocError(
-@@ -257,5 +259,7 @@ extern char* __XtCalloc (
- #define __XtCalloc XtCalloc
- #endif
-
-+_XFUNCPROTOEND
-+
- #endif /* _XtintrinsicI_h */
- /* DON'T ADD STUFF AFTER THIS #endif */
-diff --git a/include/X11/Object.h b/include/X11/Object.h
-index 96723b1..2c84aaf 100644
---- a/include/X11/Object.h
-+++ b/include/X11/Object.h
-@@ -50,11 +50,16 @@ SOFTWARE.
- #ifndef _XtObject_h
- #define _XtObject_h
-
-+_XFUNCPROTOBEGIN
-+
- typedef struct _ObjectRec *Object;
- typedef struct _ObjectClassRec *ObjectClass;
-
- #ifndef OBJECT
- externalref WidgetClass objectClass;
- #endif
-+
-+_XFUNCPROTOEND
-+
- #endif /* _XtObject_h */
- /* DON'T ADD STUFF AFTER THIS #endif */
-diff --git a/include/X11/ObjectP.h b/include/X11/ObjectP.h
-index a24564e..0f484d2 100644
---- a/include/X11/ObjectP.h
-+++ b/include/X11/ObjectP.h
-@@ -52,6 +52,8 @@ SOFTWARE.
-
- #include <X11/Object.h>
-
-+_XFUNCPROTOBEGIN
-+
- /**********************************************************
- * Object Instance Data Structures
- *
-@@ -132,6 +134,8 @@ typedef struct _ObjectClassRec {
-
- externalref ObjectClassRec objectClassRec;
-
-+_XFUNCPROTOEND
-+
- #define XtObjectExtensionVersion 1L
- #define XtInheritAllocate ((XtAllocateProc) _XtInherit)
- #define XtInheritDeallocate ((XtDeallocateProc) _XtInherit)
-diff --git a/include/X11/PassivGraI.h b/include/X11/PassivGraI.h
-index 02e2964..10591ac 100644
---- a/include/X11/PassivGraI.h
-+++ b/include/X11/PassivGraI.h
-@@ -60,6 +60,8 @@ in this Software without prior written authorization from The Open Group.
- #define KEYBOARD TRUE
- #define POINTER FALSE
-
-+_XFUNCPROTOBEGIN
-+
- typedef enum {
- XtNoServerGrab,
- XtPassiveServerGrab,
-@@ -183,4 +185,6 @@ extern void _XtClearAncestorCache(
- Widget /* widget */
- );
-
-+_XFUNCPROTOEND
-+
- #endif /* _PDI_h_ */
-diff --git a/include/X11/RectObj.h b/include/X11/RectObj.h
-index 07615fa..dced5c3 100644
---- a/include/X11/RectObj.h
-+++ b/include/X11/RectObj.h
-@@ -50,11 +50,16 @@ SOFTWARE.
- #ifndef _XtRect_h
- #define _XtRect_h
-
-+_XFUNCPROTOBEGIN
-+
- typedef struct _RectObjRec *RectObj;
- typedef struct _RectObjClassRec *RectObjClass;
-
- #ifndef RECTOBJ
- externalref WidgetClass rectObjClass;
- #endif
-+
-+_XFUNCPROTOEND
-+
- #endif /* _XtRect_h */
- /* DON'T ADD STUFF AFTER THIS #endif */
-diff --git a/include/X11/RectObjP.h b/include/X11/RectObjP.h
-index ca3b8ad..d6ffb78 100644
---- a/include/X11/RectObjP.h
-+++ b/include/X11/RectObjP.h
-@@ -53,6 +53,8 @@ SOFTWARE.
- #include <X11/RectObj.h>
- #include <X11/ObjectP.h>
-
-+_XFUNCPROTOBEGIN
-+
- /**********************************************************
- * Rectangle Object Instance Data Structures
- *
-@@ -126,4 +128,6 @@ typedef struct _RectObjClassRec {
-
- externalref RectObjClassRec rectObjClassRec;
-
-+_XFUNCPROTOEND
-+
- #endif /*_Xt_RectObjP_h_*/
-diff --git a/include/X11/ResourceI.h b/include/X11/ResourceI.h
-index d6ed1df..3db97f8 100644
---- a/include/X11/ResourceI.h
-+++ b/include/X11/ResourceI.h
-@@ -61,6 +61,8 @@ SOFTWARE.
- #define StringToName(string) XrmStringToName(string)
- #define StringToClass(string) XrmStringToClass(string)
-
-+_XFUNCPROTOBEGIN
-+
- extern void _XtDependencies(
- XtResourceList * /* class_resp */,
- Cardinal * /* class_num_resp */,
-@@ -96,5 +98,6 @@ extern XrmResourceList* _XtCreateIndirectionTable(XtResourceList resources,
- Cardinal num_resources);
- extern void _XtResourceListInitialize(void);
-
-+_XFUNCPROTOEND
-
- #endif /* _XtresourceI_h */
-diff --git a/include/X11/ShellP.h b/include/X11/ShellP.h
-index 2b08c3f..7297d33 100644
---- a/include/X11/ShellP.h
-+++ b/include/X11/ShellP.h
-@@ -67,6 +67,8 @@ SOFTWARE.
- * *****
- */
-
-+_XFUNCPROTOBEGIN
-+
- /***********************************************************************
- *
- * Shell Widget Private Data
-@@ -214,8 +216,12 @@ typedef struct {
- WMShellPart wm;
- } WMShellRec, *WMShellWidget;
-
-+_XFUNCPROTOEND
-+
- #include <X11/VendorP.h>
-
-+_XFUNCPROTOBEGIN
-+
- /***********************************************************************
- *
- * TransientShell Widget Private Data
-@@ -425,4 +431,6 @@ typedef struct {
- SessionShellPart session;
- } SessionShellRec, *SessionShellWidget;
-
-+_XFUNCPROTOEND
-+
- #endif /* _XtShellPrivate_h */
-diff --git a/include/X11/ThreadsI.h b/include/X11/ThreadsI.h
-index 1492d77..28cbc98 100644
---- a/include/X11/ThreadsI.h
-+++ b/include/X11/ThreadsI.h
-@@ -81,6 +81,8 @@ typedef void (*ThreadAppRestoreLockProc)(
- Boolean* /* pushed_thread */
- );
-
-+_XFUNCPROTOBEGIN
-+
- extern void (*_XtProcessLock)(
- void
- );
-@@ -93,6 +95,8 @@ extern void (*_XtInitAppLock)(
- XtAppContext /* app */
- );
-
-+_XFUNCPROTOEND
-+
- #define INIT_APP_LOCK(app) if(_XtInitAppLock) (*_XtInitAppLock)(app)
- #define FREE_APP_LOCK(app) if(app && app->free_lock)(*app->free_lock)(app)
-
-diff --git a/include/X11/TranslateI.h b/include/X11/TranslateI.h
-index 1224875..6cc3099 100644
---- a/include/X11/TranslateI.h
-+++ b/include/X11/TranslateI.h
-@@ -342,6 +342,8 @@ typedef struct _TMGlobalRec{
- #endif /* TRACE_TM */
- }TMGlobalRec;
-
-+_XFUNCPROTOBEGIN
-+
- extern TMGlobalRec _XtGlobalTM;
-
- #define TM_MOD_SEGMENT_SIZE 16
-@@ -604,3 +606,4 @@ extern void _XtUnmergeTranslations(
- /* TMKey.c */
- extern void _XtAllocTMContext(XtPerDisplay pd);
-
-+_XFUNCPROTOEND
-diff --git a/include/X11/VarargsI.h b/include/X11/VarargsI.h
-index e15404a..76ce9bc 100644
---- a/include/X11/VarargsI.h
-+++ b/include/X11/VarargsI.h
-@@ -34,6 +34,8 @@ in this Software without prior written authorization from The Open Group.
-
- /* private routines */
-
-+_XFUNCPROTOBEGIN
-+
- extern void _XtCountVaList(
- va_list /*var*/, int* /*total_count*/, int* /*typed_count*/
- );
-@@ -62,4 +64,6 @@ extern void _XtGetSubresources(
- Widget /*w*/, XtPointer /*base*/, const char* /*name*/, const char* /*class*/, XtResourceList /*resources*/, Cardinal /*num_resources*/, ArgList /*args*/, Cardinal /*num_args*/, XtTypedArgList /*typed_args*/, Cardinal /*num_typed_args*/
- );
-
-+_XFUNCPROTOEND
-+
- #endif /* _VarargsI_h_ */
-diff --git a/include/X11/Vendor.h b/include/X11/Vendor.h
-index 65e7c38..633d17a 100644
---- a/include/X11/Vendor.h
-+++ b/include/X11/Vendor.h
-@@ -65,7 +65,11 @@ SOFTWARE.
-
- typedef struct _VendorShellClassRec *VendorShellWidgetClass;
-
-+_XFUNCPROTOBEGIN
-+
- externalref WidgetClass vendorShellWidgetClass;
-
-+_XFUNCPROTOEND
-+
- #endif /* _XtVendor_h */
- /* DON'T ADD STUFF AFTER THIS #endif */
-diff --git a/include/X11/VendorP.h b/include/X11/VendorP.h
-index 08bf689..e60857d 100644
---- a/include/X11/VendorP.h
-+++ b/include/X11/VendorP.h
-@@ -72,6 +72,8 @@ SOFTWARE.
-
- /* New fields for the VendorShell widget class record */
-
-+_XFUNCPROTOBEGIN
-+
- typedef struct {
- XtPointer extension; /* pointer to extension record */
- } VendorShellClassPart;
-@@ -100,4 +102,6 @@ typedef struct {
- VendorShellPart vendor;
- } VendorShellRec, *VendorShellWidget;
-
-+_XFUNCPROTOEND
-+
- #endif /* _XtVendorPrivate_h */
diff --git a/recipes/xorg-lib/libxt_1.0.4.bb b/recipes/xorg-lib/libxt_1.0.4.bb
index 3911b78382..e67590bdf1 100644
--- a/recipes/xorg-lib/libxt_1.0.4.bb
+++ b/recipes/xorg-lib/libxt_1.0.4.bb
@@ -9,10 +9,6 @@ PROVIDES = "xt"
XORG_PN = "libXt"
-SRC_URI += "file://pr10970-header-fix.patch;patch=1"
-
-PR = "r1"
-
EXTRA_OECONF="--enable-malloc0returnsnull --disable-install-makestrs --disable-xkb"
do_compile() {
diff --git a/recipes/xorg-lib/libxt_1.0.5.bb b/recipes/xorg-lib/libxt_1.0.5.bb
index 47b980e650..4190a1158b 100644
--- a/recipes/xorg-lib/libxt_1.0.5.bb
+++ b/recipes/xorg-lib/libxt_1.0.5.bb
@@ -3,13 +3,11 @@ require xorg-lib-common.inc
DESCRIPTION = "X11 toolkit intrinsics library"
DEPENDS += "libsm virtual/libx11 kbproto"
PROVIDES = "xt"
-PR = "r2"
+PR = "r1"
PE = "1"
XORG_PN = "libXt"
-SRC_URI += "file://pr10970-header-fix.patch;patch=1"
-
EXTRA_OECONF += "--disable-install-makestrs --disable-xkb"
do_compile() {