aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-xserver/xserver-xorg_1.10.0.902.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-04-06 10:37:22 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-04-11 15:12:26 +0200
commita39e33b7a508849a6dffe577370d7a80fbf26511 (patch)
tree9f92e55829e201f855c917c677029e8184734c99 /recipes/xorg-xserver/xserver-xorg_1.10.0.902.bb
parent69f50f3c0314532d823dc2ce56b87de4ad24b04c (diff)
downloadopenembedded-a39e33b7a508849a6dffe577370d7a80fbf26511.tar.gz
xorg: add new versions
* xserver-xorg-1.10 is added with D_P -1 until xf86-input-tslib is ported, so 1.9.4 is still default version * xserver-xorg-1.10, dolt was removed in upstream a769f4c22a9cfb5ba248c924a66c31ec966bd8a0 * xserver-xorg-1.10, randr-support needs to be updated, but maybe won't be needed when new xinput-calibrator with config in xorg.conf.d is used (waiting for Marco) * xf86-input-tslib needs to be ported to XINPUT 12 ABI or obsoleted * tested only on om-gta02 and nokia900, please test xserver-xorg-1.10 on other devices Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-xserver/xserver-xorg_1.10.0.902.bb')
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.10.0.902.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg_1.10.0.902.bb b/recipes/xorg-xserver/xserver-xorg_1.10.0.902.bb
new file mode 100644
index 0000000000..9ac0c41843
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg_1.10.0.902.bb
@@ -0,0 +1,31 @@
+# Assign it here, since the hal->udev transition happens post 1.7 in angstrom
+DISTRO_XORG_CONFIG_MANAGER_angstrom = "udev"
+
+require xorg-xserver-common.inc
+
+DESCRIPTION = "the X.Org X server"
+DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts font-util-native"
+PE = "2"
+PR = "${INC_PR}.0"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += " \
+ file://hack-fbdev-ignore-return-mode.patch \
+ file://hack-assume-pixman-supports-overlapped-blt.patch \
+ "
+SRC_URI[archive.md5sum] = "65e5db9e614cd75e97840247c3754521"
+SRC_URI[archive.sha256sum] = "994ab87bb0cc9b56203e01e3294fddd502a96d074139496ea4ffc03c95b41b42"
+
+do_install_prepend() {
+ mkdir -p ${D}/${libdir}/X11/fonts
+}
+
+# The NVidia driver requires Xinerama support in the X server. Ion uses it.
+PACKAGE_ARCH_ion = "${MACHINE_ARCH}"
+XINERAMA = "${@['--disable-xinerama','--enable-xinerama'][bb.data.getVar('MACHINE',d) in ['ion']]}"
+
+EXTRA_OECONF += " ${CONFIG_MANAGER_OPTION} ${XINERAMA} --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
+EXTRA_OECONF += " --enable-dri2 --disable-unit-tests --disable-docs --disable-devel-docs"
+
+export LDFLAGS += " -ldl "