summaryrefslogtreecommitdiffstats
path: root/recipes/xorg-xserver
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-04-14 14:30:35 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-04-14 15:02:53 +0200
commitde9e047739390cba58dc6b8e0e0053ef639cdcb8 (patch)
tree967edfb367b6b6537453756b00b7477e1eaa9fbe /recipes/xorg-xserver
parentdcf2f855ea84370d450fb0d14ebfc5a91093318d (diff)
downloadopenembedded-de9e047739390cba58dc6b8e0e0053ef639cdcb8.tar.gz
xserver-xorg 1.7.4,1.8.0,git : make it MACHINE_ARCH for ion and bump PR
In case of ion(a machine),Xorg is configured with --enable-xinerama, But xorg is not MACHINE_ARCH anymore,so that's problematic. The easiest fix as suggested in #oe is this one: <XorA> needs PACKAGE_ARCH_ion = "${MACHINE_ARCH}" then PR was also bumped(advise taken in #oe): <GNUtoo> I'll also bump PR: PR = "${INC_PR}.0" => PR = "${INC_PR}.1" <GNUtoo> JaMa, is it ok to bump like this for xserver or does every xf86-somesystem-somedriver has to be rebuilt? <JaMa> GNUtoo: no, it should be fine.. <GNUtoo> ok thanks a lot <JaMa> drivers needs to be bumped only if ABI changed
Diffstat (limited to 'recipes/xorg-xserver')
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.7.4.bb3
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.8.0.bb3
-rw-r--r--recipes/xorg-xserver/xserver-xorg_git.bb3
3 files changed, 6 insertions, 3 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg_1.7.4.bb b/recipes/xorg-xserver/xserver-xorg_1.7.4.bb
index 1645ed6145..3424784805 100644
--- a/recipes/xorg-xserver/xserver-xorg_1.7.4.bb
+++ b/recipes/xorg-xserver/xserver-xorg_1.7.4.bb
@@ -3,7 +3,7 @@ require xorg-xserver-common.inc
DESCRIPTION = "the X.Org X server"
DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts"
PE = "2"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI += "file://sysroot_fix.patch;patch=1 \
file://dolt-fix-1.7.0.patch;patch=1 \
@@ -19,6 +19,7 @@ do_install_prepend() {
}
# The NVidia driver requires Xinerama support in the X server. Ion uses it.
+PACKAGE_ARCH_ion = "${MACHINE_ARCH}"
XINERAMA = "${@['--disable-xinerama','--enable-xinerama'][bb.data.getVar('MACHINE',d) in ['ion']]}"
EXTRA_OECONF += " ${CONFIG_MANAGER_OPTION} ${XINERAMA} --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
diff --git a/recipes/xorg-xserver/xserver-xorg_1.8.0.bb b/recipes/xorg-xserver/xserver-xorg_1.8.0.bb
index 4d1630c5e2..0bd187d794 100644
--- a/recipes/xorg-xserver/xserver-xorg_1.8.0.bb
+++ b/recipes/xorg-xserver/xserver-xorg_1.8.0.bb
@@ -3,7 +3,7 @@ require xorg-xserver-common.inc
DESCRIPTION = "the X.Org X server"
DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts font-util-native"
PE = "2"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
# Needs newer mesa-dri, where is D_P = "-1"
DEFAULT_PREFERENCE = "-1"
@@ -25,6 +25,7 @@ do_install_prepend() {
}
# The NVidia driver requires Xinerama support in the X server. Ion uses it.
+PACKAGE_ARCH_ion = "${MACHINE_ARCH}"
XINERAMA = "${@['--disable-xinerama','--enable-xinerama'][bb.data.getVar('MACHINE',d) in ['ion']]}"
EXTRA_OECONF += " ${CONFIG_MANAGER_OPTION} ${XINERAMA} --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
diff --git a/recipes/xorg-xserver/xserver-xorg_git.bb b/recipes/xorg-xserver/xserver-xorg_git.bb
index 47e797c633..47264ffc01 100644
--- a/recipes/xorg-xserver/xserver-xorg_git.bb
+++ b/recipes/xorg-xserver/xserver-xorg_git.bb
@@ -3,7 +3,7 @@ require xorg-xserver-common.inc
DESCRIPTION = "the X.Org X server"
DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts font-util-native"
PV = "1.7.999"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
PR_append = "+gitr${SRCREV}"
PE = "2"
@@ -23,6 +23,7 @@ do_install_prepend() {
}
# The NVidia driver requires Xinerama support in the X server. Ion uses it.
+PACKAGE_ARCH_ion = "${MACHINE_ARCH}"
XINERAMA = "${@['--disable-xinerama','--enable-xinerama'][bb.data.getVar('MACHINE',d) in ['ion']]}"
EXTRA_OECONF += " ${CONFIG_MANAGER_OPTION} ${XINERAMA} --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"