aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xserver-common
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-31 11:57:10 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-31 11:57:10 +0200
commit0e6b0d58f40668da496ff0209c93dd444e7b2fa0 (patch)
tree82859083eb393b029ffbcf7ad042aaebe71e2acb /recipes/xserver-common
parent83b88a7f144cceb0eb49710206d7172c586efe3c (diff)
downloadopenembedded-0e6b0d58f40668da496ff0209c93dd444e7b2fa0.tar.gz
xserver-common 1.24: fix xdg autostarting
* it belongs in the xsession, not in the xinit
Diffstat (limited to 'recipes/xserver-common')
-rw-r--r--recipes/xserver-common/files/89xdgautostart.sh6
-rw-r--r--recipes/xserver-common/xserver-common_1.24.bb4
2 files changed, 6 insertions, 4 deletions
diff --git a/recipes/xserver-common/files/89xdgautostart.sh b/recipes/xserver-common/files/89xdgautostart.sh
index db7aa229d2..9886f9fee1 100644
--- a/recipes/xserver-common/files/89xdgautostart.sh
+++ b/recipes/xserver-common/files/89xdgautostart.sh
@@ -1,7 +1,9 @@
+#!/bin/sh
+
XDGAUTOSTART=/etc/xdg/autostart
-if [ -d $XDGAUTOSTART ]; then
+if [ -d $XDGAUTOSTART ] ; then
for SCRIPT in $XDGAUTOSTART/*; do
CMD=`grep ^Exec= $SCRIPT | cut -d '=' -f 2`
$CMD &
done
-fi \ No newline at end of file
+fi
diff --git a/recipes/xserver-common/xserver-common_1.24.bb b/recipes/xserver-common/xserver-common_1.24.bb
index 27b4ba6a70..105916018f 100644
--- a/recipes/xserver-common/xserver-common_1.24.bb
+++ b/recipes/xserver-common/xserver-common_1.24.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts and support files"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
-PR = "r1"
+PR = "r3"
PACKAGE_ARCH = "all"
@@ -15,5 +15,5 @@ SRC_URI_append = " file://setDPI.sh \
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
- install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xinit.d/89xdgautostart.sh"
+ install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
}