aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xserver-common
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-07-31 15:44:23 +0200
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-08-03 14:50:28 +0200
commit3c6c036a1f3a04669aade14337200f7d55e050cf (patch)
treed3d3034461951e54633ab3b035c753128d0096c5 /recipes/xserver-common
parentc4817a241ca5df93f36647edae9206ecd1ec74b8 (diff)
downloadopenembedded-3c6c036a1f3a04669aade14337200f7d55e050cf.tar.gz
xserver-common: added 1.30 + patches
This will be 1.31 ;)
Diffstat (limited to 'recipes/xserver-common')
-rw-r--r--recipes/xserver-common/xserver-common-1.30/0018-zaurus-fixed-machine-names.patch35
-rw-r--r--recipes/xserver-common/xserver-common-1.30/0019-keymap-fixed-machine-names.patch59
-rw-r--r--recipes/xserver-common/xserver-common-1.30/0020-keymap-fixed-machine-names-again.patch50
-rw-r--r--recipes/xserver-common/xserver-common-1.30/0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch63
-rw-r--r--recipes/xserver-common/xserver-common-1.30/0022-xserver-fix-syntax-error.patch27
-rw-r--r--recipes/xserver-common/xserver-common_1.30.bb25
6 files changed, 259 insertions, 0 deletions
diff --git a/recipes/xserver-common/xserver-common-1.30/0018-zaurus-fixed-machine-names.patch b/recipes/xserver-common/xserver-common-1.30/0018-zaurus-fixed-machine-names.patch
new file mode 100644
index 0000000000..d6d6aa80f1
--- /dev/null
+++ b/recipes/xserver-common/xserver-common-1.30/0018-zaurus-fixed-machine-names.patch
@@ -0,0 +1,35 @@
+From a287e6414a765926fc7b169617bc1174370bc183 Mon Sep 17 00:00:00 2001
+From: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
+Date: Mon, 20 Jul 2009 18:57:56 +0200
+Subject: [PATCH 18/22] zaurus: fixed machine names
+
+
+Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
+---
+ X11/Xinit.d/11zaurus | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/X11/Xinit.d/11zaurus b/X11/Xinit.d/11zaurus
+index 02090be..54ea6f5 100644
+--- a/X11/Xinit.d/11zaurus
++++ b/X11/Xinit.d/11zaurus
+@@ -13,14 +13,14 @@ fi
+ $CHCK -e
+ if [ $? = 12 ]; then
+ case `machine_id` in
+- *Spitz | *Akita | *Borzoi)
++ *spitz | *akita | *borzoi)
+ DIRECTION="normal" ;;
+ *)
+ DIRECTION="right" ;;
+ esac
+ else
+ case `machine_id` in
+- *Spitz | *Akita | *Borzoi)
++ *spitz | *akita | *borzoi)
+ # Xfbdev needs to settle
+ sleep 2
+ DIRECTION="right" ;;
+--
+1.6.3.3
+
diff --git a/recipes/xserver-common/xserver-common-1.30/0019-keymap-fixed-machine-names.patch b/recipes/xserver-common/xserver-common-1.30/0019-keymap-fixed-machine-names.patch
new file mode 100644
index 0000000000..9a4e561518
--- /dev/null
+++ b/recipes/xserver-common/xserver-common-1.30/0019-keymap-fixed-machine-names.patch
@@ -0,0 +1,59 @@
+From e564699c60d69148e19150dc9d2105734b1df7e1 Mon Sep 17 00:00:00 2001
+From: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
+Date: Mon, 20 Jul 2009 18:58:54 +0200
+Subject: [PATCH 19/22] keymap: fixed machine names
+
+
+Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
+---
+ X11/Xinit.d/12keymap | 18 +++++++++---------
+ 1 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/X11/Xinit.d/12keymap b/X11/Xinit.d/12keymap
+index 0a909d0..cfa9750 100644
+--- a/X11/Xinit.d/12keymap
++++ b/X11/Xinit.d/12keymap
+@@ -1,31 +1,31 @@
+ #!/bin/sh
+
+-MACHINE=`awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo`
++. /etc/init.d/functions
+
+ # since kdrive 1.4 there is no default keymap in server
+ xmodmap - </etc/X11/xmodmap/default.xmodmap
+
+-case $MACHINE in
+- "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi")
++case `machine_id` in
++ "sharp shepherd" | "sharp husky" | "sharp corgi")
+ xmodmap - < /etc/X11/xmodmap/shepherd.xmodmap
+ ;;
+- "SHARP Akita" | "SHARP Borzoi" | "SHARP Spitz")
++ "sharp akita" | "sharp borzoi" | "sharp spitz")
+ xmodmap - < /etc/X11/xmodmap/slcXXXX.xmodmap
+ ;;
+- "SHARP Poodle")
++ "sharp poodle")
+ xmodmap - < /etc/X11/xmodmap/poodle.xmodmap
+ ;;
+- "Sharp-Collie")
++ "sharp-collie")
+ xmodmap - < /etc/X11/xmodmap/collie.xmodmap
+ ;;
+- "HP iPAQ h6300")
++ "hp ipaq h6300")
+ xmodmap - < /etc/X11/xmodmap/h6300.xmodmap
+ ;;
+- "TI-OSK")
++ "ti-osk")
+ xmodmap - < /etc/X11/xmodmap/omap5912osk.xmodmap
+ ;;
+ # All the rest of keyboardless PDA machines use common buttonmap
+- "Simpad" | "HP iPAQ"* | "Asus MyPal"*)
++ "simpad" | "hp ipaq"* | "asus mypal"*)
+ xmodmap - < /etc/X11/xmodmap/keyboardless.xmodmap
+ ;;
+ esac
+--
+1.6.3.3
+
diff --git a/recipes/xserver-common/xserver-common-1.30/0020-keymap-fixed-machine-names-again.patch b/recipes/xserver-common/xserver-common-1.30/0020-keymap-fixed-machine-names-again.patch
new file mode 100644
index 0000000000..f14f5ae3b2
--- /dev/null
+++ b/recipes/xserver-common/xserver-common-1.30/0020-keymap-fixed-machine-names-again.patch
@@ -0,0 +1,50 @@
+From f216da13941685575786e617c2cc072edd5b210c Mon Sep 17 00:00:00 2001
+From: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
+Date: Mon, 20 Jul 2009 19:01:08 +0200
+Subject: [PATCH 20/22] keymap: fixed machine names again
+
+
+Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
+---
+ X11/Xinit.d/12keymap | 10 +++++-----
+ 1 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/X11/Xinit.d/12keymap b/X11/Xinit.d/12keymap
+index cfa9750..7eac296 100644
+--- a/X11/Xinit.d/12keymap
++++ b/X11/Xinit.d/12keymap
+@@ -6,26 +6,26 @@
+ xmodmap - </etc/X11/xmodmap/default.xmodmap
+
+ case `machine_id` in
+- "sharp shepherd" | "sharp husky" | "sharp corgi")
++ "sharp_shepherd" | "sharp_husky" | "sharp_corgi")
+ xmodmap - < /etc/X11/xmodmap/shepherd.xmodmap
+ ;;
+- "sharp akita" | "sharp borzoi" | "sharp spitz")
++ "sharp_akita" | "sharp_borzoi" | "sharp_spitz")
+ xmodmap - < /etc/X11/xmodmap/slcXXXX.xmodmap
+ ;;
+- "sharp poodle")
++ "sharp_poodle")
+ xmodmap - < /etc/X11/xmodmap/poodle.xmodmap
+ ;;
+ "sharp-collie")
+ xmodmap - < /etc/X11/xmodmap/collie.xmodmap
+ ;;
+- "hp ipaq h6300")
++ "hp_ipaq_h6300")
+ xmodmap - < /etc/X11/xmodmap/h6300.xmodmap
+ ;;
+ "ti-osk")
+ xmodmap - < /etc/X11/xmodmap/omap5912osk.xmodmap
+ ;;
+ # All the rest of keyboardless PDA machines use common buttonmap
+- "simpad" | "hp ipaq"* | "asus mypal"*)
++ "simpad" | "hp_ipaq"* | "asus_mypal"*)
+ xmodmap - < /etc/X11/xmodmap/keyboardless.xmodmap
+ ;;
+ esac
+--
+1.6.3.3
+
diff --git a/recipes/xserver-common/xserver-common-1.30/0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch b/recipes/xserver-common/xserver-common-1.30/0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch
new file mode 100644
index 0000000000..4d9bfa21e8
--- /dev/null
+++ b/recipes/xserver-common/xserver-common-1.30/0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch
@@ -0,0 +1,63 @@
+From 3ada7e341334766f6be27164dbb43a3715faf580 Mon Sep 17 00:00:00 2001
+From: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
+Date: Tue, 21 Jul 2009 13:36:17 +0200
+Subject: [PATCH 21/22] xserver: introduced MOUSE variable for "-mouse" argument
+
+MOUSE is not passed in ARGS if Xorg server is used as it is KDrive only.
+
+Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
+---
+ X11/Xserver | 13 +++++++++----
+ 1 files changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/X11/Xserver b/X11/Xserver
+index 25ce816..e7e88d9 100755
+--- a/X11/Xserver
++++ b/X11/Xserver
+@@ -46,19 +46,20 @@ export XSERVER_DEFAULT_ORIENTATION=normal
+
+ ARGS="-br -pn $INPUT_EXTRA_ARGS"
+ DPI="100"
++MOUSE=""
+
+ # use ucb 1x00 touchscreen if present
+ if [ -z "$TSLIB_TSDEVICE" ] && [ -e /dev/touchscreen/ucb1x00 ]; then
+- ARGS="$ARGS -mouse /dev/touchscreen/ucb1x00"
++ MOUSE="-mouse /dev/touchscreen/ucb1x00"
+ fi
+
+ # kdrive 1.4 onwards needs -mouse args
+ # Xorg doesn't support "-mouse" option, and uses /dev/input/mice automatically
+ if [ -e "$TSLIB_TSDEVICE" ] ; then
+- ARGS="$ARGS -mouse tslib"
++ MOUSE="-mouse tslib"
+ else
+ if [ -e /dev/input/mice ] && [ "$XSERVER" != "Xorg" ] ; then
+- ARGS="$ARGS -mouse mouse"
++ MOUSE="-mouse mouse"
+ fi
+ fi
+
+@@ -103,7 +104,7 @@ else
+ ARGS="$ARGS -rgba rgb"
+ DPI="100" ;;
+ "generic_omap1510/1610/1710")
+- ARGS="$ARGS -mouse /dev/input/event0"
++ MOUSE="-mouse /dev/input/event0"
+ DPI="220" ;;
+ "ti-osk")
+ DPI="100" ;;
+@@ -183,6 +184,10 @@ else
+ esac
+ fi
+
++if [ "$XSERVER" != "Xorg" ] ; then
++ ARGS="$ARGS $MOUSE"
++fi
++
+ echo "tslib: $TSLIB_TSDEVICE"
+ echo "exec $XSERVER $ARGS -dpi $DPI $*"
+ exec $XSERVER $ARGS -dpi $DPI $*
+--
+1.6.3.3
+
diff --git a/recipes/xserver-common/xserver-common-1.30/0022-xserver-fix-syntax-error.patch b/recipes/xserver-common/xserver-common-1.30/0022-xserver-fix-syntax-error.patch
new file mode 100644
index 0000000000..e96fabf064
--- /dev/null
+++ b/recipes/xserver-common/xserver-common-1.30/0022-xserver-fix-syntax-error.patch
@@ -0,0 +1,27 @@
+From 00cbc2b27c7df84d7837760e05ac13b686e6bfa9 Mon Sep 17 00:00:00 2001
+From: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
+Date: Thu, 23 Jul 2009 12:04:12 +0200
+Subject: [PATCH 22/22] xserver: fix syntax error
+
+
+Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
+---
+ X11/Xserver | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/X11/Xserver b/X11/Xserver
+index e7e88d9..3d93a0a 100755
+--- a/X11/Xserver
++++ b/X11/Xserver
+@@ -63,7 +63,7 @@ else
+ fi
+ fi
+
+-if [ -e /etc/default/xserver ]
++if [ -e /etc/default/xserver ] ; then
+ . /etc/default/xserver
+ else
+ # start off server in conventional location.
+--
+1.6.3.3
+
diff --git a/recipes/xserver-common/xserver-common_1.30.bb b/recipes/xserver-common/xserver-common_1.30.bb
new file mode 100644
index 0000000000..23953a699f
--- /dev/null
+++ b/recipes/xserver-common/xserver-common_1.30.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
+PR = "r2"
+
+PACKAGE_ARCH = "all"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI_append = " file://setDPI.sh \
+ file://89xdgautostart.sh \
+file://0018-zaurus-fixed-machine-names.patch;patch=1 \
+file://0019-keymap-fixed-machine-names.patch;patch=1 \
+file://0020-keymap-fixed-machine-names-again.patch;patch=1 \
+file://0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch;patch=1 \
+file://0022-xserver-fix-syntax-error.patch;patch=1 \
+"
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+ install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
+ sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/Xserver
+}