aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xserver-common
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/xserver-common
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/xserver-common')
-rw-r--r--recipes/xserver-common/xserver-common_1.11.bb6
-rw-r--r--recipes/xserver-common/xserver-common_1.12.bb2
-rw-r--r--recipes/xserver-common/xserver-common_1.13.bb4
-rw-r--r--recipes/xserver-common/xserver-common_1.14.bb4
-rw-r--r--recipes/xserver-common/xserver-common_1.15.bb4
-rw-r--r--recipes/xserver-common/xserver-common_1.16.bb12
-rw-r--r--recipes/xserver-common/xserver-common_1.18.bb2
-rw-r--r--recipes/xserver-common/xserver-common_1.22.bb6
-rw-r--r--recipes/xserver-common/xserver-common_1.25.bb8
-rw-r--r--recipes/xserver-common/xserver-common_1.30.bb18
-rw-r--r--recipes/xserver-common/xserver-common_1.32.bb2
-rw-r--r--recipes/xserver-common/xserver-common_1.33.bb16
-rw-r--r--recipes/xserver-common/xserver-common_svn.bb12
13 files changed, 48 insertions, 48 deletions
diff --git a/recipes/xserver-common/xserver-common_1.11.bb b/recipes/xserver-common/xserver-common_1.11.bb
index c25080055e..c3727122f3 100644
--- a/recipes/xserver-common/xserver-common_1.11.bb
+++ b/recipes/xserver-common/xserver-common_1.11.bb
@@ -1,9 +1,9 @@
require xserver-common.inc
SRC_URI_append = " file://setDPI.sh \
- file://calibrate_zaurusd.patch;apply=yes \
- file://w100.patch;apply=yes \
- file://poodle-xmodmap-2.6.patch;apply=yes"
+ file://calibrate_zaurusd.patch \
+ file://w100.patch \
+ file://poodle-xmodmap-2.6.patch"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.12.bb b/recipes/xserver-common/xserver-common_1.12.bb
index 3b8545e821..b2661a6ef6 100644
--- a/recipes/xserver-common/xserver-common_1.12.bb
+++ b/recipes/xserver-common/xserver-common_1.12.bb
@@ -3,7 +3,7 @@ require xserver-common.inc
PR = "r1"
SRC_URI_append = " file://setDPI.sh \
- file://rxvt-less-pink.diff;apply=yes"
+ file://rxvt-less-pink.diff"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.13.bb b/recipes/xserver-common/xserver-common_1.13.bb
index 4882300ca0..a894124179 100644
--- a/recipes/xserver-common/xserver-common_1.13.bb
+++ b/recipes/xserver-common/xserver-common_1.13.bb
@@ -3,8 +3,8 @@ require xserver-common.inc
PR = "r2"
SRC_URI_append = " file://setDPI.sh \
- file://xserver-imageon.patch;apply=yes \
- file://calibrate-only-if-ts.patch;apply=yes"
+ file://xserver-imageon.patch \
+ file://calibrate-only-if-ts.patch"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.14.bb b/recipes/xserver-common/xserver-common_1.14.bb
index b6e1a99653..c55bb2971c 100644
--- a/recipes/xserver-common/xserver-common_1.14.bb
+++ b/recipes/xserver-common/xserver-common_1.14.bb
@@ -10,8 +10,8 @@ PACKAGE_ARCH = "all"
inherit gpe
SRC_URI_append = " file://setDPI.sh \
- file://xserver-imageon.patch;apply=yes \
- file://calibrate-only-if-ts.patch;apply=yes"
+ file://xserver-imageon.patch \
+ file://calibrate-only-if-ts.patch"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.15.bb b/recipes/xserver-common/xserver-common_1.15.bb
index a82aeda228..c420049a52 100644
--- a/recipes/xserver-common/xserver-common_1.15.bb
+++ b/recipes/xserver-common/xserver-common_1.15.bb
@@ -10,8 +10,8 @@ PACKAGE_ARCH = "all"
inherit gpe
SRC_URI_append = " file://setDPI.sh \
- file://xserver-imageon.patch;apply=yes \
- file://calibrate-only-if-ts.patch;apply=yes"
+ file://xserver-imageon.patch \
+ file://calibrate-only-if-ts.patch"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.16.bb b/recipes/xserver-common/xserver-common_1.16.bb
index eae4aed8e7..8d229a5b12 100644
--- a/recipes/xserver-common/xserver-common_1.16.bb
+++ b/recipes/xserver-common/xserver-common_1.16.bb
@@ -10,12 +10,12 @@ PACKAGE_ARCH = "all"
inherit gpe
SRC_URI_append = " file://setDPI.sh \
- file://xserver-imageon.patch;apply=yes \
- file://calibrate-only-if-ts.patch;apply=yes \
- file://softkeys-c7x0.patch;apply=yes \
- file://load-xmodmap-k26.patch;apply=yes \
- file://Xserver-udev-input-helper.patch;apply=yes \
- file://sl-cxx00-modmap.patch;apply=yes \
+ file://xserver-imageon.patch \
+ file://calibrate-only-if-ts.patch \
+ file://softkeys-c7x0.patch \
+ file://load-xmodmap-k26.patch \
+ file://Xserver-udev-input-helper.patch \
+ file://sl-cxx00-modmap.patch \
"
do_install_append() {
diff --git a/recipes/xserver-common/xserver-common_1.18.bb b/recipes/xserver-common/xserver-common_1.18.bb
index 6b3cf071c3..846093eb3d 100644
--- a/recipes/xserver-common/xserver-common_1.18.bb
+++ b/recipes/xserver-common/xserver-common_1.18.bb
@@ -9,7 +9,7 @@ PACKAGE_ARCH = "all"
# we are using a gpe-style Makefile
inherit gpe
-SRC_URI_append = " file://ti-osk.patch;apply=yes file://unbreak-simpad.patch;apply=yes file://setDPI.sh "
+SRC_URI_append = " file://ti-osk.patch file://unbreak-simpad.patch file://setDPI.sh"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.22.bb b/recipes/xserver-common/xserver-common_1.22.bb
index d026989470..160a3fd301 100644
--- a/recipes/xserver-common/xserver-common_1.22.bb
+++ b/recipes/xserver-common/xserver-common_1.22.bb
@@ -10,9 +10,9 @@ PACKAGE_ARCH = "all"
inherit gpe
SRC_URI_append = " file://setDPI.sh "
-SRC_URI_append_angstrom = " file://kdrive-1.4-fixes.patch;apply=yes \
- file://xorg-fixes.patch;apply=yes \
- file://gta-xorg-fixes.patch;apply=yes \
+SRC_URI_append_angstrom = " file://kdrive-1.4-fixes.patch \
+ file://xorg-fixes.patch \
+ file://gta-xorg-fixes.patch \
file://default.xmodmap \
file://98keymap-fixup "
diff --git a/recipes/xserver-common/xserver-common_1.25.bb b/recipes/xserver-common/xserver-common_1.25.bb
index a770729db7..ad7824ca9e 100644
--- a/recipes/xserver-common/xserver-common_1.25.bb
+++ b/recipes/xserver-common/xserver-common_1.25.bb
@@ -11,12 +11,12 @@ inherit gpe
SRC_URI_append = " file://setDPI.sh \
file://89xdgautostart.sh \
- file://avoid-rotated-server.patch;apply=yes \
- file://ts-handling-cleanup.diff;apply=yes \
- file://Xserver-at91.patch;apply=yes \
+ file://avoid-rotated-server.patch \
+ file://ts-handling-cleanup.diff \
+ file://Xserver-at91.patch \
"
-SRC_URI_append_angstrom = " file://xtscal-fix.patch;apply=yes "
+SRC_URI_append_angstrom = " file://xtscal-fix.patch "
RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
do_install_append() {
diff --git a/recipes/xserver-common/xserver-common_1.30.bb b/recipes/xserver-common/xserver-common_1.30.bb
index dbcfa33ef9..a4390ab792 100644
--- a/recipes/xserver-common/xserver-common_1.30.bb
+++ b/recipes/xserver-common/xserver-common_1.30.bb
@@ -13,15 +13,15 @@ inherit gpe
SRC_URI_append = " file://setDPI.sh \
file://89xdgautostart.sh \
-file://0018-zaurus-fixed-machine-names.patch;apply=yes \
-file://0019-keymap-fixed-machine-names.patch;apply=yes \
-file://0020-keymap-fixed-machine-names-again.patch;apply=yes \
-file://0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch;apply=yes \
-file://0022-xserver-fix-syntax-error.patch;apply=yes \
-file://0023-Xserver-provide-screen-argument-only-for-non-X.org-s.patch;apply=yes \
-file://0024-Xserver-move-nearly-whole-functionality-to-xserver-c.patch;apply=yes \
-file://0025-Makefile-move-modmaps-install-xserver-common.patch;apply=yes \
-file://0026-98keymap-fixup-fixed-path-to-xmodmap-file.patch;apply=yes \
+file://0018-zaurus-fixed-machine-names.patch \
+file://0019-keymap-fixed-machine-names.patch \
+file://0020-keymap-fixed-machine-names-again.patch \
+file://0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch \
+file://0022-xserver-fix-syntax-error.patch \
+file://0023-Xserver-provide-screen-argument-only-for-non-X.org-s.patch \
+file://0024-Xserver-move-nearly-whole-functionality-to-xserver-c.patch \
+file://0025-Makefile-move-modmaps-install-xserver-common.patch \
+file://0026-98keymap-fixup-fixed-path-to-xmodmap-file.patch \
"
do_install_append() {
diff --git a/recipes/xserver-common/xserver-common_1.32.bb b/recipes/xserver-common/xserver-common_1.32.bb
index 7cbd52bd5b..a0f7709d5a 100644
--- a/recipes/xserver-common/xserver-common_1.32.bb
+++ b/recipes/xserver-common/xserver-common_1.32.bb
@@ -13,7 +13,7 @@ inherit gpe
SRC_URI_append = " file://setDPI.sh \
file://89xdgautostart.sh"
-SRC_URI_append_angstrom = " file://xtscal-fix.patch;apply=yes "
+SRC_URI_append_angstrom = " file://xtscal-fix.patch "
RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
do_install_append() {
diff --git a/recipes/xserver-common/xserver-common_1.33.bb b/recipes/xserver-common/xserver-common_1.33.bb
index dc35c0ccae..f1fcfc337a 100644
--- a/recipes/xserver-common/xserver-common_1.33.bb
+++ b/recipes/xserver-common/xserver-common_1.33.bb
@@ -16,19 +16,19 @@ inherit gpe
SRC_URI[md5sum] = "2df46d6b1bbac9f3e5e7e3191ccdd3e4"
SRC_URI[sha256sum] = "4576ccca80730f1860a273df38b9f917cf906eca9865e108d76fc5460e006d87"
-SRC_URI_append = " file://loop.patch;apply=yes;striplevel=3 \
- file://rgba.diff;apply=yes \
+SRC_URI_append = " file://loop.patch;striplevel=3 \
+ file://rgba.diff \
file://setDPI.sh \
file://89xdgautostart.sh"
-SRC_URI_append_angstrom = " file://xtscal-fix.patch;apply=yes "
+SRC_URI_append_angstrom = " file://xtscal-fix.patch "
RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
-SRC_URI_append_shr = " file://89xTs_Calibrate.xinput_calibrator.patch;apply=yes \
- file://90xXWindowManager.patch;apply=yes \
- file://Xserver.add.nocursor.for.gta.patch;apply=yes \
- file://Xserver.add.xserver-system.patch;apply=yes \
- file://Xserver.add.dpi.for.gta.patch;apply=yes"
+SRC_URI_append_shr = " file://89xTs_Calibrate.xinput_calibrator.patch \
+ file://90xXWindowManager.patch \
+ file://Xserver.add.nocursor.for.gta.patch \
+ file://Xserver.add.xserver-system.patch \
+ file://Xserver.add.dpi.for.gta.patch"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_svn.bb b/recipes/xserver-common/xserver-common_svn.bb
index 558baa2bf2..f664cb9bc2 100644
--- a/recipes/xserver-common/xserver-common_svn.bb
+++ b/recipes/xserver-common/xserver-common_svn.bb
@@ -11,10 +11,10 @@ PR = "r2"
SRC_URI = "${GPE_SVN} \
file://Makefile.translation \
file://Makefile.dpkg_ipkg \
- file://svn_makefiles.patch;apply=yes \
- file://keyboardless-buttonmap.patch;apply=yes \
- file://softkeys-c7x0.patch;apply=yes \
- file://sl-cxx00-modmap.patch;apply=yes \
- file://load-xmodmap-k26.patch;apply=yes \
- file://Xserver-udev-input-helper.patch;apply=yes"
+ file://svn_makefiles.patch \
+ file://keyboardless-buttonmap.patch \
+ file://softkeys-c7x0.patch \
+ file://sl-cxx00-modmap.patch \
+ file://load-xmodmap-k26.patch \
+ file://Xserver-udev-input-helper.patch"