aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xserver-common
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-23 20:23:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:53:41 -0700
commitbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (patch)
tree96f28e2f5133d68c3e3dadabaa2339340671454f /recipes/xserver-common
parentfab0af3aefee22b21541e403d3c356a6979bfa63 (diff)
downloadopenembedded-bf7d0467a0788a7fcc1c96e0dc35a25ae09278a0.tar.gz
Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>
I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/xserver-common')
-rw-r--r--recipes/xserver-common/xserver-common_1.11.bb6
-rw-r--r--recipes/xserver-common/xserver-common_1.12.bb2
-rw-r--r--recipes/xserver-common/xserver-common_1.13.bb4
-rw-r--r--recipes/xserver-common/xserver-common_1.14.bb4
-rw-r--r--recipes/xserver-common/xserver-common_1.15.bb4
-rw-r--r--recipes/xserver-common/xserver-common_1.16.bb12
-rw-r--r--recipes/xserver-common/xserver-common_1.18.bb2
-rw-r--r--recipes/xserver-common/xserver-common_1.22.bb6
-rw-r--r--recipes/xserver-common/xserver-common_1.25.bb8
-rw-r--r--recipes/xserver-common/xserver-common_1.30.bb18
-rw-r--r--recipes/xserver-common/xserver-common_1.32.bb2
-rw-r--r--recipes/xserver-common/xserver-common_1.33.bb16
-rw-r--r--recipes/xserver-common/xserver-common_svn.bb12
13 files changed, 48 insertions, 48 deletions
diff --git a/recipes/xserver-common/xserver-common_1.11.bb b/recipes/xserver-common/xserver-common_1.11.bb
index 6b08e1ea31..c25080055e 100644
--- a/recipes/xserver-common/xserver-common_1.11.bb
+++ b/recipes/xserver-common/xserver-common_1.11.bb
@@ -1,9 +1,9 @@
require xserver-common.inc
SRC_URI_append = " file://setDPI.sh \
- file://calibrate_zaurusd.patch;patch=1 \
- file://w100.patch;patch=1 \
- file://poodle-xmodmap-2.6.patch;patch=1"
+ file://calibrate_zaurusd.patch;apply=yes \
+ file://w100.patch;apply=yes \
+ file://poodle-xmodmap-2.6.patch;apply=yes"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.12.bb b/recipes/xserver-common/xserver-common_1.12.bb
index 5537a8d3f1..3b8545e821 100644
--- a/recipes/xserver-common/xserver-common_1.12.bb
+++ b/recipes/xserver-common/xserver-common_1.12.bb
@@ -3,7 +3,7 @@ require xserver-common.inc
PR = "r1"
SRC_URI_append = " file://setDPI.sh \
- file://rxvt-less-pink.diff;patch=1"
+ file://rxvt-less-pink.diff;apply=yes"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.13.bb b/recipes/xserver-common/xserver-common_1.13.bb
index ee62356146..4882300ca0 100644
--- a/recipes/xserver-common/xserver-common_1.13.bb
+++ b/recipes/xserver-common/xserver-common_1.13.bb
@@ -3,8 +3,8 @@ require xserver-common.inc
PR = "r2"
SRC_URI_append = " file://setDPI.sh \
- file://xserver-imageon.patch;patch=1 \
- file://calibrate-only-if-ts.patch;patch=1"
+ file://xserver-imageon.patch;apply=yes \
+ file://calibrate-only-if-ts.patch;apply=yes"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.14.bb b/recipes/xserver-common/xserver-common_1.14.bb
index 5eea62e361..b6e1a99653 100644
--- a/recipes/xserver-common/xserver-common_1.14.bb
+++ b/recipes/xserver-common/xserver-common_1.14.bb
@@ -10,8 +10,8 @@ PACKAGE_ARCH = "all"
inherit gpe
SRC_URI_append = " file://setDPI.sh \
- file://xserver-imageon.patch;patch=1 \
- file://calibrate-only-if-ts.patch;patch=1"
+ file://xserver-imageon.patch;apply=yes \
+ file://calibrate-only-if-ts.patch;apply=yes"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.15.bb b/recipes/xserver-common/xserver-common_1.15.bb
index 6b3a02294e..a82aeda228 100644
--- a/recipes/xserver-common/xserver-common_1.15.bb
+++ b/recipes/xserver-common/xserver-common_1.15.bb
@@ -10,8 +10,8 @@ PACKAGE_ARCH = "all"
inherit gpe
SRC_URI_append = " file://setDPI.sh \
- file://xserver-imageon.patch;patch=1 \
- file://calibrate-only-if-ts.patch;patch=1"
+ file://xserver-imageon.patch;apply=yes \
+ file://calibrate-only-if-ts.patch;apply=yes"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.16.bb b/recipes/xserver-common/xserver-common_1.16.bb
index d85baf172f..eae4aed8e7 100644
--- a/recipes/xserver-common/xserver-common_1.16.bb
+++ b/recipes/xserver-common/xserver-common_1.16.bb
@@ -10,12 +10,12 @@ PACKAGE_ARCH = "all"
inherit gpe
SRC_URI_append = " file://setDPI.sh \
- file://xserver-imageon.patch;patch=1 \
- file://calibrate-only-if-ts.patch;patch=1 \
- file://softkeys-c7x0.patch;patch=1 \
- file://load-xmodmap-k26.patch;patch=1 \
- file://Xserver-udev-input-helper.patch;patch=1 \
- file://sl-cxx00-modmap.patch;patch=1 \
+ file://xserver-imageon.patch;apply=yes \
+ file://calibrate-only-if-ts.patch;apply=yes \
+ file://softkeys-c7x0.patch;apply=yes \
+ file://load-xmodmap-k26.patch;apply=yes \
+ file://Xserver-udev-input-helper.patch;apply=yes \
+ file://sl-cxx00-modmap.patch;apply=yes \
"
do_install_append() {
diff --git a/recipes/xserver-common/xserver-common_1.18.bb b/recipes/xserver-common/xserver-common_1.18.bb
index dd1e1c13a1..6b3cf071c3 100644
--- a/recipes/xserver-common/xserver-common_1.18.bb
+++ b/recipes/xserver-common/xserver-common_1.18.bb
@@ -9,7 +9,7 @@ PACKAGE_ARCH = "all"
# we are using a gpe-style Makefile
inherit gpe
-SRC_URI_append = " file://ti-osk.patch;patch=1 file://unbreak-simpad.patch;patch=1 file://setDPI.sh "
+SRC_URI_append = " file://ti-osk.patch;apply=yes file://unbreak-simpad.patch;apply=yes file://setDPI.sh "
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_1.22.bb b/recipes/xserver-common/xserver-common_1.22.bb
index a255dd4634..d026989470 100644
--- a/recipes/xserver-common/xserver-common_1.22.bb
+++ b/recipes/xserver-common/xserver-common_1.22.bb
@@ -10,9 +10,9 @@ PACKAGE_ARCH = "all"
inherit gpe
SRC_URI_append = " file://setDPI.sh "
-SRC_URI_append_angstrom = " file://kdrive-1.4-fixes.patch;patch=1 \
- file://xorg-fixes.patch;patch=1 \
- file://gta-xorg-fixes.patch;patch=1 \
+SRC_URI_append_angstrom = " file://kdrive-1.4-fixes.patch;apply=yes \
+ file://xorg-fixes.patch;apply=yes \
+ file://gta-xorg-fixes.patch;apply=yes \
file://default.xmodmap \
file://98keymap-fixup "
diff --git a/recipes/xserver-common/xserver-common_1.25.bb b/recipes/xserver-common/xserver-common_1.25.bb
index 9e66633d2e..a770729db7 100644
--- a/recipes/xserver-common/xserver-common_1.25.bb
+++ b/recipes/xserver-common/xserver-common_1.25.bb
@@ -11,12 +11,12 @@ inherit gpe
SRC_URI_append = " file://setDPI.sh \
file://89xdgautostart.sh \
- file://avoid-rotated-server.patch;patch=1 \
- file://ts-handling-cleanup.diff;patch=1 \
- file://Xserver-at91.patch;patch=1 \
+ file://avoid-rotated-server.patch;apply=yes \
+ file://ts-handling-cleanup.diff;apply=yes \
+ file://Xserver-at91.patch;apply=yes \
"
-SRC_URI_append_angstrom = " file://xtscal-fix.patch;patch=1 "
+SRC_URI_append_angstrom = " file://xtscal-fix.patch;apply=yes "
RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
do_install_append() {
diff --git a/recipes/xserver-common/xserver-common_1.30.bb b/recipes/xserver-common/xserver-common_1.30.bb
index 56db9fa5e5..dbcfa33ef9 100644
--- a/recipes/xserver-common/xserver-common_1.30.bb
+++ b/recipes/xserver-common/xserver-common_1.30.bb
@@ -13,15 +13,15 @@ inherit gpe
SRC_URI_append = " file://setDPI.sh \
file://89xdgautostart.sh \
-file://0018-zaurus-fixed-machine-names.patch;patch=1 \
-file://0019-keymap-fixed-machine-names.patch;patch=1 \
-file://0020-keymap-fixed-machine-names-again.patch;patch=1 \
-file://0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch;patch=1 \
-file://0022-xserver-fix-syntax-error.patch;patch=1 \
-file://0023-Xserver-provide-screen-argument-only-for-non-X.org-s.patch;patch=1 \
-file://0024-Xserver-move-nearly-whole-functionality-to-xserver-c.patch;patch=1 \
-file://0025-Makefile-move-modmaps-install-xserver-common.patch;patch=1 \
-file://0026-98keymap-fixup-fixed-path-to-xmodmap-file.patch;patch=1 \
+file://0018-zaurus-fixed-machine-names.patch;apply=yes \
+file://0019-keymap-fixed-machine-names.patch;apply=yes \
+file://0020-keymap-fixed-machine-names-again.patch;apply=yes \
+file://0021-xserver-introduced-MOUSE-variable-for-mouse-argument.patch;apply=yes \
+file://0022-xserver-fix-syntax-error.patch;apply=yes \
+file://0023-Xserver-provide-screen-argument-only-for-non-X.org-s.patch;apply=yes \
+file://0024-Xserver-move-nearly-whole-functionality-to-xserver-c.patch;apply=yes \
+file://0025-Makefile-move-modmaps-install-xserver-common.patch;apply=yes \
+file://0026-98keymap-fixup-fixed-path-to-xmodmap-file.patch;apply=yes \
"
do_install_append() {
diff --git a/recipes/xserver-common/xserver-common_1.32.bb b/recipes/xserver-common/xserver-common_1.32.bb
index d57b38e40f..7cbd52bd5b 100644
--- a/recipes/xserver-common/xserver-common_1.32.bb
+++ b/recipes/xserver-common/xserver-common_1.32.bb
@@ -13,7 +13,7 @@ inherit gpe
SRC_URI_append = " file://setDPI.sh \
file://89xdgautostart.sh"
-SRC_URI_append_angstrom = " file://xtscal-fix.patch;patch=1 "
+SRC_URI_append_angstrom = " file://xtscal-fix.patch;apply=yes "
RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
do_install_append() {
diff --git a/recipes/xserver-common/xserver-common_1.33.bb b/recipes/xserver-common/xserver-common_1.33.bb
index 44e3183328..dc35c0ccae 100644
--- a/recipes/xserver-common/xserver-common_1.33.bb
+++ b/recipes/xserver-common/xserver-common_1.33.bb
@@ -16,19 +16,19 @@ inherit gpe
SRC_URI[md5sum] = "2df46d6b1bbac9f3e5e7e3191ccdd3e4"
SRC_URI[sha256sum] = "4576ccca80730f1860a273df38b9f917cf906eca9865e108d76fc5460e006d87"
-SRC_URI_append = " file://loop.patch;patch=1;pnum=3 \
- file://rgba.diff;patch=1 \
+SRC_URI_append = " file://loop.patch;apply=yes;striplevel=3 \
+ file://rgba.diff;apply=yes \
file://setDPI.sh \
file://89xdgautostart.sh"
-SRC_URI_append_angstrom = " file://xtscal-fix.patch;patch=1 "
+SRC_URI_append_angstrom = " file://xtscal-fix.patch;apply=yes "
RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
-SRC_URI_append_shr = " file://89xTs_Calibrate.xinput_calibrator.patch;patch=1 \
- file://90xXWindowManager.patch;patch=1 \
- file://Xserver.add.nocursor.for.gta.patch;patch=1 \
- file://Xserver.add.xserver-system.patch;patch=1 \
- file://Xserver.add.dpi.for.gta.patch;patch=1"
+SRC_URI_append_shr = " file://89xTs_Calibrate.xinput_calibrator.patch;apply=yes \
+ file://90xXWindowManager.patch;apply=yes \
+ file://Xserver.add.nocursor.for.gta.patch;apply=yes \
+ file://Xserver.add.xserver-system.patch;apply=yes \
+ file://Xserver.add.dpi.for.gta.patch;apply=yes"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
diff --git a/recipes/xserver-common/xserver-common_svn.bb b/recipes/xserver-common/xserver-common_svn.bb
index 546481d48f..558baa2bf2 100644
--- a/recipes/xserver-common/xserver-common_svn.bb
+++ b/recipes/xserver-common/xserver-common_svn.bb
@@ -11,10 +11,10 @@ PR = "r2"
SRC_URI = "${GPE_SVN} \
file://Makefile.translation \
file://Makefile.dpkg_ipkg \
- file://svn_makefiles.patch;patch=1 \
- file://keyboardless-buttonmap.patch;patch=1 \
- file://softkeys-c7x0.patch;patch=1 \
- file://sl-cxx00-modmap.patch;patch=1 \
- file://load-xmodmap-k26.patch;patch=1 \
- file://Xserver-udev-input-helper.patch;patch=1"
+ file://svn_makefiles.patch;apply=yes \
+ file://keyboardless-buttonmap.patch;apply=yes \
+ file://softkeys-c7x0.patch;apply=yes \
+ file://sl-cxx00-modmap.patch;apply=yes \
+ file://load-xmodmap-k26.patch;apply=yes \
+ file://Xserver-udev-input-helper.patch;apply=yes"