aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xserver-common
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-20 19:50:28 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-20 19:50:28 +0200
commitda8608ce9f84566831c6c3f737123d63897a8ae7 (patch)
treec190f6e186115dc460ed5a9de3849cb8d9208bae /recipes/xserver-common
parent717855f88dadb8a5983c0b4def49270a2561d216 (diff)
downloadopenembedded-da8608ce9f84566831c6c3f737123d63897a8ae7.tar.gz
xserver-common: add 1.33 with some extra fixes
Diffstat (limited to 'recipes/xserver-common')
-rw-r--r--recipes/xserver-common/xserver-common-1.33/loop.patch33
-rw-r--r--recipes/xserver-common/xserver-common-1.33/rgba.diff265
-rw-r--r--recipes/xserver-common/xserver-common_1.33.bb28
3 files changed, 326 insertions, 0 deletions
diff --git a/recipes/xserver-common/xserver-common-1.33/loop.patch b/recipes/xserver-common/xserver-common-1.33/loop.patch
new file mode 100644
index 0000000000..1f1ac73ca8
--- /dev/null
+++ b/recipes/xserver-common/xserver-common-1.33/loop.patch
@@ -0,0 +1,33 @@
+From 36b10b27570b8549ee1b75793fddc9bc9aea9081 Mon Sep 17 00:00:00 2001
+From: fboor <fboor@d4735bf7-8e1f-0410-bce4-ef584eb11c25>
+Date: Fri, 29 Jan 2010 14:28:23 +0000
+Subject: Avoid X startup to hang in keymap fixing loop.
+
+git-svn-id: svn://projects.linuxtogo.org/svnroot/gpe/trunk@10072 d4735bf7-8e1f-0410-bce4-ef584eb11c25
+---
+diff --git a/base/xserver-common/ChangeLog b/base/xserver-common/ChangeLog
+index 0f4bf90..2c06f75 100644
+--- a/base/xserver-common/ChangeLog
++++ b/base/xserver-common/ChangeLog
+@@ -1,3 +1,5 @@
++2010-01-29 Florian Boor <florian@kernelconcepts.de>
++ * Avoid X startup to hang in keymap fixing loop.
+
+ 2009-11-20 Florian Boor <florian@kernelconcepts.de>
+ * Release 1.33
+diff --git a/base/xserver-common/X11/Xinit.d/98keymap-fixup b/base/xserver-common/X11/Xinit.d/98keymap-fixup
+index fcc84d9..6f9c8bf 100755
+--- a/base/xserver-common/X11/Xinit.d/98keymap-fixup
++++ b/base/xserver-common/X11/Xinit.d/98keymap-fixup
+@@ -5,6 +5,9 @@ iter=0
+ while [ $(xmodmap -pke | awk '{if ($2 == 36) { if ($4 == "Return") { print "good" } else {print "bad" }}}') = "bad" ] ; do
+ xmodmap - </etc/X11/default.xmodmap
+ let iter=iter+1
++ if [ $iter -eq 30 ]; then
++ exit 0
++ fi
+ done
+
+ echo "modmap applied after $iter additional tries"
+--
+cgit v0.8.3.1-30-gff3a
diff --git a/recipes/xserver-common/xserver-common-1.33/rgba.diff b/recipes/xserver-common/xserver-common-1.33/rgba.diff
new file mode 100644
index 0000000000..1c913c94d4
--- /dev/null
+++ b/recipes/xserver-common/xserver-common-1.33/rgba.diff
@@ -0,0 +1,265 @@
+From: Koen Kooi <koen@openembedded.org
+Subject: xserver-common: make rgb params kdrive specific
+
+Also convert stray tabs to spaces
+
+--- /tmp/xserver-common 2010-04-20 19:47:18.000000000 +0200
++++ xserver-common-1.33/X11/xserver-common 2010-04-20 19:47:22.000000000 +0200
+@@ -47,6 +47,7 @@
+ ARGS="-br -pn $INPUT_EXTRA_ARGS"
+ DPI="100"
+ MOUSE=""
++KDRIVEARGS=""
+
+ # use ucb 1x00 touchscreen if present
+ if [ -z "$TSLIB_TSDEVICE" ] && [ -e /dev/touchscreen/ucb1x00 ]; then
+@@ -68,127 +69,133 @@
+ else
+ # start off server in conventional location.
+ case `machine_id` in
+- "aml_m8050")
+- ARGS="$ARGS -screen 320x240@270"
+- DPI="100" ;;
+- "hp_ipaq_h3100" | "hp_ipaq_h3800")
+- ARGS="$ARGS -rgba vrgb -screen 320x240@90"
+- DPI="100" ;;
+- "hp_ipaq_h3600" | "hp_ipaq_h3700" | "hp_ipaq_h3900")
+- ARGS="$ARGS -rgba vbgr -screen 320x240@270"
+- DPI="100" ;;
+- "hp_ipaq_h5400" | "hp_ipaq_h2200")
+- ARGS="$ARGS -rgba rgb"
+- DPI="100" ;;
+- "hp_ipaq_hx4700")
+- DPI="200" ;;
+- "ramses")
+- # What is this "vt2" in aid of?
+- ARGS="$ARGS -rgba vrgb -screen 320x240@90 vt2"
+- DPI="100" ;;
+- *poodle)
+- ARGS="$ARGS -rgba vrgb -screen 320x240@270"
+- DPI="100" ;;
+- # both 'Sharp-Collie' and just 'Collie' have been reported
+- *collie)
+- ARGS="$ARGS -rgba vrgb -screen 320x240@270"
+- DPI="100" ;;
+- "sharp_shepherd" | "sharp_husky" | "sharp_corgi")
+- ARGS="$ARGS -rgba rgb"
+- DPI="200" ;;
+- "sharp_spitz" | "sharp_akita" | "sharp_borzoi")
+- export XSERVER_DEFAULT_ORIENTATION="normal"
+- ARGS="$ARGS -rgba rgb -screen 480x640"
+- DPI="200" ;;
+- "simpad")
+- ARGS="$ARGS -rgba rgb"
+- DPI="100" ;;
+- "generic_omap1510/1610/1710")
+- MOUSE="-mouse /dev/input/event0"
+- DPI="220" ;;
+- "ti-osk")
+- DPI="100" ;;
+- "cellon_c8000_board")
+- ARGS="$ARGS -screen ${SCREEN_SIZE},10,1"
+- DPI="100" ;;
+- "htc_magician")
+- DPI="142" ;;
+- "htc_universal")
+- ARGS="$ARGS -screen 480x640@270"
+- DPI="100" ;;
+- "htc_tornado")
+- ARGS="$ARGS -hide-cursor"
+- DPI="100" ;;
+- "generic_omap1510/1610/1710")
+- ARGS="$ARGS -screen ${SCREEN_SIZE}"
+- DPI="225" ;;
+- "nokia_n800" | "nokia_rx-44" | "nokia_n770")
+- ARGS="$ARGS -screen ${SCREEN_SIZE}"
+- DPI="225" ;;
+- "gta01" )
+- DPI="285"
+- if [ "$XSERVER" != "Xorg" ] ; then
+- ARGS="$ARGS -screen 480x640"
+- fi
+- ;;
+- "gta02")
+- DPI="285"
+- if [ "$XSERVER" != "Xorg" ] ; then
+- ARGS="$ARGS -screen ${SCREEN_SIZE}"
+- fi
+- ;;
+- "motorola_ezx_platform")
+- ARGS="$ARGS -screen 240x320"
+- DPI="170" ;;
+- "arm-integratorcp" | "arm-versatile_pb")
+- ARGS="$ARGS -rgba vrgb" ;;
+- "compulab_cm-x270")
+- modprobe mbxfb
+- ARGS="$ARGS -fb /dev/fb1" ;;
+- "boundary_devices_neon_board")
+- ARGS="$ARGS -screen ${SCREEN_SIZE}"
+- DPI="100" ;;
+- "hoeft&wessel_hw90350")
+- ARGS="$ARGS -screen ${SCREEN_SIZE}"
+- DPI="100" ;;
+- "hoeft&wessel_hw90250")
+- ARGS="$ARGS -screen 240x320@90"
+- DPI="100" ;;
+- "hoeft&wessel_skeye.pad_pos_aka_almex_mobile")
+- DPI="100"
+- ARGS="$ARGS -screen 640x480@180 -hide-cursor" ;;
+- "mini2440")
+- ARGS="$ARGS -screen ${SCREEN_SIZE}"
+- DPI="100" ;;
+- "palm_treo_650")
+- DPI="181"
+- ARGS="$ARGS -screen 320x320 -hide-cursor" ;;
+- "glofiish_m800")
+- DPI="285"
+- ARGS="$ARGS -screen ${SCREEN_SIZE} -hide-cursor vt1" ;;
+- "freescale_mx21ads")
+- # That's what /proc/cpuinfo shows as hardware on the chumby
+- DPI="121"
+- ARGS="$ARGS -screen 320x240 -hide-cursor" ;;
++ "aml_m8050")
++ ARGS="$ARGS -screen 320x240@270"
++ DPI="100" ;;
++ "hp_ipaq_h3100" | "hp_ipaq_h3800")
++ KDRIVEARGS="-rgba vrgb"
++ ARGS="$ARGS -screen 320x240@90"
++ DPI="100" ;;
++ "hp_ipaq_h3600" | "hp_ipaq_h3700" | "hp_ipaq_h3900")
++ KDRIVEARGS="-rgba vrgb"
++ ARGS="$ARGS -screen 320x240@270"
++ DPI="100" ;;
++ "hp_ipaq_h5400" | "hp_ipaq_h2200")
++ KDRIVEARGS="-rgba rgb"
++ DPI="100" ;;
++ "hp_ipaq_hx4700")
++ DPI="200" ;;
++ "ramses")
++ # What is this "vt2" in aid of?
++ KDRIVEARGS="-rgba vrgb"
++ ARGS="$ARGS -screen 320x240@90 vt2"
++ DPI="100" ;;
++ *poodle)
++ KDRIVEARGS="-rgba vrgb"
++ ARGS="$ARGS -screen 320x240@270"
++ DPI="100" ;;
++ # both 'Sharp-Collie' and just 'Collie' have been reported
++ *collie)
++ KDRIVEARGS="-rgba vrgb"
++ ARGS="$ARGS -screen 320x240@270"
++ DPI="100" ;;
++ "sharp_shepherd" | "sharp_husky" | "sharp_corgi")
++ KDRIVEARGS="-rgba rgb"
++ DPI="200" ;;
++ "sharp_spitz" | "sharp_akita" | "sharp_borzoi")
++ export XSERVER_DEFAULT_ORIENTATION="normal"
++ KDRIVEARGS="-rgba vrgb"
++ ARGS="$ARGS -screen 480x640"
++ DPI="200" ;;
++ "simpad")
++ KDRIVEARGS="-rgba rgb"
++ DPI="100" ;;
++ "generic_omap1510/1610/1710")
++ MOUSE="-mouse /dev/input/event0"
++ DPI="220" ;;
++ "ti-osk")
++ DPI="100" ;;
++ "cellon_c8000_board")
++ ARGS="$ARGS -screen ${SCREEN_SIZE},10,1"
++ DPI="100" ;;
++ "htc_magician")
++ DPI="142" ;;
++ "htc_universal")
++ ARGS="$ARGS -screen 480x640@270"
++ DPI="100" ;;
++ "htc_tornado")
++ ARGS="$ARGS -hide-cursor"
++ DPI="100" ;;
++ "generic_omap1510/1610/1710")
++ ARGS="$ARGS -screen ${SCREEN_SIZE}"
++ DPI="225" ;;
++ "nokia_n800" | "nokia_rx-44" | "nokia_n770")
++ ARGS="$ARGS -screen ${SCREEN_SIZE}"
++ DPI="225" ;;
++ "gta01" )
++ DPI="285"
++ if [ "$XSERVER" != "Xorg" ] ; then
++ ARGS="$ARGS -screen 480x640"
++ fi
++ ;;
++ "gta02")
++ DPI="285"
++ if [ "$XSERVER" != "Xorg" ] ; then
++ ARGS="$ARGS -screen ${SCREEN_SIZE}"
++ fi
++ ;;
++ "motorola_ezx_platform")
++ ARGS="$ARGS -screen 240x320"
++ DPI="170" ;;
++ "arm-integratorcp" | "arm-versatile_pb")
++ KDRIVEARGS="-rgba vrgb" ;;
++ "compulab_cm-x270")
++ modprobe mbxfb
++ ARGS="$ARGS -fb /dev/fb1" ;;
++ "boundary_devices_neon_board")
++ ARGS="$ARGS -screen ${SCREEN_SIZE}"
++ DPI="100" ;;
++ "hoeft&wessel_hw90350")
++ ARGS="$ARGS -screen ${SCREEN_SIZE}"
++ DPI="100" ;;
++ "hoeft&wessel_hw90250")
++ ARGS="$ARGS -screen 240x320@90"
++ DPI="100" ;;
++ "hoeft&wessel_skeye.pad_pos_aka_almex_mobile")
++ DPI="100"
++ ARGS="$ARGS -screen 640x480@180 -hide-cursor" ;;
++ "mini2440")
++ ARGS="$ARGS -screen ${SCREEN_SIZE}"
++ DPI="100" ;;
++ "palm_treo_650")
++ DPI="181"
++ ARGS="$ARGS -screen 320x320 -hide-cursor" ;;
++ "glofiish_m800")
++ DPI="285"
++ ARGS="$ARGS -screen ${SCREEN_SIZE} -hide-cursor vt1" ;;
++ "freescale_mx21ads")
++ # That's what /proc/cpuinfo shows as hardware on the chumby
++ DPI="121"
++ ARGS="$ARGS -screen 320x240 -hide-cursor" ;;
+
+ # this is to rotate X display properly, tested with display TX09D71VM1CCA
+ ronetix*pm9261* | ronetix*pm9263*)
+- ARGS="$ARGS -screen 240/54x320/81@90x16" ;;
+- # This is a fallback for PCs
+- "")
+- if [ -f $BINDIR/Xvesa ]; then
+- ARGS="$ARGS -mode 0x0114"
+- else
+- # It is a device we do not know about, in which case we force
+- # kdrive to use the current framebuffer geometry -- otherwise
+- # it will default to trying to achieve 1024x768
+- if [ "$XSERVER" != "Xorg" ] ; then
+- ARGS="$ARGS -screen ${SCREEN_SIZE}"
+- fi
+- fi
++ ARGS="$ARGS -screen 240/54x320/81@90x16" ;;
++ # This is a fallback for PCs
++ "")
++ if [ -f $BINDIR/Xvesa ]; then
++ ARGS="$ARGS -mode 0x0114"
++ else
++ # It is a device we do not know about, in which case we force
++ # kdrive to use the current framebuffer geometry -- otherwise
++ # it will default to trying to achieve 1024x768
++ if [ "$XSERVER" != "Xorg" ] ; then
++ ARGS="$ARGS -screen ${SCREEN_SIZE}"
++ fi
++ fi
+ esac
+ fi
+
+ if [ "$XSERVER" != "Xorg" ] ; then
+- ARGS="$ARGS $MOUSE"
++ ARGS="$ARGS $MOUSE $KDRIVEARGS"
+ fi
diff --git a/recipes/xserver-common/xserver-common_1.33.bb b/recipes/xserver-common/xserver-common_1.33.bb
new file mode 100644
index 0000000000..80d703ec70
--- /dev/null
+++ b/recipes/xserver-common/xserver-common_1.33.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
+
+PACKAGE_ARCH = "all"
+DEFAULT_PREFERENCE = "-1"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI[md5sum] = "2df46d6b1bbac9f3e5e7e3191ccdd3e4"
+SRC_URI[sha256sum] = "4576ccca80730f1860a273df38b9f917cf906eca9865e108d76fc5460e006d87"
+
+SRC_URI_append = " file://loop.patch;patch=1;pnum=3 \
+ file://rgba.diff;patch=1 \
+ file://setDPI.sh \
+ file://89xdgautostart.sh"
+
+SRC_URI_append_angstrom = " file://xtscal-fix.patch;patch=1 "
+RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+ install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
+ sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/Xserver
+}
+