aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xserver-common
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-18 10:24:05 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-18 10:24:05 +0200
commit4fb5e283e611b87c4d55079c12a1a4ca1c5624a7 (patch)
tree46ef0cf12c319930dc2552e979122a0d1d0a2a3a /recipes/xserver-common
parentdba4943a54c97d1479b60ff05a6f36aee91082ee (diff)
downloadopenembedded-4fb5e283e611b87c4d55079c12a1a4ca1c5624a7.tar.gz
xserver-common: add xdg-autostart support (from poky)
Diffstat (limited to 'recipes/xserver-common')
-rw-r--r--recipes/xserver-common/files/89xdgautostart.sh7
-rw-r--r--recipes/xserver-common/xserver-common_1.24.bb7
2 files changed, 12 insertions, 2 deletions
diff --git a/recipes/xserver-common/files/89xdgautostart.sh b/recipes/xserver-common/files/89xdgautostart.sh
new file mode 100644
index 0000000000..db7aa229d2
--- /dev/null
+++ b/recipes/xserver-common/files/89xdgautostart.sh
@@ -0,0 +1,7 @@
+XDGAUTOSTART=/etc/xdg/autostart
+if [ -d $XDGAUTOSTART ]; then
+ for SCRIPT in $XDGAUTOSTART/*; do
+ CMD=`grep ^Exec= $SCRIPT | cut -d '=' -f 2`
+ $CMD &
+ done
+fi \ No newline at end of file
diff --git a/recipes/xserver-common/xserver-common_1.24.bb b/recipes/xserver-common/xserver-common_1.24.bb
index a30a37c893..27b4ba6a70 100644
--- a/recipes/xserver-common/xserver-common_1.24.bb
+++ b/recipes/xserver-common/xserver-common_1.24.bb
@@ -2,15 +2,18 @@ DESCRIPTION = "Common X11 scripts and support files"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
-PR = "r0"
+PR = "r1"
PACKAGE_ARCH = "all"
# we are using a gpe-style Makefile
inherit gpe
-SRC_URI_append = " file://setDPI.sh "
+SRC_URI_append = " file://setDPI.sh \
+ file://89xdgautostart.sh \
+"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+ install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xinit.d/89xdgautostart.sh"
}