aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xst
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-05-12 23:38:50 +0000
committerKoen Kooi <koen@openembedded.org>2009-05-13 16:36:51 +0200
commitee62088a90445e7ed4e3664214e3776a266bd4ac (patch)
tree828a68613e93f90b6cf20187b1e6e371ee779ff8 /recipes/xst
parente97ca5c7be03cba6be1c7607bf23068983f79039 (diff)
downloadopenembedded-ee62088a90445e7ed4e3664214e3776a266bd4ac.tar.gz
xst: Makefile fix - don't strip on install
Signed-off-by: Koen Kooi <koen@openembedded.org> Acked-by: Philip Balister <philip@balister.org>
Diffstat (limited to 'recipes/xst')
-rw-r--r--recipes/xst/files/makefile-fix.patch11
-rw-r--r--recipes/xst/xst_0.15.bb2
2 files changed, 13 insertions, 0 deletions
diff --git a/recipes/xst/files/makefile-fix.patch b/recipes/xst/files/makefile-fix.patch
new file mode 100644
index 0000000000..3af2d57d70
--- /dev/null
+++ b/recipes/xst/files/makefile-fix.patch
@@ -0,0 +1,11 @@
+--- /tmp/Makefile.old 2005-08-27 01:13:47.000000000 +0200
++++ xst-0.15/Makefile 2009-05-01 15:48:15.000000000 +0200
+@@ -32,7 +32,7 @@
+
+ install-program: $(PACKAGE)
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+
+ clean:
+ rm -f $(PACKAGE) $(OBJS) $(DEPS)
diff --git a/recipes/xst/xst_0.15.bb b/recipes/xst/xst_0.15.bb
index 76ab7af26f..6d6156e778 100644
--- a/recipes/xst/xst_0.15.bb
+++ b/recipes/xst/xst_0.15.bb
@@ -5,3 +5,5 @@ SECTION = "gpe"
DESCRIPTION = "GPE configuration utility"
LICENSE = "GPL"
SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.gz"
+
+SRC_URI += "file://makefile-fix.patch;patch=1"