aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xz
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2010-02-10 21:13:00 +0100
committerPhil Blundell <philb@gnu.org>2010-02-11 12:28:09 +0000
commitfd2bed3297f3b76a8a6b18ba599e7d9d71d2c045 (patch)
treeae89cede945f18e8ffb75e8580588a041d0483ed /recipes/xz
parent8feccac9f3da5cb189450318cd1b82617ee5623a (diff)
downloadopenembedded-fd2bed3297f3b76a8a6b18ba599e7d9d71d2c045.tar.gz
xz: add xz package
xz is the lzma successor tested with automake-1.11.1, autoconf-2.65 Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Diffstat (limited to 'recipes/xz')
-rw-r--r--recipes/xz/xz-native.inc2
-rw-r--r--recipes/xz/xz-native_4.999.9beta.bb3
-rw-r--r--recipes/xz/xz-native_git.bb7
-rw-r--r--recipes/xz/xz.inc8
-rw-r--r--recipes/xz/xz_4.999.9beta.bb8
-rw-r--r--recipes/xz/xz_git.bb22
6 files changed, 50 insertions, 0 deletions
diff --git a/recipes/xz/xz-native.inc b/recipes/xz/xz-native.inc
new file mode 100644
index 0000000000..bc5e9ff39b
--- /dev/null
+++ b/recipes/xz/xz-native.inc
@@ -0,0 +1,2 @@
+inherit native
+require xz_${PV}.bb
diff --git a/recipes/xz/xz-native_4.999.9beta.bb b/recipes/xz/xz-native_4.999.9beta.bb
new file mode 100644
index 0000000000..c4f0da9ead
--- /dev/null
+++ b/recipes/xz/xz-native_4.999.9beta.bb
@@ -0,0 +1,3 @@
+PV = "4.999.9beta"
+
+require xz-native.inc
diff --git a/recipes/xz/xz-native_git.bb b/recipes/xz/xz-native_git.bb
new file mode 100644
index 0000000000..006b9d72eb
--- /dev/null
+++ b/recipes/xz/xz-native_git.bb
@@ -0,0 +1,7 @@
+# XZ_BASE should be the latest released version of xz.
+# It can be set in the distro file.
+#XZ_BASE ?= "4.999.9"
+#SRCREV = "HEAD"
+#PV = "${XZ_BASE}+gitr${SRCREV}"
+PV = "git"
+require xz-native.inc
diff --git a/recipes/xz/xz.inc b/recipes/xz/xz.inc
new file mode 100644
index 0000000000..f103e68639
--- /dev/null
+++ b/recipes/xz/xz.inc
@@ -0,0 +1,8 @@
+DESCRIPTION = "XZ Utils is free general-purpose data compression software with high compression ratio. XZ Utils are the successor to LZMA Utils."
+SECTION = "console/utils"
+LICENSE = "Public Domain"
+INC_PR = "r0"
+S ?= "${WORKDIR}/xz-${PV}"
+#FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/xz-${PV}"
+
+inherit autotools
diff --git a/recipes/xz/xz_4.999.9beta.bb b/recipes/xz/xz_4.999.9beta.bb
new file mode 100644
index 0000000000..4f0adf9343
--- /dev/null
+++ b/recipes/xz/xz_4.999.9beta.bb
@@ -0,0 +1,8 @@
+PV = "4.999.9beta"
+
+require xz.inc
+PR = "${INC_PR}.0"
+SRC_URI = "http://tukaani.org/xz/xz-${PV}.tar.bz2;name=xz"
+SRC_URI[xz.md5sum] = "cc4044fcc073b8bcf3164d1d0df82161"
+SRC_URI[xz.sha256sum] = "330312c4397608d8b7be362cc7edbfeafa6101614bc2164d816ea767656aa15c"
+EXTRA_OECONF = "--enable-shared"
diff --git a/recipes/xz/xz_git.bb b/recipes/xz/xz_git.bb
new file mode 100644
index 0000000000..6c481ed68a
--- /dev/null
+++ b/recipes/xz/xz_git.bb
@@ -0,0 +1,22 @@
+# XZ_BASE should be the latest released version of xz.
+# It can be set in the distro file.
+#XZ_BASE ?= "4.999.9"
+#SRCREV = "HEAD"
+#PV = "${XZ_BASE}+gitr${SRCREV}"
+S = "${WORKDIR}/git"
+PV = "git"
+PR = "${INC_PR}.0"
+SRC_URI = "git://ctrl.tukaani.org/xz.git;branch=master;protocol=git"
+EXTRA_OECONF = "--enable-shared --disable-nls"
+DEFAULT_PREFERENCE = "-1"
+require xz.inc
+inherit gettext
+EXTRA_AUTORECONF = "--install"
+# XXX: Not sure what i managed to break, but this should not be needed!
+# | configure.ac:460: required file `build-aux/config.rpath' not found
+do_configure () {
+ install -D -m0755 ${STAGING_DATADIR}/gettext/config.rpath \
+ ${S}/build-aux/config.rpath
+ autotools_do_configure
+}
+# just disabled nls for now