aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/yum/createrepo-native_0.9.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-25 20:46:02 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2009-03-19 20:22:35 +0100
commit7732204f1e737b5874629ea1469e69ee5db8b0a3 (patch)
treeb1819358908246d48d85e26f52894684331daaaf /recipes/yum/createrepo-native_0.9.bb
parent7fe23916b92d01915c7497edcac55fee9ab67091 (diff)
downloadopenembedded-7732204f1e737b5874629ea1469e69ee5db8b0a3.tar.gz
Add yum and createrepo (from Poky)
Squashed set of changes from Poky: svn r5098 - Add yum-native and createrepo svn r5108 - createrepo-native: Add fix for empty data fields when creating repositories svn r5109 - yum-native: Add patch to fix install paths svn r5110 - yum-native: Add some hacks to make yum work better in the cross build case svn r5118 - yum-native: add depends on libxml2-native svn r5130 - yum-native: Add NOPOST and NOTRIGGERS flags when installing packages svn r5133 - yum-native: Add extract-postinst.awk script for use during rootfs generation svn r5142 - createrepo-native: added dependency on Python svn r5157 - yum: Add yum-install-recommends.py script to handle installing Recommends svn r5379 - yum: added 3.2.18 svn r5385 - yum-metadata-parser: fixed dependencies svn r5392 - yum: do not hardcode arm architecture - rootfs_rpm provide arch info svn r5395 - yum: Don't apply hacks.patch, its only needed for the native version svn r5396 - yum-native: Fix hacks.patch to handle architecture detection issues svn r5426 - yum: fixed packaging svn r5427 - yum: added all required Python modules to dependencies OE changes: yum: do not hardcode /usr yum-native: added intltool-native to dependencies - spotted by Tom Rini
Diffstat (limited to 'recipes/yum/createrepo-native_0.9.bb')
-rw-r--r--recipes/yum/createrepo-native_0.9.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/yum/createrepo-native_0.9.bb b/recipes/yum/createrepo-native_0.9.bb
new file mode 100644
index 0000000000..c634ecb746
--- /dev/null
+++ b/recipes/yum/createrepo-native_0.9.bb
@@ -0,0 +1,17 @@
+DEPENDS = "python-native"
+
+SRC_URI = "http://createrepo.baseurl.org/download/createrepo-${PV}.tar.gz \
+ file://fix.patch;patch=1 \
+ file://pathfix.patch;patch=1 "
+PR = "r1"
+
+inherit autotools native
+
+S = "${WORKDIR}/createrepo-${PV}"
+
+do_compile_append () {
+ sed -e 's#exec /usr/share#exec ${datadir}#' -i ${S}/bin/createrepo
+ sed -e 's#exec /usr/share#exec ${datadir}#' -i ${S}/bin/modifyrepo
+ sed -e 's#!/usr/bin/python#!${bindir}/python#' -i ${S}/genpkgmetadata.py
+ sed -e 's#!/usr/bin/python#!${bindir}/python#' -i ${S}/modifyrepo.py
+}