aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zd1211/zd1211-r83
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/zd1211/zd1211-r83
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/zd1211/zd1211-r83')
-rw-r--r--recipes/zd1211/zd1211-r83/makefile-unslung.patch48
-rw-r--r--recipes/zd1211/zd1211-r83/makefile.patch47
-rw-r--r--recipes/zd1211/zd1211-r83/unslung-iwpriv-hack.patch19
-rw-r--r--recipes/zd1211/zd1211-r83/unslung-writel-logging.patch14
4 files changed, 128 insertions, 0 deletions
diff --git a/recipes/zd1211/zd1211-r83/makefile-unslung.patch b/recipes/zd1211/zd1211-r83/makefile-unslung.patch
new file mode 100644
index 0000000000..bc189e823f
--- /dev/null
+++ b/recipes/zd1211/zd1211-r83/makefile-unslung.patch
@@ -0,0 +1,48 @@
+--- zd1211-driver-r83.orig/Makefile 2006-07-09 04:59:42.000000000 -0500
++++ zd1211-driver-r83/Makefile 2006-10-21 16:27:41.000000000 -0500
+@@ -4,25 +4,25 @@
+ #
+ #
+
+-CC=gcc
+-CPP=g++
+-LD=ld
++CC ?= gcc
++CPP ?= g++
++LD ?= ld
+ rM=rm -f -r
+
+ VERSION := $(shell uname -r)
+-MODPATH := /lib/modules/$(VERSION)
++MODPATH ?= /lib/modules/$(VERSION)
+
+ # if the kernel is 2.6.x, turn on this
+-KERN_26=y
++#KERN_26=y
+
+-KERNEL_SOURCE=$(MODPATH)/source
++KERNEL_SOURCE ?= $(MODPATH)/source
+ #KERNEL_SOURCE=/usr/src/linux
+
+ # set to 1 for zd1211b
+ ZD1211REV_B=0
+
+ SRC_DIR=src
+-DEFINES=-D__KERNEL__ -DMODULE=1
++DEFINES ?= -D__KERNEL__ -DMODULE=1
+
+
+
+@@ -228,9 +228,9 @@
+ depmod -a $(VERSION)
+
+ #for apdbg
+- gcc -o apdbg apdbg.c
+- chmod +x apdbg
+- cp ./apdbg /sbin/apdbg
++# gcc -o apdbg apdbg.c
++# chmod +x apdbg
++# cp ./apdbg /sbin/apdbg
+
+ clean:
+ rm -rf .tmp_versions .*.cmd *.ko *.mod.c *.mod.o *.o $(SRC_DIR)/*.o $(SRC_DIR)/.*.o.cmd
diff --git a/recipes/zd1211/zd1211-r83/makefile.patch b/recipes/zd1211/zd1211-r83/makefile.patch
new file mode 100644
index 0000000000..adc2bd416d
--- /dev/null
+++ b/recipes/zd1211/zd1211-r83/makefile.patch
@@ -0,0 +1,47 @@
+--- zd1211-driver-r83/Makefile.orig 2006-09-02 16:00:00.000000000 +0200
++++ zd1211-driver-r83/Makefile 2006-09-02 16:01:57.000000000 +0200
+@@ -4,10 +4,10 @@
+ #
+ #
+
+-CC=gcc
+-CPP=g++
+-LD=ld
+-rM=rm -f -r
++#CC=gcc
++#CPP=g++
++#LD=ld
++#rM=rm -f -r
+
+ VERSION := $(shell uname -r)
+ MODPATH := /lib/modules/$(VERSION)
+@@ -15,14 +15,14 @@
+ # if the kernel is 2.6.x, turn on this
+ KERN_26=y
+
+-KERNEL_SOURCE=$(MODPATH)/source
++KERNEL_SOURCE ?= $(MODPATH)/source
+ #KERNEL_SOURCE=/usr/src/linux
+
+ # set to 1 for zd1211b
+ ZD1211REV_B=0
+
+ SRC_DIR=src
+-DEFINES=-D__KERNEL__ -DMODULE=1
++DEFINES ?= -D__KERNEL__ -DMODULE=1
+
+
+
+@@ -228,9 +228,9 @@
+ depmod -a $(VERSION)
+
+ #for apdbg
+- gcc -o apdbg apdbg.c
+- chmod +x apdbg
+- cp ./apdbg /sbin/apdbg
++# gcc -o apdbg apdbg.c
++# chmod +x apdbg
++# cp ./apdbg /sbin/apdbg
+
+ clean:
+ rm -rf .tmp_versions .*.cmd *.ko *.mod.c *.mod.o *.o $(SRC_DIR)/*.o $(SRC_DIR)/.*.o.cmd
diff --git a/recipes/zd1211/zd1211-r83/unslung-iwpriv-hack.patch b/recipes/zd1211/zd1211-r83/unslung-iwpriv-hack.patch
new file mode 100644
index 0000000000..64f3806140
--- /dev/null
+++ b/recipes/zd1211/zd1211-r83/unslung-iwpriv-hack.patch
@@ -0,0 +1,19 @@
+--- zd1211-driver-r74/src/zd1205.c~ 2006-04-16 09:42:15.000000000 -0500
++++ zd1211-driver-r74/src/zd1205.c 2006-04-27 12:29:03.000000000 -0500
+@@ -349,8 +349,14 @@
+ { SIOCIWFIRSTPRIV + 0xA, IW_PRIV_TYPE_INT | IW_PRIV_SIZE_FIXED | 1, 0, "connect" },
+ { SIOCIWFIRSTPRIV + 0xB, IW_PRIV_TYPE_INT | IW_PRIV_SIZE_FIXED | 1, 0, "set_mac_mode" },
+ { SIOCIWFIRSTPRIV + 0xC, 0, IW_PRIV_TYPE_CHAR | 12, "get_mac_mode" },
+- { SIOCIWFIRSTPRIV + 0xD, 0, 0, "save_conf" /* has been removed */ },
+- { SIOCIWFIRSTPRIV + 0xE, 0, 0, "load_conf" /* has been removed */ },
++// HACK HACK HACK - The following two lines are commented out in order to make
++// iwpriv work on Unslung (2.4.22 kernel) - this kernel's Wireless Extensions
++// can only handle up to 16 iwpriv entries in this structure. Yes, the correct
++// fix is to patch the Wireless Extensions in the Unslung kernel. This hack
++// should be removed when that's actually done. ~mwester 27APR2006
++// { SIOCIWFIRSTPRIV + 0xD, 0, 0, "save_conf" /* has been removed */ },
++// { SIOCIWFIRSTPRIV + 0xE, 0, 0, "load_conf" /* has been removed */ },
++// End of HACK
+ { SIOCIWFIRSTPRIV + 0xF, 0, IW_PRIV_TYPE_CHAR | 14, "get_Region" },
+ { SIOCIWFIRSTPRIV + 0x9,IW_PRIV_TYPE_INT | IW_PRIV_SIZE_FIXED | 1, 0, "set_Region" },
+ };
diff --git a/recipes/zd1211/zd1211-r83/unslung-writel-logging.patch b/recipes/zd1211/zd1211-r83/unslung-writel-logging.patch
new file mode 100644
index 0000000000..00d54d7d68
--- /dev/null
+++ b/recipes/zd1211/zd1211-r83/unslung-writel-logging.patch
@@ -0,0 +1,14 @@
+--- zd1211-driver-r74/src/zd1211.c~ 2006-04-09 12:28:06.000000000 -0500
++++ zd1211-driver-r74/src/zd1211.c 2006-04-27 12:38:55.000000000 -0500
+@@ -652,7 +652,10 @@
+ count++;
+
+ if (count > 5) {
+- printk(KERN_ERR "1211_readl failed for 5 attempts...Very Serious");
++// You are going to see this often enough on Unslung that we might as well put it in
++// the syslog and fix it so it has a nl on the end. Sigh. ~mwester, 27APR06
++//
++ printk(KERN_ERR "1211_readl failed for 5 attempts...Very Serious\n");
+ break;
+ }
+ }