aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zip
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2010-05-15 22:58:14 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2010-05-15 22:58:14 +0200
commit3da1686952f90147cc9971da28ef486dd81b9c27 (patch)
tree74d8b3c365a949463a129dae6b2bc43bfe9db103 /recipes/zip
parent89187f3050ab771c4315f69e3e92dddb9a630b7a (diff)
downloadopenembedded-3da1686952f90147cc9971da28ef486dd81b9c27.tar.gz
zip: use BBCLASSEXTEND = "native" for native recipe
Diffstat (limited to 'recipes/zip')
-rw-r--r--recipes/zip/zip-native_2.32.bb13
-rw-r--r--recipes/zip/zip.inc4
2 files changed, 4 insertions, 13 deletions
diff --git a/recipes/zip/zip-native_2.32.bb b/recipes/zip/zip-native_2.32.bb
deleted file mode 100644
index fa5d8210b5..0000000000
--- a/recipes/zip/zip-native_2.32.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-require zip_${PV}.bb
-
-inherit native
-
-S = "${WORKDIR}/zip-${PV}"
-
-do_stage() {
- install -d ${STAGING_BINDIR}
- install zip zipnote zipsplit zipcloak ${STAGING_BINDIR}
-}
-
-SRC_URI[md5sum] = "8a4da4460386e324debe97f3b7fe4d96"
-SRC_URI[sha256sum] = "d0d3743f732a9baa162f80d0c4567b9c545b41a3385825042113810f2a56eb2f"
diff --git a/recipes/zip/zip.inc b/recipes/zip/zip.inc
index 0ac49139f4..3ac8ce8c2a 100644
--- a/recipes/zip/zip.inc
+++ b/recipes/zip/zip.inc
@@ -4,6 +4,10 @@ LICENSE = "Info-ZIP"
SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/zip${@bb.data.getVar('PV',d,1).replace('.', '')}.tar.gz"
+BBCLASSEXTEND = "native"
+
+NATIVE_INSTALL_WORKS = "1"
+
EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC} ${LDFLAGS}' 'AS=${CC} -c' 'CPP=${CPP}' \
'CFLAGS=-I. -DUNIX ${CFLAGS} ${LDFLAGS}' 'LFLAGS1=${LDFLAGS}' 'INSTALL=install' \
'BINFLAGS=0755' 'INSTALL_D=install -d'"