aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zshopi
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/zshopi
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/zshopi')
-rw-r--r--recipes/zshopi/files/zshopi.desktop6
-rw-r--r--recipes/zshopi/files/zshopi.pngbin0 -> 2416 bytes
-rw-r--r--recipes/zshopi/zshopi_0.2.bb42
3 files changed, 48 insertions, 0 deletions
diff --git a/recipes/zshopi/files/zshopi.desktop b/recipes/zshopi/files/zshopi.desktop
new file mode 100644
index 0000000000..232e06cd42
--- /dev/null
+++ b/recipes/zshopi/files/zshopi.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Comment=Shopping list for the Zaurus.
+Exec=zshopi
+Icon=zshopi
+Type=Application
+Name=ZShopi
diff --git a/recipes/zshopi/files/zshopi.png b/recipes/zshopi/files/zshopi.png
new file mode 100644
index 0000000000..c75f52bedd
--- /dev/null
+++ b/recipes/zshopi/files/zshopi.png
Binary files differ
diff --git a/recipes/zshopi/zshopi_0.2.bb b/recipes/zshopi/zshopi_0.2.bb
new file mode 100644
index 0000000000..098ac2b664
--- /dev/null
+++ b/recipes/zshopi/zshopi_0.2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Shopping manager"
+SECTION = "opie/applications"
+DEPENDS = "sqlite opie-lrelease-native"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.lachner-net.de/"
+AUTHOR = "Bernd Lachner <dev@lachner-net.de>"
+APPTYPE = "binary"
+APPNAME = "zshopi"
+APPDESKTOP = "${WORKDIR}"
+PR = "r1"
+
+SRC_URI = "http://www.lachner-net.de/old/Frames/Software/zshopi_0.2.tar.bz2 \
+file://zshopi.desktop \
+file://zshopi.png"
+
+S = "${WORKDIR}/${PN}_${PV}/${PN}/"
+
+PACKAGES_prepend = "zshopi-i18n-de "
+
+FILES_zshopi-i18n-de = "/opt/QtPalmtop/i18n/*"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST += "DEFINES+=QTOPIA LIBS+=-lm LIBS+=-lsqlite LIBS+=-lqpe"
+OE_QMAKE_CXXFLAGS = "-fno-rtti ${CXXFLAGS}"
+
+do_configure_prepend() {
+ qmake -project
+}
+
+do_install() {
+
+ cd "${WORKDIR}/${PN}_${PV}/zshopi"
+ opie-lrelease zshopi.de.ts
+
+
+ install -d ${D}${palmtopdir}/i18n/de
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 ${WORKDIR}/zshopi.png ${D}${palmtopdir}/pics/
+ install -m 0644 ${WORKDIR}/${PN}_${PV}/zshopi/zshopi.de.qm ${D}${palmtopdir}/i18n/de/zshopi.qm
+}