aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zten
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/zten
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/zten')
-rw-r--r--recipes/zten/files/zten.patch37
-rw-r--r--recipes/zten/zten_1.6.2.bb28
2 files changed, 65 insertions, 0 deletions
diff --git a/recipes/zten/files/zten.patch b/recipes/zten/files/zten.patch
new file mode 100644
index 0000000000..3fff27a23d
--- /dev/null
+++ b/recipes/zten/files/zten.patch
@@ -0,0 +1,37 @@
+upstream: no upstream bug tracker. Laibsch contacted author by mail on 2008-02-17.
+
+--- zten/zten.pro.orig 2003-02-16 16:45:44.000000000 +0100
++++ zten/zten.pro 2006-04-23 18:50:19.000000000 +0200
+@@ -1,11 +1,9 @@
+ TEMPLATE = app
+ CONFIG = qt warn_on release
+-HEADERS = pixmap.h \
+- qbookbrowser.h \
++HEADERS = qbookbrowser.h \
+ qbookentry.h \
+ qbookitem.h \
+ qhistorylineedit.h \
+- qlabeledit.h \
+ qlistboxrichtext.h \
+ zpixmap.h \
+ zten.h \
+@@ -29,5 +27,5 @@
+ ztenbookbase.ui \
+ ztencandidatebase.ui \
+ ztenextbase.ui
+-LIBS += -lqpe /opt/Embedix/lib/libeb.a /opt/Embedix/lib/libz.a -L/opt/QtPalmtop/lib -lkakasi
++LIBS += -lqpe -leb -lz -lkakasi
+ TRANSLATIONS = zten.ts
+
+--- zten/qbookentry.cpp.orig 2006-04-23 23:38:00.000000000 +0200
++++ zten/qbookentry.cpp 2006-04-23 23:38:10.000000000 +0200
+@@ -14,7 +14,8 @@
+ }
+
+ static const char* INSERT_MARK = "\a";
+-QTextCodec* g_codec;
++//QTextCodec* g_codec = NULL;
++QTextCodec* g_codec = QTextCodec::codecForName("eucJP");
+ unsigned int last_wide_font = 0;
+ unsigned int last_narrow_font = 0;
+
diff --git a/recipes/zten/zten_1.6.2.bb b/recipes/zten/zten_1.6.2.bb
new file mode 100644
index 0000000000..33feae0911
--- /dev/null
+++ b/recipes/zten/zten_1.6.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "EB*/EPWING dictionary browser for Linux Zaurus"
+AUTHOR = "Yuuichi Teranishi <teranisi@gohome.org>"
+HOMEPAGE = "http://www.gohome.org/zten"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "eb kakasi"
+RDEPENDS = "virtual/japanese-font"
+RCONFLICTS = "ztenv"
+
+SRC_URI = "http://www.gohome.org/cgi-bin/viewcvs.cgi/zten.tar.gz;md5sum=d24f03c8df5c98d510590bd9a63dc932 \
+ file://zten.patch;patch=1"
+
+S = "${WORKDIR}/zten"
+
+inherit palmtop
+
+CXXFLAGS += " -DQWS"
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin
+ install -d ${D}${palmtopdir}/apps/Applications
+ install -d ${D}${palmtopdir}/pics
+ install -m 0755 zten ${D}${palmtopdir}/bin/zten
+ install -m 0644 zten.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 Zten.png ${D}${palmtopdir}/pics
+}
+