aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-09-18 17:28:20 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-09-18 22:40:27 +0800
commit483450b23bd2ebaa63fada21aa5ed61b1cefada0 (patch)
treedaae04a32c0d5e188f5417254cc02dd0a03dec51 /recipes
parentd50fa7e5a22e546c5548d2cd2b20e313307e0afe (diff)
downloadopenembedded-483450b23bd2ebaa63fada21aa5ed61b1cefada0.tar.gz
busybox: Apply a paych for make3.82 and the Makefile
Newer make do not like to mix different types of rules, take the patch from upstream master to address this.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/busybox/busybox-1.13.2/busybox-1.13.2-make382.patch40
-rw-r--r--recipes/busybox/busybox_1.13.2.bb3
2 files changed, 42 insertions, 1 deletions
diff --git a/recipes/busybox/busybox-1.13.2/busybox-1.13.2-make382.patch b/recipes/busybox/busybox-1.13.2/busybox-1.13.2-make382.patch
new file mode 100644
index 0000000000..caf874ca69
--- /dev/null
+++ b/recipes/busybox/busybox-1.13.2/busybox-1.13.2-make382.patch
@@ -0,0 +1,40 @@
+From adbe3b5b982874071b9b826cea1632fc00c85982 Mon Sep 17 00:00:00 2001
+From: Denys Vlasenko <vda.linux@googlemail.com>
+Date: Sun, 22 Aug 2010 07:28:46 +0000
+Subject: build system: make 3.82 fix. Closes bug 2323
+
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+---
+Index: busybox-1.13.2/Makefile
+===================================================================
+--- busybox-1.13.2.orig/Makefile
++++ busybox-1.13.2/Makefile
+@@ -418,7 +418,12 @@ ifeq ($(config-targets),1)
+ -include $(srctree)/arch/$(ARCH)/Makefile
+ export KBUILD_DEFCONFIG
+
+-config %config: scripts_basic outputmakefile FORCE
++config: scripts_basic outputmakefile FORCE
++ $(Q)mkdir -p include
++ $(Q)$(MAKE) $(build)=scripts/kconfig $@
++ $(Q)$(MAKE) -C $(srctree) KBUILD_SRC= .kernelrelease
++
++%config: scripts_basic outputmakefile FORCE
+ $(Q)mkdir -p include
+ $(Q)$(MAKE) $(build)=scripts/kconfig $@
+ $(Q)$(MAKE) -C $(srctree) KBUILD_SRC= .kernelrelease
+@@ -1266,9 +1271,13 @@ endif
+ $(Q)$(MAKE) $(build)=$(build-dir) $(target-dir)$(notdir $@)
+
+ # Modules
+-/ %/: prepare scripts FORCE
++%/: prepare scripts FORCE
+ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
+ $(build)=$(build-dir)
++/: prepare scripts FORCE
++ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
++ $(build)=$(build-dir)
++
+ %.ko: prepare scripts FORCE
+ $(Q)$(MAKE) KBUILD_MODULES=$(if $(CONFIG_MODULES),1) \
+ $(build)=$(build-dir) $(@:.ko=.o)
diff --git a/recipes/busybox/busybox_1.13.2.bb b/recipes/busybox/busybox_1.13.2.bb
index 0741d5c614..a3acceb5ae 100644
--- a/recipes/busybox/busybox_1.13.2.bb
+++ b/recipes/busybox/busybox_1.13.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
@@ -15,6 +15,7 @@ SRC_URI = "\
file://busybox-1.13.2-top24.patch \
file://busybox-1.13.2-unzip.patch \
file://busybox-1.13.2-wget.patch \
+ file://busybox-1.13.2-make382.patch \
file://fdisk_nios2.patch \
\
file://udhcpscript.patch \