aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-12-14 15:47:16 +0100
committerKoen Kooi <koen@openembedded.org>2010-12-14 15:47:16 +0100
commit26d3cbffe1bc4d5efaf0774347292e58b6ac062d (patch)
treef9947a0c33785b65e81099884e05683b5ec51096 /recipes
parent9ff5ca924fbb268bb3aae52b0788ba7ff1f4da75 (diff)
downloadopenembedded-26d3cbffe1bc4d5efaf0774347292e58b6ac062d.tar.gz
libdce: add latest git
Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ti/libdce_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/ti/libdce_git.bb b/recipes/ti/libdce_git.bb
new file mode 100644
index 0000000000..63ff5280b3
--- /dev/null
+++ b/recipes/ti/libdce_git.bb
@@ -0,0 +1,20 @@
+DEPENDS = "ti-libd2cmap ti-tiler-memmgr ti-syslink"
+
+LICENSE = "TI"
+
+inherit autotools lib_package
+
+PV = "1.0.0"
+PR_append = "+gitr${SRCREV}"
+
+SRCREV = "340931755707a6d5a1af"
+SRC_URI = "git://github.com/robclark/libdce.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ install -d ${D}${base_libdir}/firmware/omap4
+ install -m 0644 firmware/* ${D}${base_libdir}/firmware/omap4/
+}
+
+FILES_${PN} += "${base_libdir}/firmware/"