aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-12-05 19:26:56 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-12-05 20:35:33 +0100
commit26dcbd8cb668807061ada8a6979daaff2f85556d (patch)
tree02b0471bf74e8efd5c2d7c56883c3e2b84a34939 /recipes
parent8ea3c122ace4447919311007d6b24d5fbd3b6ad1 (diff)
downloadopenembedded-26dcbd8cb668807061ada8a6979daaff2f85556d.tar.gz
libsdl-mixer 1.2.11: wrap the mp3 dependency in enterprise and bump PR
Distributing an MP3 encoder/decoder can be problematic in the countries where software patents are legal and enforceable. So people not wanting to distribute or use mp3 can set ENTERPRISE_DISTRO in their local.conf to avoid the dependency. As adding ENTERPRISE_DISTRO mask some dependencies, this patch should permit to build libsdl-mixer with enterprise set. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.11.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes/libsdl/libsdl-mixer_1.2.11.bb b/recipes/libsdl/libsdl-mixer_1.2.11.bb
index 8c032ceb03..498f3591c5 100644
--- a/recipes/libsdl/libsdl-mixer_1.2.11.bb
+++ b/recipes/libsdl/libsdl-mixer_1.2.11.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "Simple DirectMedia Layer mixer library."
SECTION = "libs"
PRIORITY = "optional"
-DEPENDS = "virtual/libsdl flac libmikmod libvorbis libmad"
+DEPENDS = "virtual/libsdl flac libmikmod libvorbis ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
LICENSE = "LGPL"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
file://fix-flac-madness.diff"
@@ -20,7 +20,7 @@ inherit autotools
# Add support for runtime linking with libmad so we can use that for fixed point MP3 decoding.
# Add support for runtime linking with libtremor so we can use that for fixed point OGG Vorbis decoding.
-EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor --enable-music-mp3-mad-gpl LIBS=-L${STAGING_LIBDIR}"
+EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-music-mp3-mad-gpl', d)} LIBS=-L${STAGING_LIBDIR}"
do_compile() {
# Override SDL_LIBS to include a linker rpath so the linker