aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-12-14 15:58:21 +0100
committerKoen Kooi <koen@openembedded.org>2010-12-14 15:58:21 +0100
commit44bc29c4c03aead7dc38f059cd01ae77446dbae9 (patch)
treef979d0c41685f913cae4d3fbe168393d08141466 /recipes
parent018b214c358bce69b9328f9a58ba2bcbf6436e99 (diff)
downloadopenembedded-44bc29c4c03aead7dc38f059cd01ae77446dbae9.tar.gz
omapfbplay-dce: add DCE capable omapfbplay
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ffmpeg/omapfbplay-dce_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/ffmpeg/omapfbplay-dce_git.bb b/recipes/ffmpeg/omapfbplay-dce_git.bb
new file mode 100644
index 0000000000..6441da08b2
--- /dev/null
+++ b/recipes/ffmpeg/omapfbplay-dce_git.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Simple ffmpeg-based player that uses the omapfb overlays"
+DEPENDS = "libdce bzip2 lame ffmpeg virtual/kernel"
+LICENSE = "MIT"
+
+PR = "r0"
+
+PV = "0.0+${PR}+gitr${SRCREV}"
+
+SRCREV = "1d217676ba71e8740524e9814c47da39880ed3bc"
+SRC_URI = "git://git.mansr.com/omapfbplay;protocol=git \
+"
+
+S = "${WORKDIR}/git"
+
+# We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that
+STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"
+
+CFLAGS += " -I. -I${STAGING_INCDIR}/dce -I${STAGING_KERNEL_DIR}/include "
+
+do_compile() {
+ cp ${STAGING_KERNEL_DIR}/arch/arm/plat-omap/include/mach/omapfb.h ${S} || true
+ cp ${STAGING_KERNEL_DIR}/include/asm-arm/arch-omap/omapfb.h ${S} || true
+ cp ${STAGING_KERNEL_DIR}/include/linux/omapfb.h ${S} || true
+ oe_runmake ${TARGET_ARCH}=y V4L2=y OMAPFB=y NETSYNC=y DCE=y -e
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/omapfbplay ${D}/${bindir}/omapfbplay-dce
+}