aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-11-25 20:07:25 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-30 02:00:13 +0100
commit454d36fb54dd392ad70bbfb1978ca2b337c689e1 (patch)
tree2d3a5e706fcca8fc43f2eb0c95510815b734f172 /recipes
parentf519bc2e363cc4ccb8acf5f1a7faa335e9e07d1d (diff)
downloadopenembedded-454d36fb54dd392ad70bbfb1978ca2b337c689e1.tar.gz
libogg: update to version 1.1.4
* switch to INC_PR and use the reworked autotools functions * bump PR
Diffstat (limited to 'recipes')
-rw-r--r--recipes/libogg/libogg.inc11
-rw-r--r--recipes/libogg/libogg_1.0.bb18
-rw-r--r--recipes/libogg/libogg_1.1.3.bb17
-rw-r--r--recipes/libogg/libogg_1.1.4.bb4
-rw-r--r--recipes/libogg/libogg_1.1.bb19
5 files changed, 22 insertions, 47 deletions
diff --git a/recipes/libogg/libogg.inc b/recipes/libogg/libogg.inc
new file mode 100644
index 0000000000..f8eed60fef
--- /dev/null
+++ b/recipes/libogg/libogg.inc
@@ -0,0 +1,11 @@
+SECTION = "libs"
+DESCRIPTION = "libogg is the bitstream and framing library \
+for the Ogg project. It provides functions which are \
+necessary to codec libraries like libvorbis."
+LICENSE = "BSD"
+
+INC_PR = "r4"
+
+inherit autotools
+
+SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
diff --git a/recipes/libogg/libogg_1.0.bb b/recipes/libogg/libogg_1.0.bb
index 7af1468004..d5bad18a0a 100644
--- a/recipes/libogg/libogg_1.0.bb
+++ b/recipes/libogg/libogg_1.0.bb
@@ -1,18 +1,4 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
-PR = "r1"
+require libogg.inc
-SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libogg-${PV}.tar.gz"
+PR = "${INC_PR}.0"
-inherit autotools pkgconfig
-
-do_stage () {
- oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ogg
- (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
- install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/recipes/libogg/libogg_1.1.3.bb b/recipes/libogg/libogg_1.1.3.bb
index 0a6e827ff1..d5bad18a0a 100644
--- a/recipes/libogg/libogg_1.1.3.bb
+++ b/recipes/libogg/libogg_1.1.3.bb
@@ -1,17 +1,4 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
+require libogg.inc
-SRC_URI = "http://downloads.xiph.org/releases/ogg/libogg-${PV}.tar.gz"
+PR = "${INC_PR}.0"
-inherit autotools pkgconfig
-
-do_stage () {
- oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ogg
- (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
- install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/recipes/libogg/libogg_1.1.4.bb b/recipes/libogg/libogg_1.1.4.bb
new file mode 100644
index 0000000000..d5bad18a0a
--- /dev/null
+++ b/recipes/libogg/libogg_1.1.4.bb
@@ -0,0 +1,4 @@
+require libogg.inc
+
+PR = "${INC_PR}.0"
+
diff --git a/recipes/libogg/libogg_1.1.bb b/recipes/libogg/libogg_1.1.bb
index 687b4decec..0baec126e3 100644
--- a/recipes/libogg/libogg_1.1.bb
+++ b/recipes/libogg/libogg_1.1.bb
@@ -1,19 +1,6 @@
-SECTION = "libs"
-DESCRIPTION = "libogg is the bitstream and framing library \
-for the Ogg project. It provides functions which are \
-necessary to codec libraries like libvorbis."
-LICENSE = "BSD"
-PR = "r3"
+require libogg.inc
-SRC_URI = "http://www.vorbis.com/files/1.0.1/unix/libogg-${PV}.tar.gz \
-file://m4.patch;patch=1"
+PR = "${INC_PR}.0"
-inherit autotools pkgconfig
+SRC_URI += "file://m4.patch;patch=1"
-do_stage () {
- oe_libinstall -a -so -C src libogg ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/ogg
- (cd ${S}/include/ogg; cp config_types.h ogg.h os_types.h ${STAGING_INCDIR}/ogg/)
- install -m 0644 ${S}/ogg.m4 ${STAGING_DATADIR}/aclocal/
-}