aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-11-19 17:33:00 +0100
committerKhem Raj <raj.khem@gmail.com>2010-11-24 14:09:27 -0800
commit4a24a5522b0df60e47521c8d1e7762bdeff8bcfd (patch)
tree954ea8743c8cd8390878a74873a9732d20c456ac /recipes
parentfe798c3a31ee44591fdcecccfa9832f55caeaf1a (diff)
downloadopenembedded-4a24a5522b0df60e47521c8d1e7762bdeff8bcfd.tar.gz
gsl.inc: Remove `do_stage`.
Inkscape fails to build after commit c2c8fe [1] with the following error. | checking for CAIRO_USER_FONTS... yes | checking for INKSCAPE... configure: error: Package requirements (gdkmm-2.4 glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0 gtk+-2.0 libxml-2.0 >= 2.6.11 libxslt >= 1.0.15 cairo sigc++-2.0 >= 2.0.12 gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met: | | No package 'gsl' found | | Consider adjusting the PKG_CONFIG_PATH environment variable if you | installed software in a non-standard prefix. | | Alternatively, you may set the environment variables INKSCAPE_CFLAGS | and INKSCAPE_LIBS to avoid the need to call pkg-config. | See the pkg-config man page for more details. | | ERROR: Function do_configure failed NOTE: package inkscape-0.48.0-r0: task do_configure: Failed ERROR: TaskFailed event exception, aborting ERROR: Build of /home/paul/oe/openembedded/recipes/inkscape/inkscape_0.48.0.bb do_configure failed Removing `do_stage` fixes building `inkscape_0.48.0.bb` with `angstrom-2008.1`, `angstrom-2010.x` and `minimal` for `MACHINE = "beagleboard"`. [1] http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=c2c8fe4c5629add94bd0b922f5b3446624a9f4d8 Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Andreas Oberritter <obi@opendreambox.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gsl/gsl.inc11
1 files changed, 1 insertions, 10 deletions
diff --git a/recipes/gsl/gsl.inc b/recipes/gsl/gsl.inc
index bc4865c15b..10bacc523d 100644
--- a/recipes/gsl/gsl.inc
+++ b/recipes/gsl/gsl.inc
@@ -3,17 +3,8 @@ HOMEPAGE = "http://www.gnu.org/software/gsl/"
SECTION = "libs"
PRIORITY = "optional"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
inherit autotools pkgconfig binconfig
LEAD_SONAME = "libgsl.so"
-
-do_stage() {
- oe_runmake DESTDIR=${S}/.install install
- oe_libinstall -so -C cblas/.libs/ libgslcblas ${STAGING_LIBDIR}
- oe_libinstall -so -C .libs/ libgsl ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/gsl
- install -m 0644 .install${includedir}/gsl/* ${STAGING_INCDIR}/gsl
-}