aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-11-11 23:03:31 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-11 23:05:22 +0100
commit5793e93f71db384b6671d4293614b71334161e52 (patch)
tree397c204de3a1d3b0cd50b179c7f765f33b1cb63b /recipes
parent140929089dcaa82c1c322314bb82af786e12afab (diff)
downloadopenembedded-5793e93f71db384b6671d4293614b71334161e52.tar.gz
libsdl-mixer: update to version 1.2.10
* don't made it the default yet
Diffstat (limited to 'recipes')
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.10.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-mixer_1.2.10.bb b/recipes/libsdl/libsdl-mixer_1.2.10.bb
new file mode 100644
index 0000000000..1a9e808c52
--- /dev/null
+++ b/recipes/libsdl/libsdl-mixer_1.2.10.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Simple DirectMedia Layer mixer library."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libmikmod libvorbis"
+LICENSE = "LGPL"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_mixer-${PV}"
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+inherit autotools_stage
+
+EXTRA_OECONF = "--disable-music-mp3"
+# although we build smpeg... need to find out how
+# to deal with optional dependencies
+
+do_compile() {
+ # Override SDL_LIBS to include a linker rpath so the linker
+ # can find the correct libdl.so when it links playwave to
+ # libSDL_mixer.so.
+ oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
+}