aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-12-14 19:47:36 +0000
committerKoen Kooi <koen@openembedded.org>2010-01-06 09:34:56 +0100
commit7762f3d7b64dd02fbb7cd5dda14a562deef33ab4 (patch)
tree2fa26aff72a1b6874b29a324310e240d61eacb06 /recipes
parent3da2d1d860c952690eec157d3b552056ca1a1c9e (diff)
downloadopenembedded-7762f3d7b64dd02fbb7cd5dda14a562deef33ab4.tar.gz
libsdl-mixer: Add libMAD and libTremor support to SDL Mixer 1.2.11.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.11.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes/libsdl/libsdl-mixer_1.2.11.bb b/recipes/libsdl/libsdl-mixer_1.2.11.bb
index ee0ba454ba..d6c9c69531 100644
--- a/recipes/libsdl/libsdl-mixer_1.2.11.bb
+++ b/recipes/libsdl/libsdl-mixer_1.2.11.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "Simple DirectMedia Layer mixer library."
SECTION = "libs"
PRIORITY = "optional"
-DEPENDS = "virtual/libsdl flac libmikmod libvorbis"
+DEPENDS = "virtual/libsdl flac libmikmod libvorbis libmad"
LICENSE = "LGPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
file://fix-flac-madness.diff;patch=1"
@@ -15,9 +15,12 @@ export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
inherit autotools_stage
-EXTRA_OECONF = "--disable-music-mp3"
-# although we build smpeg... need to find out how
-# to deal with optional dependencies
+# Although we build SMPEG lets not use it as it is pointless in the embedded space.
+
+# Add support for runtime linking with libmad so we can use that for fixed point MP3 decoding.
+# Add support for runtime linking with libtremor so we can use that for fixed point OGG Vorbis decoding.
+
+EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor --enable-music-mp3-mad-gpl"
do_compile() {
# Override SDL_LIBS to include a linker rpath so the linker