aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-11-04 21:57:05 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-11-04 21:57:05 +0000
commit846588de960200be9cc2553fc8fac1ae81758466 (patch)
treec83f6bc345168e97297d211aa98e573e90494552 /recipes
parent691030b524bf1a4f94f3d7da846ce61ea20ece0a (diff)
downloadopenembedded-846588de960200be9cc2553fc8fac1ae81758466.tar.gz
prismstumbler-0.7.3+0.7.4pre1: Use much simper and more robust libgps check.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/libgps-check.patch57
-rw-r--r--recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb6
2 files changed, 60 insertions, 3 deletions
diff --git a/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/libgps-check.patch b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/libgps-check.patch
new file mode 100644
index 0000000000..613adb2255
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/libgps-check.patch
@@ -0,0 +1,57 @@
+Index: prismstumbler-0.7.4pre1/configure.ac
+===================================================================
+--- prismstumbler-0.7.4pre1.orig/configure.ac
++++ prismstumbler-0.7.4pre1/configure.ac
+@@ -137,51 +137,11 @@ AC_ARG_ENABLE(static-libgps,
+ ], [ static_libgps="no"]
+ )
+
+-AC_MSG_CHECKING(for libgps)
+-AC_ARG_WITH(libgps,
+-[ --with-libgps=DIR use libgps in DIR],
+-[ case "$withval" in
+- *)
+- AC_MSG_RESULT($withval)
+- if test -f $withval/include/gps.h -a -f $withval/lib/libgps.a; then
+- owd=`pwd`
+- if cd $withval; then withval=`pwd`; cd $owd; fi
+- libgps_dir=${withval}
+- GPSD_CFLAGS="-I$withval/include"
+- if test "x$static_libgps" = "xyes"; then
+- GPSD_LIBS="-lm -lpthread $withval/lib/libgps.a"
+- else
+- GPSD_LIBS="-L$withval/lib -lgps"
+- fi
+- else
+- AC_ERROR(libgps not found in $withval prefix)
+- fi
+- ;;
+- esac ],
+-[
+- for dir in ${prefix} ${prefix}/local /usr /usr/local; do
+- if test -f ${dir}/include/gps.h -a -f ${dir}/lib/libgps.a; then
+- libgps_dir=${dir}
+- GPSD_CFLAGS="-I${dir}/include"
+- if test "x$static_libgps" = "xyes"; then
+- GPSD_LIBS="-lm -lpthread ${dir}/lib/libgps.a"
+- else
+- GPSD_LIBS="-L${dir}/lib -lgps"
+- fi
+- fi
+- done
+- if test -z ${libgps_dir}; then
+- AC_MSG_RESULT(no)
+- AC_ERROR(libgps not found)
+- fi
+- AC_MSG_RESULT(yes) ]
+-)
++PKG_CHECK_MODULES([GPSD], [libgps])
+
+ if test -z "$GPSD_CFLAGS"; then
+ AC_ERROR("libgps not found")
+ fi
+-AC_SUBST(GPSD_CFLAGS)
+-AC_SUBST(GPSD_LIBS)
+
+
+ dnl Checks for wireless lib
diff --git a/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb b/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
index bc23824e42..fb444e2f01 100644
--- a/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
+++ b/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
@@ -1,5 +1,5 @@
SECTION = "x11/network"
-PR = "r3"
+PR = "r4"
PACKAGES = "${PN}-dbg prismstumbler prismstumbler-frontend prismstumbler-doc"
DESCRIPTION = "Prismstumbler wireless LAN scanner"
@@ -14,7 +14,8 @@ RRECOMMENDS = "gpsd"
SRC_URI = "http://projects.linuxtogo.org/frs/download.php/14/${PN}-0.7.4pre1.tar.gz \
file://gpsapi.patch;patch=1 \
${@['', 'file://wireless.patch;patch=1'][bb.data.getVar('PREFERRED_VERSION_linux-libc-headers', d, 1) and bb.data.getVar('PREFERRED_VERSION_linux-libc-headers', d, 1).split('.')[2] < '30']} \
- file://fix-includes.patch;patch=1;pnum=0"
+ file://fix-includes.patch;patch=1;pnum=0 \
+ file://libgps-check.patch;patch=1"
S = "${WORKDIR}/${PN}-0.7.4pre1"
@@ -22,7 +23,6 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR} \
- --with-libgps=${STAGING_EXECPREFIXDIR} \
--with-libpcap=${STAGING_EXECPREFIXDIR} \
--with-sqlite-includes=${STAGING_INCDIR} \
--with-sqlite-libs=${STAGING_LIBDIR} \