aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-29 23:45:14 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-29 23:51:35 +0200
commita7d9d113aa5f536f54bd9b37c13b436c067fce07 (patch)
tree085febce54e44ca149bb9e9c11ff6423b30a88cd /recipes
parent049f0f6d1ea8f66b496dd2382fb72e6136d3e09c (diff)
downloadopenembedded-a7d9d113aa5f536f54bd9b37c13b436c067fce07.tar.gz
linux-openmoko-2.6.34: update mci resume patch a bit
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch25
-rw-r--r--recipes/linux/linux-openmoko-2.6.34_git.bb2
2 files changed, 20 insertions, 7 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch b/recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch
index fa3b1389a5..1f996fafaf 100644
--- a/recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch
+++ b/recipes/linux/linux-openmoko-2.6.34/0001-glamo-mci-add-MMC_CAP_NONREMOVABLE.patch
@@ -1,14 +1,14 @@
-From ceee4a77574ebb8fe211043731f64f585f87b7de Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
+From 10e7f7b2132aaac8e3ebc549d3837cc2df888df7 Mon Sep 17 00:00:00 2001
+From: Thibaut Girka <thib@sitedethib.com>
Date: Tue, 29 Jun 2010 12:54:03 +0200
-Subject: [PATCH] glamo-mci: add MMC_CAP_NONREMOVABLE
+Subject: [PATCH] glamo-mci: add MMC_CAP_NONREMOVABLE and move enable_irq to right place
---
- drivers/mmc/host/glamo-mci.c | 1 +
- 1 files changed, 1 insertions(+), 0 deletions(-)
+ drivers/mmc/host/glamo-mci.c | 5 +++--
+ 1 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/mmc/host/glamo-mci.c b/drivers/mmc/host/glamo-mci.c
-index b2442c2..7c96b4c 100644
+index b2442c2..11deb7d 100644
--- a/drivers/mmc/host/glamo-mci.c
+++ b/drivers/mmc/host/glamo-mci.c
@@ -811,6 +811,7 @@ static int glamo_mci_probe(struct platform_device *pdev)
@@ -19,6 +19,19 @@ index b2442c2..7c96b4c 100644
MMC_CAP_SD_HIGHSPEED;
mmc->f_min = host->clk_rate / 256;
mmc->f_max = sd_max_clk;
+@@ -930,10 +931,10 @@ static int glamo_mci_resume(struct device *dev)
+ glamo_mci_reset(host);
+ mdelay(10);
+
+- ret = mmc_resume_host(host->mmc);
+-
+ enable_irq(host->irq);
+
++ ret = mmc_resume_host(host->mmc);
++
+ mmc_host_lazy_disable(host->mmc);
+
+ return ret;
--
1.7.1
diff --git a/recipes/linux/linux-openmoko-2.6.34_git.bb b/recipes/linux/linux-openmoko-2.6.34_git.bb
index 7381123c6e..5ba2196ce8 100644
--- a/recipes/linux/linux-openmoko-2.6.34_git.bb
+++ b/recipes/linux/linux-openmoko-2.6.34_git.bb
@@ -4,7 +4,7 @@ require linux-openmoko.inc
KERNEL_RELEASE="2.6.34"
SRCREV = "4ce5f33cd4bcde2e25d50ae0880eb39213e2b6d2"
-OEV = "oe4.1"
+OEV = "oe4.2"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
SRC_URI = "\