aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-21 11:09:25 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-21 11:09:25 +0200
commitacb6551a2ab3352006f3822c9f374afba732146d (patch)
tree1566d5bd5c222a06535b810dbf8a5efd1747ca92 /recipes
parent7a67dcd27d8512128d207891ffd597399a4760f0 (diff)
downloadopenembedded-acb6551a2ab3352006f3822c9f374afba732146d.tar.gz
ptlib: update to 2.6.4
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ekiga/ptlib_2.6.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/ekiga/ptlib_2.6.4.bb b/recipes/ekiga/ptlib_2.6.4.bb
new file mode 100644
index 0000000000..93a3bd8c96
--- /dev/null
+++ b/recipes/ekiga/ptlib_2.6.4.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Portable Tools Libary"
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += "libgsm openldap openssl expat virtual/libsdl alsa-lib"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/ptlib-${PV}.tar.bz2"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ ptlib.pc
+}
+
+FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+
+