aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-11-30 01:52:40 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-30 02:00:14 +0100
commitcfba2ac2e3846bb16237cf97f33f855fd330c3c8 (patch)
tree8aa8f76e0f5f9fb6164820c5dfda92dec330dcbb /recipes
parent06f3e11fc922fea4a4ccb85ec4916200fb60244a (diff)
downloadopenembedded-cfba2ac2e3846bb16237cf97f33f855fd330c3c8.tar.gz
gnome-games: fix sdl in configure.ac
* gnome-games ships an older sdl.m4 macro which *sigh* modfiy the path in configure and prepend /usr to the path variable removing the sdl.m4 and use the one we ship original, solves the problem, problem occured while guile from hostsystem was draged in and linker bailed about wrong format, this was a side effect of the path-manipulation from the sdl.m4
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gnome/gnome-games_2.24.0.bb11
1 files changed, 2 insertions, 9 deletions
diff --git a/recipes/gnome/gnome-games_2.24.0.bb b/recipes/gnome/gnome-games_2.24.0.bb
index b4e7cf43c9..20221bd410 100644
--- a/recipes/gnome/gnome-games_2.24.0.bb
+++ b/recipes/gnome/gnome-games_2.24.0.bb
@@ -16,21 +16,14 @@ EXTRA_OECONF = "--with-libggz-includes=${STAGING_INCDIR} \
INTLTOOL_PERL=${STAGING_BINDIR_NATIVE}/perl \
"
+# disable help dir and crappy old sdl-macro
do_configure_prepend() {
+ rm m4/sdl.m4
for i in $(find ${S} -name "Makefile.am") ; do
sed -i -e s:help::g $i
done
}
-do_configure_append() {
- for i in $(find ${S} -name "Makefile") ; do
- sed -i \
- -e s:'-I/usr/include/SDL':'-I${STAGING_INCDIR}/SDL':g \
- -e s:'-I/usr/local/include/SDL':'-I${STAGING_INCDIR}/SDL':g \
- $i
- done
-}
-
# copy matchbox icons
do_install_append() {
install -m 0644 ${D}/${datadir}/icons/hicolor/48x48/apps/* ${D}/${datadir}/pixmaps