aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMelissa Watkins <mwatkins.ti@gmail.com>2010-12-13 21:19:48 +0000
committerKhem Raj <raj.khem@gmail.com>2010-12-13 22:30:39 -0800
commitd4e22bd830b3767b2b70700e690157ac73a3f632 (patch)
treeae89e79a1b3ce1921541848e2cbe5f78d6da6021 /recipes
parent209a538d3dfca464a9bc0dc4d189238de56fa20c (diff)
downloadopenembedded-d4e22bd830b3767b2b70700e690157ac73a3f632.tar.gz
ti-pru-sw-edma-driver: do not strip driver
* Added PACKAGE_STRIP = "no" so that the module will not be stripped and can be insmoded into the kernel. Failure to do so results in errors like: <module>: module has no symbols (stripped?) * Changed PR setting to key off changes to MACHINE_KERNEL_PR or the SRCREV of the module repository. * Updated SRC_REV. * Updated COMAPTIBLE_MACHINE Signed-off-by: Melissa Watkins <m-watkins@ti.com> Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb b/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb
index e315f8ef0c..b975d785e3 100644
--- a/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb
+++ b/recipes/ti/ti-pru-sw-edma-driver_1.00.00.bb
@@ -1,16 +1,18 @@
DESCRIPTION = "Builds eDMA module used by eDMA libraries for PRU sw example applications"
HOMEPAGE = "https://gforge.ti.com/gf/project/pru_sw/"
LICENSE = "GPLv2"
-PR = "r0+svnr${SRCPV}"
-COMPATIBLE_MACHINE = "omapl138|am180x-evm|am181x-evm"
+COMPATIBLE_MACHINE = "omapl138"
SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;proto=https;user=anonymous;pswd=''"
-SRCREV = "18"
+SRCREV = "20"
S = "${WORKDIR}/trunk/peripheral_lib/edma_driver/module"
+PACKAGE_STRIP = "no"
+
inherit module
+PR = "${MACHINE_KERNEL_PR}+svnr${SRCPV}"
do_install () {
install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/pru